Fun, Learning, Friendship and Mutual Respect
START  HERE


Unregistered
Go Back   HeliFreak > R/C Helicopter Support > Blade Helicopters (eFlite) > Blade 400


Blade 400 Blade Helicopters (eFlite) 400 Helicopters


Reply
 
Thread Tools Display Modes
Old 05-15-2008, 10:33 AM   #1
whoanelly
Registered Users
 
Posts: 5,418
 

Join Date: Apr 2008
Location: Central Ca
Question B400 Motor Help

Hey guys,,got a problem,,,i put those new black plastic blades on my bird and adjusted to 0 pitch at center then when i was flying it seemed really loud i couldnt tell if the noise was coming from the new blades or my engine,,but then i noticed the bird only stayed in the air for about a minute before the battery was dead,,not sure if my engine is blown or what..
whoanelly is offline        Reply With Quote
Old 05-15-2008, 10:37 AM   #2
LockMD
Registered Users
 
Posts: 3,184
 

Join Date: Oct 2007
Location: Concord, CA
Default

Quote:
Originally Posted by whoanelly View Post
Hey guys,,got a problem,,,i put those new black plastic blades on my bird and adjusted to 0 pitch at center then when i was flying it seemed really loud i couldnt tell if the noise was coming from the new blades or my engine,,but then i noticed the bird only stayed in the air for about a minute before the battery was dead,,not sure if my engine is blown or what..

Have you tried other batteries? by dead you mean needs charged or wont charge now?
LockMD is offline        Reply With Quote
Old 05-15-2008, 10:38 AM   #3
whoanelly
Registered Users
 
Posts: 5,418
Thread Starter Thread Starter
 

Join Date: Apr 2008
Location: Central Ca
Default

ya i tried 2 charged batterys,,,it just comes to the groung like the battery is dead.
whoanelly is offline        Reply With Quote
Old 05-15-2008, 10:39 AM   #4
skigolfmike
Registered Users
 
Posts: 1,997
 
My HF Map location
Join Date: Jan 2008
Location: Dayton, OH
Default

It's probably the blades. I got a set of E-Flite Blades and they were out of balance and, even after balancing, did run smooth at all. Check your blade tracking too.

Killing the battery in only a minute isn't right, there may be something else wrong too.
__________________
TRex700N, TRex600NP
Logo 400 VBar, Furion 450, Blade 400
Gooie 200 (2), CX2, mSR
AMA# 3066
skigolfmike is offline        Reply With Quote
Old 05-15-2008, 10:41 AM   #5
whoanelly
Registered Users
 
Posts: 5,418
Thread Starter Thread Starter
 

Join Date: Apr 2008
Location: Central Ca
Default

ya thats why i was wondering if my motor might be blown,but how would i tell.
whoanelly is offline        Reply With Quote
Reply




Unregistered
Go Back   HeliFreak > R/C Helicopter Support > Blade Helicopters (eFlite) > Blade 400


Blade 400 Blade Helicopters (eFlite) 400 Helicopters

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


Copyright © 2004-2011 - William James - Helifreak.com