Fun, Learning, Friendship and Mutual Respect
START  HERE


Unregistered
Go Back   HeliFreak > R/C Helicopter Support > Scale Helicopters


Scale Helicopters Discussions About Scale Helis, compatibility and and projects


Reply
 
Thread Tools Display Modes
Old 06-13-2008, 01:27 PM   #1
jaseyb1
Registered Users
 

Join Date: Mar 2008
Default Gutted!!!!!!!!!!

hi just put my 600e into the new align 500e fuze looks awesome got it up into the hover to check it out,had some vibration landed not much but it was there.so checked all nuts,bolts ,fixings all ok so checked paddles,blades for balance they were ok.went back hovered it again to try to locate what was wrong then it just feel apart the top mount broke away in side the fuze, which let the swash hit the cowl big mess phoned midland where i got it from not interested at all and they said funkey would not even look at it to be replaced i'm GUTTED!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!An y one else had a problem at all?
jaseyb1 is offline        Reply With Quote
Old 06-13-2008, 03:47 PM   #2
Buzzkill
 
My HF Map location
Join Date: Feb 2007
Location: Woodstock, IL
Default

That sucks man. Sorry to hear it.
Buzzkill is offline        Reply With Quote
Reply




Unregistered
Go Back   HeliFreak > R/C Helicopter Support > Scale Helicopters


Scale Helicopters Discussions About Scale Helis, compatibility and and projects

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


Copyright © 2004-2015 by RCGroups.com, LLC except where otherwise indicated. The HeliFreak.com logo is a trademark of RCGroups.com, LLC.