Fun, Learning, Friendship and Mutual Respect
START  HERE


Unregistered
Go Back   HeliFreak > R/C Helicopter Support > 600 Class Nitro Helicopters


600 Class Nitro Helicopters 600 Class Nitro Helicopters manufactured by Align, Tarot, SYMA, Airhog, Chaos, HK and similar.


Reply
 
Thread Tools Display Modes
Old 06-22-2008, 04:27 PM   #1
Helio Addict
Registered Users
 
Posts: 109
 
My HF Map location
Join Date: Jan 2007
Location: King William, VA - USA
Default Blades woofing, do I need a new swash?

OK, anytime I go inverted and backwards and am near 0 deg of pitch the blades vibrate violently and shake the whole heli. Just as soon as I start giving it pitch it smoothes out and things are fine. Could this be a swashplate issure? I have tried V-blades, CYB SB's and it is the same. I upgraded to metal blade grips also with no changes.
Helio Addict is offline        Reply With Quote
Old 06-22-2008, 05:23 PM   #2
Espeefan
Registered Users
 
Posts: 579
 

Join Date: Mar 2006
Location: Wisconsin, USA
Default

Maybe the dampeners are getting worn out, or maybe you upgraded to a harder style? I've heard some of the really stiff dampeners viberate pretty badly at the lower throttle settings. They tend to like higher head speeds.
__________________
-Nathan-

Align 600N Super Pro
Espeefan is offline        Reply With Quote
Old 06-22-2008, 07:47 PM   #3
fiveoboy01
Registered Users
 
Posts: 3,620
 
My HF Map location
Join Date: Sep 2007
Location: Waunakee, WI
Default

Yep, my guess is dampeners wearing out.
__________________
Bill - RWMAA #1009, AMA #805853

fiveoboy01 is offline        Reply With Quote
Old 06-22-2008, 08:55 PM   #4
latesleeper
Registered Users
 
Posts: 37
 

Join Date: Apr 2007
Location: Ohio
Default

Do you have any slop in the head? Double check the ball links. Seems that slop develops over time between old links and the mixing arms.
__________________
Align 700N
Align 600 NSP
Align Trex 500
latesleeper is offline        Reply With Quote
Old 06-23-2008, 03:14 AM   #5
invertmast
Registered Users
 
Posts: 3,329
 
My HF Map location
Join Date: Oct 2004
Location: North Port, FL
Default

Blade overspeed.. i bet your running way to high of a headspeed. i've seen this a few times before on a guys heli... it ended up self destructing in flight.
__________________
Comparf Eurosport
1/7 F-14D
Rave 450, scorpion -10, DS285MG, 3500G, Spartan, 4s 2200 outrage, 6100e, 350mm radix
lookin for another Vibe 50
invertmast is offline        Reply With Quote
Old 06-23-2008, 06:22 PM   #6
Helio Addict
Registered Users
 
Posts: 109
Thread Starter Thread Starter
 
My HF Map location
Join Date: Jan 2007
Location: King William, VA - USA
Default

I'm using the plastic sleeve insert in the head to help stiffen it up and I don't have any play other than the swash seems to have some play between the ball joint and the swash itself.
I'm not currently using a gov on this so maybe I am running too much headspeed. I do know she rocks so maybe I'm pushing her too hard. I have a multi gov sitting arround so I'll install that and see if it helps although when it happens the heli doesn't seem to have all that much headspeed. Thanks for your replies....I'll keep working on it.
Helio Addict is offline        Reply With Quote
Reply




Unregistered
Go Back   HeliFreak > R/C Helicopter Support > 600 Class Nitro Helicopters


600 Class Nitro Helicopters 600 Class Nitro Helicopters manufactured by Align, Tarot, SYMA, Airhog, Chaos, HK and similar.

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


Copyright © 2004-2011 - William James - Helifreak.com