Fun, Learning, Friendship and Mutual Respect
START  HERE


Unregistered
Go Back   HeliFreak > R/C Helicopter Support > Blade Helicopters (eFlite) > Blade 400


Blade 400 Blade Helicopters (eFlite) 400 Helicopters


Reply
 
Thread Tools Display Modes
Old 09-10-2008, 02:51 AM   #1
blazerk5
Registered Users
 

Join Date: Apr 2008
Default Trex V2 Tail Rotor

Is anyone using the trex v2 tail grips. I am getting massive vibes with the tail blades on.This is my second one also and the blades are balanced.
Looking it over, the slider links are not centered over the tail shaft with the stock balls. Maybe this is the problem? Do I need longer balls?
Thanks
Tim
blazerk5 is offline        Reply With Quote
Old 09-10-2008, 02:49 PM   #2
JOMAZQ
Registered Users
 
Posts: 308
 

Join Date: Feb 2008
Location: Rowland Heights, CA
Default

all the trex se v2 tails i've seen on a B400 are full tail assemblies.
JOMAZQ is offline        Reply With Quote
Old 09-10-2008, 07:40 PM   #3
blazerk5
Registered Users
Thread Starter Thread Starter
 

Join Date: Apr 2008
Default

Ok. What I just discovered was that the stock grips are now causing the same vibration. All of the parts are new from the boom back. Looks like I am now yet another person stuck with the dreaded tail vibes.
Tim
blazerk5 is offline        Reply With Quote
Old 09-10-2008, 10:53 PM   #4
JohnLund
Registered Users
 
Posts: 919
 

Join Date: Feb 2007
Location: Corpus Christi
Default

I've been running the Trex 450 tail hub, and blade grips for a while, nothing except a stronger tail. I ran it with the balls all the way in, and out just enough to make the links level, and never noticed any difference, or vibrations. Just put loctite on the balls so that they stay all the way in, because they will back themselves out until the links are level, though they won't come all the way but still, better safe than sorry.

__________________
(~)
JohnLund is offline        Reply With Quote
Old 09-11-2008, 07:37 PM   #5
blazerk5
Registered Users
Thread Starter Thread Starter
 

Join Date: Apr 2008
Default

John,
What trex tail is that. I went with the v2. My hub does not look as robust as your's.
Tim
blazerk5 is offline        Reply With Quote
Old 09-12-2008, 12:29 AM   #6
JohnLund
Registered Users
 
Posts: 919
 

Join Date: Feb 2007
Location: Corpus Christi
Default

Quote:
Originally Posted by blazerk5 View Post
John,
What trex tail is that. I went with the v2. My hub does not look as robust as your's.
Tim
It the original SE tail in gray.
__________________
(~)
JohnLund is offline        Reply With Quote
Reply




Unregistered
Go Back   HeliFreak > R/C Helicopter Support > Blade Helicopters (eFlite) > Blade 400


Blade 400 Blade Helicopters (eFlite) 400 Helicopters

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


Copyright © 2004-2015 by RCGroups.com, LLC except where otherwise indicated. The HeliFreak.com logo is a trademark of RCGroups.com, LLC.