View Single Post
Old 03-20-2011, 01:56 PM   #66 (permalink)
Witchouse
Registered Users
 

Join Date: Mar 2011
Default

Quote:
Originally Posted by Jaydawgx7 View Post
After reading through the manual for the mCP X, I found my problem, so I figured I'd post it for others in case they run into the same issue. I have no clue how it happened, but somehow my helicopter was in "computer transmitter mode." (see page 7 of the manual)

The binding procedure needs to be repeated as per page 7 (below)
1. Disconnect the flight battery from the helicopter.
2. Power of the TX
3. Connect the battery to the helicopter and wait at least 5 seconds (blue LED will flash quickly)
4. Hold down the trainer button and power on the radio (be ready to do the next step quickly)
5. After the TX LEDs flash twice, push the rudder stick fully to the left.
6. Release the trainer button while still holding left rudder
7. Once the LED on the heli goes to steady blue, release the rudder stick
8. Push the trainer button one more time
9. Disconnect the battery and power down the TX.
10. Turn on the TX, plug in the heli's battery and you should be good to go.
Thanks for the post on this,
Mine did the same thing after I binded my Tx with another Blade
Heli, then back to mCPx RTF it went into full negtive pitch.
I will try this today and i hope it works
I've had nothing but problems with it since I bought it last friday
My grips also blew apart on the 2nd day (the philips screw came undone)
It's alot to absorb for my first heli with all it's problems
I was so frustrated by mid week I ran out and bought the mCX2 BNF
Just to get in some practice with the controls
My LHS gave me a replacement heli on the spot but they are still
Learning about how to deal with all of it's problems to.
I guess I should of bought the mCx2 1st
We see how it goes today.
Witchouse is offline        Reply With Quote