View Single Post
Old 08-14-2011, 12:33 PM   #2 (permalink)
cruzroy
Registered Users
 
Posts: 2,345
Thread Starter Thread Starter
 
My HF Map location
Join Date: Mar 2010
Default another Quickie 18 video...updated settings

TO ALL NOOBS Mr JuanRodriguez is correct in all his statments....i just get a little excited to fly,,,i found some new bugs, ( glow igniter fell off and must be repaired), and yes i need to make a starter hole thru the canopy...But i just want to fly, and yes safty first,,HOLD THE HEAD, i know...already got wacked in the nose with the main blades...but while bleeding on my shirt...did not stop me from flying...my son helped this time holding 1 end of the blade, and i think the bird is still not perfect...but im working on it and i got another vid of new settings...i had way to much pitch (Pos 12) and 3/4 throttle....so now i have -3 to +10 and full throttle, wow big difference...thanks for all the help guys..

BUT i still have a problem with the gyro...takes off in HH and lands in rate mode ???????

also when i use throttle hold my Anti Rotation Washout Base Assembly
and swash move so far apart that the pin comes out and wont re-align when you turn it back down.....i dont know what radio funtion controls that....i need help with that???

ok here we go!!!

TO ALL NOOBS Mr JuanRodriguez is correct in all his statments....i just get a little excited to fly,,,i found some new bugs, ( glow igniter fell off and must be repaired), and yes i need to make a starter hole thru the canopy...But i just want to fly, and yes safty first,,HOLD THE HEAD, i know...already got wacked in the nose with the main blades...but while bleeding on my shirt...did not stop me from flying...my son helped this time holding 1 end of the blade, and i think the bird is still not perfect...but im working on it and i got another vid of new settings...i had way to much pitch (Pos 12) and 3/4 throttle....so now i have -3 to +10 and full throttle, wow big difference...thanks for all the help guys..

BUT i still have a problem with the gyro...takes off in HH and lands in rate mode ???????

also when i use throttle hold my Anti Rotation Washout Base Assembly
and swash move so far apart that the pin comes out and wont re-align when you turn it back down.....i dont know what radio funtion controls that....i need help with that???

ok here we go!!! i just want to say these are just opinions of a NOOB

quickie 18 new settings (13 min 43 sec)
]
cruzroy is offline        Reply With Quote