View Single Post
Old 02-10-2013, 07:22 PM   #2 (permalink)
Throttlebody
Registered Users
 

Join Date: Jan 2013
Default

Quote:
Originally Posted by Usman View Post
I am completly new to this forum and glad to be aboard.
I have a Blade SR and after setting up the settings with someone on the phone from Blade I went to go fly it a few times first time and all it wanted to do is naw its nose to the left. It flew alright for maybe four seconds then start spinning to the left alot. The tail fin broke. I went to fly it with a broken tail fin and still wanted to just naw its nose to the left after maybe flying alright in liftoff and for maybe 2 seconds. Just really confusing and fustrating to me. The rudder conrols are fine, and ruddering it to the right on the control helps soften up this malfunction but as soon as it lifts, it will go crazy nawing its nose to the left.
I hope someone has any suggestions for me. I'm thinking maybe I have to adjust the gain on the black box on the back of the helicopter where the red light comes on.
Also, is it easy to fix a slightly bent tail bloom?
Thanks soo much guys. All the tips and suggestions will really help me out. I am brand new and would absorb all the information i get. I would really like to start having fun with this bird as soon as possible ! Thank you very much !

If you give it a quick bump with throttle, does it want to spin. If so it could be a proportional gyro adjustment. You could also have your tail rotor on backwards or set too close to the tail motor mount screws, causing it to rub. Or, your tail motor is going bad.
Throttlebody is offline        Reply With Quote