Broken fan?? - HeliFreak
Fun, Learning, Friendship and Mutual Respect START  HERE


Unregistered
Go Back   HeliFreak > R/C Helicopter Support > 500 Class Electric Helicopters > RCDN 500 Nitro Conversion


RCDN 500 Nitro Conversion R/C Depot Hobbies RCDN 500 Nitro Conversion Kit Support


Reply
 
LinkBack Thread Tools Display Modes
Old 06-18-2009, 11:05 AM   #1 (permalink)
Registered Users
 
Posts: 6,510
 

Join Date: Apr 2007
Location: chicago
Exclamation Broken fan??

hey all, i flew the 500N for its first flights last week. good power, and a fun heli to beat around

im having problems with the fan however.. one blade flew off in flight on a test flight, then over the past weekend another flew out!!

i sent an email to flyhelisrus on Monday and still havnt gotten a response..?

just puttin this out there to check up on them fan blades, they seem pretty flimsy.
eightythree is offline        Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 06-18-2009, 02:02 PM   #2 (permalink)
Registered Users
 
Posts: 4,802
 

Join Date: Mar 2008
Default

See PM
BenHeli is offline        Reply With Quote Quick reply to this message
Old 06-18-2009, 02:21 PM   #3 (permalink)
Registered Users
 
Posts: 6,510
Thread Starter Thread Starter
 

Join Date: Apr 2007
Location: chicago
Default

thanks Ben
eightythree is offline        Reply With Quote Quick reply to this message
Old 06-19-2009, 06:28 PM   #4 (permalink)
Registered Users
 
Posts: 1,191
 

Join Date: Mar 2008
Location: Miami, Fl
Default

83 did you notice any vibration from running with 1 blade missing? As i had the starter nut come losse and lost a blade on start up but did not fly intil new fan came in. I did save a the fan.
__________________
Cheers, Glenn
Outrage Fusion 50 FBL SK720 12s Xera 4025-560,Kon.HV 80 ,JR8717,OR 9088 on 6v TP 6s 65c 3300's
Trex 700CHP FBL SK720 MX510,Kon HV 80, JR 8717,OR 9188, 6v, TP 6s 45c 4400's
Gernejr is offline        Reply With Quote Quick reply to this message
Old 06-22-2009, 02:00 PM   #5 (permalink)
Registered Users
 
Posts: 6,510
Thread Starter Thread Starter
 

Join Date: Apr 2007
Location: chicago
Default

no, actually no vibes came on.. even after the second blade flew off.

got my replacement fan in the post today. good customer service
eightythree is offline        Reply With Quote Quick reply to this message
Reply




Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the HeliFreak forums, you must first register.
Please enter your desired user name, your REAL and WORKING email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself. Use a real email address or you will not be granted access to the site. Thank you.
Email Address:
Location
Where do you live? ie: Country, State, City or General Geographic Location please.
Name and Lastname
Enter name and last name here. (This information is not shown to the general public. Optional)
Helicopter #1
Enter Helicopter #1 type and equipment.
Insurance
Please select your insurance company (Optional)
Helicopter #2
Enter Helicopter #2 type and equipment.
Helicopter #3
Enter Helicopter #3 type and equipment.
Helicopter #4
Enter Helicopter #4 type and equipment.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On




Copyright © Website Acquisitions Inc. All rights reserved.
 

SEO by vBSEO 3.6.1