O.S. 50 not starting!!!!!!!!! - HeliFreak
Fun, Learning, Friendship and Mutual Respect START  HERE


Unregistered
Go Back   HeliFreak > R/C Car and Truck Info and Support > Gas & Glow


Gas & Glow Gas and Glow R/C Cars


Reply
 
LinkBack Thread Tools Display Modes
Old 05-29-2011, 04:05 AM   #1 (permalink)
Registered Users
 

Join Date: May 2011
Location: Eufaula, Oklahoma
Default O.S. 50 not starting!!!!!!!!!

I am having a problem with my Heli engine not starting and don't know why. I have a great new glow plug that is glowing like no other, fresh fresh fuel, not flooded at all, and have 1.5 turns out on my adjustment screw. My heli was running awesome and I mean awesome, took not even a second to start it, and all the sudden it died in mid air and had to auto to land it in the street. I tried to start it again with no luck so I pulled the glow plug and plugged it in, and the glow plug was surely burnt out with no glow at all, so I replaced with Traxxis #3, guy at the hobby shop said it would work with extra washer due to its longness, and no luck. I gave up on the traxxis and put in a O.S. #8 that glows like a fireball. Its getting great fuel, great glow, and have good settings (as far as I know) on the carb. This is the first problem I have had, every time has fired right up no questions asked. I am getting a little frustrated with this issue and dont understand why it wont even act like its wanting to fire up after running so good. Not to mention the fact that it died in mid air and the glow plug was bad so a person should thing, "hmm, new glow plug and it will fire like new again".... apparently wrong again, turned that thing over seemed like 5,000 times and didn't even act like it wanted to fire when before fired right up within seconds no questions asked. I have only ran maybe a gallon and a half in this engine so is barely broke in and virtually brand new so I shouldn't have any problems. Please help.
ObsessedHeli is offline        Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 03-22-2012, 01:11 PM   #2 (permalink)
Registered Users
 

Join Date: Dec 2006
Location: New York
Lightbulb

Do you still have compression in your engine? Is it hard or easy to rotate the starter shaft?

I had the same thing happen to me last weekend. Flying and then engine die and auto down. I looked at the old plug (greg dry color),it was ran real lean. Crossed my fingers and installed new plug and it did not start. Check for compression by rotating the starter shaft and it was free turning . Came home and took engine apart, I have blown the engine. Need piston, ring and sleeve .

Btw, this is under the wrong section.
b.t.d.t. is offline        Reply With Quote Quick reply to this message
Reply

Tags
o.s. 50 help, o.s. 50 hyper, o.s. 50 not starting, os 50 hyper not starting




Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the HeliFreak forums, you must first register.
Please enter your desired user name, your REAL and WORKING email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself. Use a real email address or you will not be granted access to the site. Thank you.
Email Address:
Location
Where do you live? ie: Country, State, City or General Geographic Location please.
Name and Lastname
Enter name and last name here. (This information is not shown to the general public. Optional)
Helicopter #1
Enter Helicopter #1 type and equipment.
Insurance
Please select your insurance company (Optional)
Helicopter #2
Enter Helicopter #2 type and equipment.
Helicopter #3
Enter Helicopter #3 type and equipment.
Helicopter #4
Enter Helicopter #4 type and equipment.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On




Copyright © VerticalScope Inc. All rights reserved.
 

SEO by vBSEO 3.6.1