Swash issues - HeliFreak
Fun, Learning, Friendship and Mutual Respect START  HERE


Unregistered
Go Back   HeliFreak > R/C Helicopter Support > Miniature Aircraft Helicopters > MA Glow


MA Glow Miniature Aircraft Glow Helicopter Support Forum


Reply
 
LinkBack Thread Tools Display Modes
Old 09-26-2012, 04:54 PM   #1 (permalink)
Registered Users
 
Posts: 1,987
 

Join Date: Apr 2010
Location: Granbury, TX
Default Swash issues

This is my first setup on a Fury 55 (or any MA heli) and I see something I've not seen on any Align, Gaui or SAB setup.

This heli is being set up with the new Vbar Silver. The setup has gone smoothly as has all my previous Vbar setups. I have set 12.5 degrees collective and the required 8 degrees of cyclic. With these values, I am getting the swash to hit its end of travel ability when the collective is at mid stick once the setup mode is complete.

There is a noticeable click on the elevator servo and it is visibly straining to get to its full travel position when backwasrds cyclic is given at the midstick position. At either full up or down collective it doesn't hit the limit of the swash. All of the Vbar parameters (endpoint, subtrim, collective and cyclic values) are good.

It doesn't bind during either the collective or cyclic step during setup. I've read that the Vbar will use different throws during flight that are not the same as those used for the setup, but my concern is that it will try to over drive the swash in the air like I am seeing on the bench.

This will be setup as a sport flyer, with relatively tame agility values. I don't see that it will do any hard 3D type of maneuvers, so am I being overly concerned?
__________________
Logo 700, Logo 690SX, Logo 600SX, Goblin 700, Trex 700DFC, Gaui X7,
Trex600EFL Pro, Trex 600 ESP, Trex 500 ESP, DJI 550
Amain Team
Rep
rcflyerheli is offline        Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 01-29-2013, 06:15 AM   #2 (permalink)
Registered Users
 

Join Date: Feb 2011
Location: UK
Default Re: Swash issues

Getting this same issue with my Furion 6 using a 3GX.
Can't understand how anyone gets more than 7.5 deg cyclic movement in all directions, as the swash hits the main shaft. Very odd.
Might try a different swash on it and see how I get on.

Cheers


John
super is offline        Reply With Quote Quick reply to this message
Reply




Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the HeliFreak forums, you must first register.
Please enter your desired user name, your REAL and WORKING email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself. Use a real email address or you will not be granted access to the site. Thank you.
Email Address:
Location
Where do you live? ie: Country, State, City or General Geographic Location please.
Name and Lastname
Enter name and last name here. (This information is not shown to the general public. Optional)
Helicopter #1
Enter Helicopter #1 type and equipment.
Insurance
Please select your insurance company (Optional)
Helicopter #2
Enter Helicopter #2 type and equipment.
Helicopter #3
Enter Helicopter #3 type and equipment.
Helicopter #4
Enter Helicopter #4 type and equipment.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On




Copyright © VerticalScope Inc. All rights reserved.
 

SEO by vBSEO 3.6.1