Show us your Avantgarde - HeliFreak
Fun, Learning, Friendship and Mutual Respect START  HERE


Unregistered
Go Back   HeliFreak > R/C Helicopter Support > Beam > BEAM E6


BEAM E6 BEAM E6 Factory Support Forum


Reply
 
LinkBack Thread Tools Display Modes
Old 11-18-2012, 02:33 AM   #1 (permalink)
Registered Users
 
Posts: 784
 

Join Date: Jul 2009
Location: Vic. Australia
Default Show us your Avantgarde

Every other heli has a pic and vid thread so lets see those Avantgardes.

(pic of mine to follow as soon as its finished)
lowey79 is offline        Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 11-20-2012, 12:49 AM   #2 (permalink)
Registered Users
 

Join Date: Jul 2012
Location: greece
Default

i'll place pct of mine too
Dally7 is offline        Reply With Quote Quick reply to this message
Old 11-22-2012, 01:53 AM   #3 (permalink)
Registered Users
 

Join Date: Apr 2008
Default Happy owner Beam 600

This is my Beam 600 . Perfect machine!!


Uploaded with ImageShack.us
tiogus is offline        Reply With Quote Quick reply to this message
Old 01-03-2013, 07:30 AM   #4 (permalink)
Registered Users
 
Posts: 784
Thread Starter Thread Starter
 

Join Date: Jul 2009
Location: Vic. Australia
Default

Here's mine!



lowey79 is offline        Reply With Quote Quick reply to this message
Old 01-03-2013, 07:04 PM   #5 (permalink)
Registered Users
 

Join Date: Aug 2011
Location: Portugal
Default

Nice
This is one of my favourites 600 class helis, i would like to be able to get one in the future.

One detail on your Beam caught my eye, Lowey.
The gyro orientation could be stressing the cables or forcing to break the adhesive?
__________________
Lynx Heli Innovations Team Pilot
Logo 480, Warp 360 , Sport 360
T500 AP
PZ StrykerQ DX8
Luigi_tuga is online now        Reply With Quote Quick reply to this message
Old 01-04-2013, 06:44 AM   #6 (permalink)
Registered Users
 
Posts: 784
Thread Starter Thread Starter
 

Join Date: Jul 2009
Location: Vic. Australia
Default

It is a beautiful machine to fly! I'm not at the 3D stage yet, but it behaves perfectly in sport flying!

That picture angle makes it look worse than it is... But i have been meaning to split the wiring evenly out each side of the frames.

That said, my beam is the most locked in heli ive ever flown!
lowey79 is offline        Reply With Quote Quick reply to this message
Old 01-09-2013, 04:45 PM   #7 (permalink)
Registered Users
 
Posts: 802
 

Join Date: Aug 2011
Location: Halifax, United Kingdom
Default

There's not much to see yet, I just built the head in my lunch hour! I've been pleased with the small amount I've done so far.
Attached Thumbnails
Click image for larger version

Name:	IMG_0909.jpg
Views:	362
Size:	53.7 KB
ID:	382246  
__________________
Kasama UK | Bavarian Demon
wadders248 is online now        Reply With Quote Quick reply to this message
Old 01-10-2013, 06:48 AM   #8 (permalink)
Registered Users
 
Posts: 784
Thread Starter Thread Starter
 

Join Date: Jul 2009
Location: Vic. Australia
Default

Looking good wadders!

It really is an under rated heli that goes together well! And it's a dream to fly. Just hope we can get a parts supply soon!
lowey79 is offline        Reply With Quote Quick reply to this message
Old 01-10-2013, 06:06 PM   #9 (permalink)
Registered Users
 
Posts: 802
 

Join Date: Aug 2011
Location: Halifax, United Kingdom
Default

Thanks Lowey!

I thought I'd just build the tail section today, next thing I know and it's almost finished, apart from electrics.
Attached Thumbnails
Click image for larger version

Name:	photo.jpg
Views:	253
Size:	140.2 KB
ID:	382624  
__________________
Kasama UK | Bavarian Demon
wadders248 is online now        Reply With Quote Quick reply to this message
Old 01-13-2013, 12:22 AM   #10 (permalink)
Registered Users
 
Posts: 784
Thread Starter Thread Starter
 

Join Date: Jul 2009
Location: Vic. Australia
Default

I know what you mean. It just goes together very quickly, and the fit and finish of the parts is first rate!
lowey79 is offline        Reply With Quote Quick reply to this message
Old 01-15-2013, 05:19 AM   #11 (permalink)
Registered Users
 
Posts: 784
Thread Starter Thread Starter
 

Join Date: Jul 2009
Location: Vic. Australia
Default

So kits and parts are back in stock, so come on people... lets see those BEAM pics!
lowey79 is offline        Reply With Quote Quick reply to this message
Old 01-18-2013, 12:34 PM   #12 (permalink)
Registered Users
 
Posts: 802
 

Join Date: Aug 2011
Location: Halifax, United Kingdom
Default

The servo's are in... I think my kit has a v1 OWB, so good to hear that parts are plentiful as that will get replaced before I try and fly it.
Attached Thumbnails
Click image for larger version

Name:	IMG_0920.jpg
Views:	277
Size:	313.0 KB
ID:	385342   Click image for larger version

Name:	IMG_0923.jpg
Views:	429
Size:	315.6 KB
ID:	385343  
__________________
Kasama UK | Bavarian Demon
wadders248 is online now        Reply With Quote Quick reply to this message
Old 01-19-2013, 05:40 PM   #13 (permalink)
Registered Users
 
Posts: 784
Thread Starter Thread Starter
 

Join Date: Jul 2009
Location: Vic. Australia
Default

Looking good! Does the OWB run directly on the main shaft? The V2 has a sleeve that mounts to the shaft and a larger (stronger) OWB.
lowey79 is offline        Reply With Quote Quick reply to this message
Old 01-20-2013, 05:04 AM   #14 (permalink)
Registered Users
 
Posts: 802
 

Join Date: Aug 2011
Location: Halifax, United Kingdom
Default

Quote:
Originally Posted by lowey79 View Post
Looking good! Does the OWB run directly on the main shaft? The V2 has a sleeve that mounts to the shaft and a larger (stronger) OWB.
Mine is definitely a v1 then, I don't want to risk running it! Thanks for the description...
__________________
Kasama UK | Bavarian Demon
wadders248 is online now        Reply With Quote Quick reply to this message
Old 01-22-2013, 05:11 AM   #15 (permalink)
Registered Users
 
Posts: 784
Thread Starter Thread Starter
 

Join Date: Jul 2009
Location: Vic. Australia
Default

There's no reason you can't run the V1 set-up, just don't push it too hard with high headspeed and smack 3D.

I've put 10-15 flights through mine without issue.
lowey79 is offline        Reply With Quote Quick reply to this message
Old 02-15-2013, 02:26 AM   #16 (permalink)
Registered Users
 
Posts: 802
 

Join Date: Aug 2011
Location: Halifax, United Kingdom
Default

Most of the places I fly from are launched off grass and 95mm tail blades are pretty close to the ground. So I've had enough of cleaning the grass off the tail blades and stone chips. I've added a wedge between the rear landing gear and the frame to give it a bit more rake!

I know this is usless for doing any FBL unit setup, though I can always remove the wedge. I had originally planned to bend the landing gear, though it would be harder to get the heli level again.
Attached Thumbnails
Click image for larger version

Name:	IMG_0945.jpg
Views:	336
Size:	663.1 KB
ID:	394499  
__________________
Kasama UK | Bavarian Demon
wadders248 is online now        Reply With Quote Quick reply to this message
Old 02-21-2013, 10:24 PM   #17 (permalink)
Registered Users
 
Posts: 784
Thread Starter Thread Starter
 

Join Date: Jul 2009
Location: Vic. Australia
Default

I feel your pain! I'm contemplating doing the same thing!
lowey79 is offline        Reply With Quote Quick reply to this message
Old 02-22-2013, 07:50 AM   #18 (permalink)
Registered Users
 
Posts: 802
 

Join Date: Aug 2011
Location: Halifax, United Kingdom
Default

After the disaster of the stock landing gear disintegrating, I've moved to something a bit sturdier, which need the shim adding to increase the rake! I've also swapped to 92mm tails, which give a bit more clearance. Hopefully they'll have the same hold. After playing with the governor gain and Beastx settings, I was getting perfect hold with 14 of pitch

I'm also in the process of swapping to a carbon control rod for the tail. The stock tail rod kept rattling, which I was mistaking for the belt being too loose. I meant to order the Align 600E rod, though thought I'd get the 600N rod and cut it to suit, though you can't just cut and re-apply the metal end. I bet the 600E set would have been just perfect. Anyway, I've got some Quick UK rod ends coming. The boom guide will just need slotting a bit rather than the round hole it has now, then it should perfect.

I also added some quick release canopy buttons on slightly wider mounts to push the canopy out a bit more around the batteries. The buttons work really well, though they're a pain to fit. The canopy holes have to be opened and file down the thickness of the fiberglass to fit the grommets.

__________________
Kasama UK | Bavarian Demon
wadders248 is online now        Reply With Quote Quick reply to this message
Old 02-23-2013, 06:50 AM   #19 (permalink)
Registered Users
 

Join Date: May 2007
Location: Germany
Default

Hi Wadder,

nice you got your bird finished to take off again.

Landing skids are the Align now ?

I was wondering about another thing :

When i position my esc on the left frameside (under the maingear) the connectors to batterie go just next to the motor. Could be a bit nasty when they get in contact during flight.
Because of this i put my esc under the frame. Was going bad as i had to autorotate and it smacked hard onto the esc as the skid broke -> have to return the esc to service now.
Could you guys post a pic with connected esc to batterie ?

THX
Kalle
Kalle75 is offline        Reply With Quote Quick reply to this message
Old 02-23-2013, 12:43 PM   #20 (permalink)
Registered Users
 
Posts: 802
 

Join Date: Aug 2011
Location: Halifax, United Kingdom
Wink

Quote:
Originally Posted by Kalle75 View Post
Hi Wadder,

nice you got your bird finished to take off again.

Landing skids are the Align now ?

I was wondering about another thing :

When i position my esc on the left frameside (under the maingear) the connectors to batterie go just next to the motor. Could be a bit nasty when they get in contact during flight.
Because of this i put my esc under the frame. Was going bad as i had to autorotate and it smacked hard onto the esc as the skid broke -> have to return the esc to service now.
Could you guys post a pic with connected esc to batterie ?

THX
Kalle
Sad to hear another failed landing gear! My new ones aren't Align, they're more like the Gorilla skids. The heli is at work, so I'll get you details of the gear and a pic of the ESC on Monday. I've rotated the ESC so the cables aren't near the motor.

Was it cold when the skids failed? I think mine failed because the cold made them brittle. My flying buddy looked at me in disbelief when I landed then the blades started a dust storm!
__________________
Kasama UK | Bavarian Demon
wadders248 is online now        Reply With Quote Quick reply to this message
Reply




Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the HeliFreak forums, you must first register.
Please enter your desired user name, your REAL and WORKING email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself. Use a real email address or you will not be granted access to the site. Thank you.
Email Address:
Location
Where do you live? ie: Country, State, City or General Geographic Location please.
Name and Lastname
Enter name and last name here. (This information is not shown to the general public. Optional)
Helicopter #1
Enter Helicopter #1 type and equipment.
Insurance
Please select your insurance company (Optional)
Helicopter #2
Enter Helicopter #2 type and equipment.
Helicopter #3
Enter Helicopter #3 type and equipment.
Helicopter #4
Enter Helicopter #4 type and equipment.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On




Copyright © VerticalScope Inc. All rights reserved.
 

SEO by vBSEO 3.6.1