Fun, Learning, Friendship and Mutual Respect START  HERE


Unregistered
Go Back   HeliFreak > R/C Electronics Support > JR and Spektrum Radios and Electronics > 2.4G Spektrum Radios


2.4G Spektrum Radios Spektrum 2.4 Gigahertz Radios and Technology


Reply
 
LinkBack Thread Tools Display Modes
Old 10-15-2014, 04:13 AM   #101 (permalink)
Registered Users
 
Posts: 757
Thread Starter Thread Starter
 

Join Date: Nov 2008
Default

Can you indicate platform you are running on as i don't see these issues. Ok looks like a bug in the vario data
__________________
Trex 600N Pro with Vibe 50 Head and YS91RS motor, Vibe 50 VBar FBL, Trex744 VBar FBL MW44 Turbine, Logo 800 XXTreme, Logo 600 12s, Logo 500SE, Vario UH-1D (Building), Scratch built 625mm Quad.
kevinww is offline        Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 10-15-2014, 04:28 AM   #102 (permalink)
Registered Users
 

Join Date: Sep 2013
Default

Thanks for the update.
I have a small problem with it however.
If I open a tlm file, click the custom tab, and then untick a choice at the bottom (eg "L") the program closes.
I attach an example tlm file. Windows 7.
Attached Files
File Type: tlm 1st-slopesoar-okecamp-73mins.TLM (1.73 MB, 43 views)
__________________
DX9, Align Trex 450 Pro DFC, Blade 180cfx, Blade Nano cpx, Blade Msrx
venton is offline        Reply With Quote Quick reply to this message
Old 10-15-2014, 04:48 AM   #103 (permalink)
Registered Users
 
Posts: 757
Thread Starter Thread Starter
 

Join Date: Nov 2008
Default

There is a problem with files containing vario data in the Custom view, i'm looking at it.
__________________
Trex 600N Pro with Vibe 50 Head and YS91RS motor, Vibe 50 VBar FBL, Trex744 VBar FBL MW44 Turbine, Logo 800 XXTreme, Logo 600 12s, Logo 500SE, Vario UH-1D (Building), Scratch built 625mm Quad.
kevinww is offline        Reply With Quote Quick reply to this message
Old 10-15-2014, 04:49 AM   #104 (permalink)
Registered Users
 
Posts: 1,100
 

Join Date: Aug 2012
Default

Quote:
Originally Posted by kevinww View Post
Can you indicate platform you are running on as i don't see these issues. Ok looks like a bug in the vario data
Yup it is windows 7 ultimate 64bit.

I cleaned up my previous post, something happened when I edited it and it got messed up before.
BWX_ is offline        Reply With Quote Quick reply to this message
Old 10-15-2014, 08:18 AM   #105 (permalink)
Registered Users
 
Posts: 757
Thread Starter Thread Starter
 

Join Date: Nov 2008
Default Version 4.1 Available

Version 4.1 has been removed as a number of issues have been found.

Version 3.2 is still available here :-
https://www.helifreak.com/showpost.p...4&postcount=82

Kevin
__________________
Trex 600N Pro with Vibe 50 Head and YS91RS motor, Vibe 50 VBar FBL, Trex744 VBar FBL MW44 Turbine, Logo 800 XXTreme, Logo 600 12s, Logo 500SE, Vario UH-1D (Building), Scratch built 625mm Quad.

Last edited by kevinww; 10-16-2014 at 02:04 AM..
kevinww is offline        Reply With Quote Quick reply to this message
Old 10-15-2014, 08:47 AM   #106 (permalink)
Registered Users
 
Posts: 1,100
 

Join Date: Aug 2012
Default

Well those sames things don't make it crash.. but I found out another one that does.

On main screen on standard tab, I hit the temperature box, and the programmed crash, but that was the first run. I started it again and exited properly, then restarted, then I tried same thing again and it did not chase the program. I think it was because there was no file to write to yet? Not sure.

Also, on custom tab, I cannot get checked box settings to stick, are they supposed to?

Thanks!


-edit-
Well I spoke too some.. i just went back to program after it sat for a bit, went to custom tab and clicked on the one of the boxes below, I think it was "A", and program crashed. hmmm

I'll upload the files I am using..
Attached Files
File Type: tlm 010~10 Sail (2).TLM (704.3 KB, 45 views)
BWX_ is offline        Reply With Quote Quick reply to this message
Old 10-15-2014, 08:51 AM   #107 (permalink)
Registered Users
 
Posts: 757
Thread Starter Thread Starter
 

Join Date: Nov 2008
Default

Check boxes are not sticky as what's there depends on what other data present. I'll have a look at the standard telemetry
__________________
Trex 600N Pro with Vibe 50 Head and YS91RS motor, Vibe 50 VBar FBL, Trex744 VBar FBL MW44 Turbine, Logo 800 XXTreme, Logo 600 12s, Logo 500SE, Vario UH-1D (Building), Scratch built 625mm Quad.
kevinww is offline        Reply With Quote Quick reply to this message
Old 10-15-2014, 08:55 AM   #108 (permalink)
Registered Users
 
Posts: 1,100
 

Join Date: Aug 2012
Default

Oh ok.

I uploaded the file above but I had to make it a zip file because it was too big, then it wouldn't let me upload a zip file, so I renamed it to a TLM file.

Just change it to a .zip file and then unzip it. It will create a 3,824kb .TLM file.
BWX_ is offline        Reply With Quote Quick reply to this message
Old 10-15-2014, 08:59 AM   #109 (permalink)
Registered Users
 
Posts: 1,100
 

Join Date: Aug 2012
Default

Quote:
Originally Posted by kevinww View Post
Check boxes are not sticky as what's there depends on what other data present. I'll have a look at the standard telemetry
Oh ok..

What I am trying to accomplish is to get altitude and battery flight pack voltage together, and sticky on the custom tab (or any tab). (with sticky settings for color ad line thickness... and possibly to overlay temperature and other stuff if needed).
Attached Thumbnails
Click image for larger version

Name:	custom setup.jpg
Views:	169
Size:	58.4 KB
ID:	543027  
BWX_ is offline        Reply With Quote Quick reply to this message
Old 10-15-2014, 09:16 AM   #110 (permalink)
Registered Users
 
Posts: 757
Thread Starter Thread Starter
 

Join Date: Nov 2008
Default

It works the other way, you get all graphs overlayed in custom and then you switch off what you don't want to see. You cannot do what you trying to do and creat a new type of graph.
__________________
Trex 600N Pro with Vibe 50 Head and YS91RS motor, Vibe 50 VBar FBL, Trex744 VBar FBL MW44 Turbine, Logo 800 XXTreme, Logo 600 12s, Logo 500SE, Vario UH-1D (Building), Scratch built 625mm Quad.
kevinww is offline        Reply With Quote Quick reply to this message
Old 10-15-2014, 09:36 AM   #111 (permalink)
Registered Users
 
Posts: 1,100
 

Join Date: Aug 2012
Default

Quote:
Originally Posted by kevinww View Post
It works the other way, you get all graphs overlayed in custom and then you switch off what you don't want to see. You cannot do what you trying to do and creat a new type of graph.
Yeah that is what that is though.. just a custom telem tab..

Would be awesome if you gave option to be able to sticky those boxes ticked or not ticked somehow though.. Maybe with warning that if you tick a box that isn't part of current telem. file that it will mess things up? Not sure if that is the problem or not though. (I don't know what the limitation is, is what I meant)
Attached Thumbnails
Click image for larger version

Name:	custom telem tab.jpg
Views:	156
Size:	97.6 KB
ID:	543028  
BWX_ is offline        Reply With Quote Quick reply to this message
Old 10-16-2014, 11:34 AM   #112 (permalink)
Registered Users
 
Posts: 627
 

Join Date: Feb 2014
Default

It might be good to show the version number in the "About" box.
4_Props is offline        Reply With Quote Quick reply to this message
Old 10-16-2014, 01:19 PM   #113 (permalink)
Registered Users
 
Posts: 757
Thread Starter Thread Starter
 

Join Date: Nov 2008
Default

Version number should be in the about box.
__________________
Trex 600N Pro with Vibe 50 Head and YS91RS motor, Vibe 50 VBar FBL, Trex744 VBar FBL MW44 Turbine, Logo 800 XXTreme, Logo 600 12s, Logo 500SE, Vario UH-1D (Building), Scratch built 625mm Quad.
kevinww is offline        Reply With Quote Quick reply to this message
Old 10-17-2014, 09:09 AM   #114 (permalink)
Registered Users
 
Posts: 627
 

Join Date: Feb 2014
Default

Nope, maybe it's the screen resolution I run at 1920x1200. I can't drag and resize the box either.
Attached Thumbnails
Click image for larger version

Name:	Screenshot - 10_17_2014 , 9_54_40 AM.gif
Views:	163
Size:	30.3 KB
ID:	543363  
4_Props is offline        Reply With Quote Quick reply to this message
Old 10-17-2014, 04:33 PM   #115 (permalink)
Registered Users
 
Posts: 757
Thread Starter Thread Starter
 

Join Date: Nov 2008
Default

Defiantly there, you can see the start of the 3, looks like you are using large fonts, I'll increase the size of the field so its visible in your case.
__________________
Trex 600N Pro with Vibe 50 Head and YS91RS motor, Vibe 50 VBar FBL, Trex744 VBar FBL MW44 Turbine, Logo 800 XXTreme, Logo 600 12s, Logo 500SE, Vario UH-1D (Building), Scratch built 625mm Quad.
kevinww is offline        Reply With Quote Quick reply to this message
Old 10-17-2014, 11:12 PM   #116 (permalink)
Registered Users
 
Posts: 627
 

Join Date: Feb 2014
Default

Thanks
4_Props is offline        Reply With Quote Quick reply to this message
Old 10-20-2014, 03:17 AM   #117 (permalink)
Registered Users
 
Posts: 757
Thread Starter Thread Starter
 

Join Date: Nov 2008
Default Version 4.2 Available

Version 4.2 Available

This version is a major update to improve the graphing of data. The graphing code has had a complete overhaul so that any customizations made to Y axis properties such as colors names etc are now saved.
I've tested as much as i can with the files i have on hand, but odds are that there may be some anomalies, if you find any let me know.

Updates

New Functionality
1. Customizations to Y axis properties in graphs are now saved.
2. Changing the Y Axis selection filters on a graph no longer forces a complete graph redraw, so that all zooms etc are maintained.

Fixes
1. Fixes an issue where some selection filters could be missing in the custom graph.

Windows Version :-

http://boxhillheliclub.co.uk/wp-cont...etryReader.zip

MAC Version :-

http://boxhillheliclub.co.uk/wp-cont...eader.dmg_.zip

For install instructions see post #44
https://www.helifreak.com/showpost.p...9&postcount=44

Kevin
__________________
Trex 600N Pro with Vibe 50 Head and YS91RS motor, Vibe 50 VBar FBL, Trex744 VBar FBL MW44 Turbine, Logo 800 XXTreme, Logo 600 12s, Logo 500SE, Vario UH-1D (Building), Scratch built 625mm Quad.
kevinww is offline        Reply With Quote Quick reply to this message
Old 10-20-2014, 03:32 AM   #118 (permalink)
Registered Users
 
Posts: 1,100
 

Join Date: Aug 2012
Default

Thanks for update! I see no crashes and the settings seem to be remembered.
BWX_ is offline        Reply With Quote Quick reply to this message
Old 10-21-2014, 06:36 AM   #119 (permalink)
Registered Users
 

Join Date: Dec 2009
Default

I,

I have a problem with OSX Yosemite. JRE 7 isn't compatible with Yosemite and your soft is not compatible with JRE 8.

Many thanks.

Jc
godjc is offline        Reply With Quote Quick reply to this message
Old 10-21-2014, 06:44 AM   #120 (permalink)
Registered Users
 
Posts: 757
Thread Starter Thread Starter
 

Join Date: Nov 2008
Default

Its virtually impossible for me to cover every possibility, you could try JRE 6 as thats the lowest supported version of my code.

JRE 8 only supports 64 bit JRE on OSX whereas the code needs 32 bit JRE due to some native libraries used in the graphing, so it would require a separate build and test process for a 64 bit version, but I'll have a look.

After working with godjc on this issue, it turns out its an issue with java and Yosemite and Apple have released an updated JRE here :- http://support.apple.com/kb/DL1572?v...S&locale=en_US that resolves the problem.
__________________
Trex 600N Pro with Vibe 50 Head and YS91RS motor, Vibe 50 VBar FBL, Trex744 VBar FBL MW44 Turbine, Logo 800 XXTreme, Logo 600 12s, Logo 500SE, Vario UH-1D (Building), Scratch built 625mm Quad.

Last edited by kevinww; 10-23-2014 at 07:49 AM..
kevinww is offline        Reply With Quote Quick reply to this message
Reply




Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the HeliFreak forums, you must first register.
Please enter your desired user name, your REAL and WORKING email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself. Use a real email address or you will not be granted access to the site. Thank you.
Email Address:
Location
Where do you live? ie: Country, State, City or General Geographic Location please.
Name and Lastname
Enter name and last name here. (This information is not shown to the general public. Optional)
Helicopter #1
Enter Helicopter #1 type and equipment.
Helicopter #2
Enter Helicopter #2 type and equipment.
Helicopter #3
Enter Helicopter #3 type and equipment.
Helicopter #4
Enter Helicopter #4 type and equipment.

Log-in


Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On




Copyright © Website Acquisitions Inc. All rights reserved.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.

SEO by vBSEO 3.6.1