Throttle/Gov Issues - HeliFreak
Fun, Learning, Friendship and Mutual Respect START  HERE


Unregistered
Go Back   HeliFreak > R/C Electronics Support > 3Digi FBL System


3Digi FBL System 3Digi Supoort


Reply
 
LinkBack Thread Tools Display Modes
Old 08-04-2017, 09:18 PM   #1 (permalink)
Registered Users
 
Posts: 214
 

Join Date: Mar 2011
Location: York, Pa
Default Throttle/Gov Issues

Set up is as follows. G380, HW60amp Plat. ESC, Ar7700Rx and of course 3DIGI.

My problem is the Heli will not spool upon coming off 0% throttle. It will not engage motor until ~50% throttle. At that point, I can keep going to 100% throttle/motor speed. I have set the end points to -100/100 in the terminal configuration using endpoint adjustment on the radio. I swear it was the ESC not knowing the proper endpoints. I did that dozen of times with no effect. I have hooked the esc/motor to my tried and true 700 FBL and without changing a thing the motor spooled as it should.

Live data shows that at -14 endpoint (45-50% throttle) is when spooling starts. This wouldn't bother me as I never stay in "normal" mode anyway. I always immediately idle up to governed head speeds that I have set.

My other dilemma is the gov will not engage. I did have to change the sensor pull up mode to read correctly. Seems to be accurate all the way through. I have activated the gov in the parameters menu and also set a throttle input activation point in the config menu.

I am new to 3digi, I am hoping it is just something that I am missing in the setup. Any help would be greatly appreciated.
__________________
Goblin 700c, Goblin 380, Blade 450x
raptorJoe is offline        Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 08-05-2017, 03:48 AM   #2 (permalink)
Registered Users
 

Join Date: Jul 2006
Location: Germany, Froendenberg
Default

Hi Joe,
please make a short test.
Use a linear throttle curve on your transmitter and deactivate 3Digi gov.
At which throttle position does the motor start?

Maybe the endpoints of your ESC are not set correctly?!

You can also check the flightdata. Especially have a look at the governor throttle output, the rotor RPM and the eventlog messages,
__________________
Best regards

Dirk
www.3digi.de
DirkS is offline        Reply With Quote Quick reply to this message
Old 08-06-2017, 11:00 PM   #3 (permalink)
Registered Users
 
Posts: 214
Thread Starter Thread Starter
 

Join Date: Mar 2011
Location: York, Pa
Default

I think I figured it out. It is as simple as programming the ESC. I will have the ability to program the ESC tomorrow. Looking at the default settings of the ESC, HW ESC's do not initiate spool up until 40% when in gov mode. That makes sense now. I am going to start over once I have the ability to program the ESC.

I am new to electric. I have always used nitro for everything.
__________________
Goblin 700c, Goblin 380, Blade 450x
raptorJoe is offline        Reply With Quote Quick reply to this message
Old 08-07-2017, 07:17 PM   #4 (permalink)
Registered Users
 
Posts: 214
Thread Starter Thread Starter
 

Join Date: Mar 2011
Location: York, Pa
Default

I figured out why it wouldn't start until 40%. That is how the gov works within the esc. I have changed the setting of the esc to linear throttle. It now spools as it should. I set the gov up within the terminal. But I can't get the gov to activate. The rpm reads but the gov is not active. I have set a straight curve of 80% throttle in the transmitter and used the "use current" button in the terminal as the activation point.

I can't make any sense of what the "throttle output position does and what it should be set at. I have been setting it the same as the activation.

__________________
Goblin 700c, Goblin 380, Blade 450x
raptorJoe is offline        Reply With Quote Quick reply to this message
Old 08-08-2017, 09:13 AM   #5 (permalink)
Registered Users
 

Join Date: Jul 2006
Location: Germany, Froendenberg
Default

Hi,
the field Throttle output low position indicates the minimum gas value that the governor can output during operation. This is also the throttle position at which the governor soft start begins, when starting from standstill.

If you are using an electro heli, the position should be slightly below the position where the motor starts


Please have a look at the help texts at the right side of the Terminal. There are many explanations and tips.
The above text is actually copied from there.
__________________
Best regards

Dirk
www.3digi.de
DirkS is offline        Reply With Quote Quick reply to this message
Old 08-08-2017, 12:22 PM   #6 (permalink)
Registered Users
 
Posts: 214
Thread Starter Thread Starter
 

Join Date: Mar 2011
Location: York, Pa
Default

The boxes turn yellow when I enter a value that is lower then the activation value. I have tried it anyway and I still am not able to activate the gov.
__________________
Goblin 700c, Goblin 380, Blade 450x
raptorJoe is offline        Reply With Quote Quick reply to this message
Old 08-09-2017, 05:57 AM   #7 (permalink)
Registered Users
 

Join Date: Jul 2006
Location: Germany, Froendenberg
Default

It turns yellow because in electric helicopters the activation position should be set just below the output low position.
Thatīs again taken from the manual.

Maybe attach a flightlog of one of your start attemps here so that we can have a look at it.
__________________
Best regards

Dirk
www.3digi.de
DirkS is offline        Reply With Quote Quick reply to this message
Old 08-14-2017, 11:24 PM   #8 (permalink)
Registered Users
 
Posts: 214
Thread Starter Thread Starter
 

Join Date: Mar 2011
Location: York, Pa
Default

I have since figured out what I was doing wrong. One of those times where you over analyze and miss the simple point.
__________________
Goblin 700c, Goblin 380, Blade 450x
raptorJoe is offline        Reply With Quote Quick reply to this message
Reply




Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the HeliFreak forums, you must first register.
Please enter your desired user name, your REAL and WORKING email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself. Use a real email address or you will not be granted access to the site. Thank you.
Email Address:
Location
Where do you live? ie: Country, State, City or General Geographic Location please.
Name and Lastname
Enter name and last name here. (This information is not shown to the general public. Optional)
Helicopter #1
Enter Helicopter #1 type and equipment.
Insurance
Please select your insurance company (Optional)
Helicopter #2
Enter Helicopter #2 type and equipment.
Helicopter #3
Enter Helicopter #3 type and equipment.
Helicopter #4
Enter Helicopter #4 type and equipment.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On




Copyright © Website Acquisitions Inc. All rights reserved.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2018 DragonByte Technologies Ltd.
 

SEO by vBSEO 3.6.1