180CFX advanced settings including DX6i - Page 2 - HeliFreak
Fun, Learning, Friendship and Mutual Respect START  HERE


Unregistered
Go Back   HeliFreak > R/C Helicopter Support > Blade Helicopters (eFlite) > 180CFX


180CFX Blade 180CFX Helicopters Information and Help


Reply
 
LinkBack Thread Tools Display Modes
Old 02-24-2015, 01:30 PM   #21 (permalink)
Registered Users
 

Join Date: May 2014
Location: Canada
Unhappy Servo Centering Menu 180 cfx and Dx6i Issue

Hi everyone,

Its been quite a while since I've been needing to come on here just mending from a couple surgeries.

Anyways I just picked up a 180 cfx. Intially test flight out of the box was decent. Drifted to the left a bit. I've been trying to enter servo centering mode on my Dx6i by holding the TRAINER switch and BOTH sticks to outside bottom corners. It beeps twice and light is solid but the swash plate dips all the way down to the left. I cannot select or adjust servos nor bring the swash plate up to level even with full right cyclic. Any idea what is happening or what mode i'm going into? Starting the bird up normally results in a close to level swash plate and reasonable flight (everything working). I should also mention that the motor will start up in the odd mode unless I have TH on. Tried disconnecting the 3 wires underneath for safe setup (disconnect motor) but no start at all. Sorry about the newbie questions and hope someone can help.

Thank you
IcedHeli is offline        Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 02-24-2015, 07:14 PM   #22 (permalink)
Registered Users
 
Posts: 431
 

Join Date: Dec 2011
Location: Spain, Las Palmas
Default

Quote:
Originally Posted by IcedHeli View Post
Hi everyone,

Its been quite a while since I've been needing to come on here just mending from a couple surgeries.

Anyways I just picked up a 180 cfx. Intially test flight out of the box was decent. Drifted to the left a bit. I've been trying to enter servo centering mode on my Dx6i by holding the TRAINER switch and BOTH sticks to outside bottom corners. It beeps twice and light is solid but the swash plate dips all the way down to the left. I cannot select or adjust servos nor bring the swash plate up to level even with full right cyclic. Any idea what is happening or what mode i'm going into? Starting the bird up normally results in a close to level swash plate and reasonable flight (everything working). I should also mention that the motor will start up in the odd mode unless I have TH on. Tried disconnecting the 3 wires underneath for safe setup (disconnect motor) but no start at all. Sorry about the newbie questions and hope someone can help.

Thank you
Hi,

You don't need to hold the trainer switch.

1) power on your TX
2) plug the lipo to your heli
3) almost directly after you plugged the lipo to your heli you hold your throttle stick to the down left corner and cyclic to down right corner untill your swash moves.
4) let go of the sticks and you are in servo centering mode.
Now you can select the servo you want to adjust by moving cyclic to the right and to actually adjust it you need to move cyclic forward or backward.

If your done adjusting the servos you move throttle to bottom left corner and the heli will do some beeping and you are ready to fly

Hope I've been of some help
timox72 is offline        Reply With Quote Quick reply to this message
Old 02-24-2015, 08:22 PM   #23 (permalink)
Registered Users
 

Join Date: May 2014
Location: UK
Default Advanced 180 CFX settings and DX18 G2

Recently I updated my DX18 G2 to the latest software.1.03. Which was released last friday.
The tail on my 180 CFX has a bit of a tail wag on opening the throttle quickly.
So I wanted to increase the Gain on the tail and also Decrease the sensitivity on the elevator.
However when trying to enter the advanced settings with my DX18 G2 it says "no slave" on the screen. But will not enter the advanced setting screen in the flight log.
Just to make shore I am doing it correctly.
Both sticks to bottom right then press the bind button

Do I have to have certain amounts of throw settings on the throttle, pitch, elevator and ailerons. IE do I need 100% throws.

Thanks

Pete
__________________
130X,,130X Redbull, 300cfx, Trex 450V2, Trex Dominator 6S, Trex 500 Seahawk
Petebarrow is offline        Reply With Quote Quick reply to this message
Old 02-25-2015, 09:21 PM   #24 (permalink)
Registered Users
 

Join Date: Mar 2012
Location: The FBI van outside your house
Default

Iced Heli-you do not need to level your swash in advanced modes. Mine was off level out of the box a few turns. Fixed it mechanically, flew perfectly level after that...
Vincenza V is offline        Reply With Quote Quick reply to this message
Old 04-28-2015, 02:03 PM   #25 (permalink)
Registered Users
 

Join Date: Dec 2014
Location: Fairbanks, Alaska
Default

I bought a 180 CFX used. It was in good shape. I am a newer pilot and managed to hover it and fly it in close fairly well. Had a minor event. Changed a cyclic servo. Used servo mods on cyclic servos. Then crashed the bird tail down when I let it get too far from me, broke tail boom, TT, TT gear, and tail servo. Got it back together, but TT not engaging under load. That is not the point of this reply, though.

While working on the tail I also broke the ears off a cyclic servo. I took the frame apart to change the plugs on the cyclic and the tail servo. Now I need to center the cyclic servos. I use a new DX6. I have the advanced settings. I have watched James' video doing it with a DX9, I think. He says you need 7 channels or more. He pushes a bind button. The advanced settings manual says it can be done with a DX6 without depressing the bind button. Are they talking about the "old" DX6 or the new? I follow the advanced instruction settings. I think it works for getting into the servo setting mode, but I can't isolate or adjust any servo. In this mode the port servo horn points almost straight down. I move the cyclic to the right and both forward servos jump, which makes sense if one servo is so far out of whack its movement has a corresponding movement on its opposite number. But I don't get any adjustment, on any servo, by bumping the pitch stick up or down. I don't know what I am doing wrong. Any ideas?

I see talk about firmware updates. I don't have clue what firmware came with the bird. How can I tell? If I need to upgrade firmware I guess I will need to buy a cable. I would like to avoid that if possible.

This bird was fun for about 6 batteries. Any suggestions are welcome.

Regards,

Mike
IcySwan1 is offline        Reply With Quote Quick reply to this message
Old 01-11-2017, 10:34 AM   #26 (permalink)
Registered Users
 

Join Date: May 2010
Location: Australia
Default 180cfx / DX8 - Telemetry screen empty?

Hi all, I just bought a second hand 180CFX and have set it up exactly as the manual states , then bound to my DX8.

The heli currently fly's terrible with absolutely no tail authority, and major cyclic bobbling even in a hover. In fact it is so loose and disconnected, I have not even tried to do any 3D with it yet.

I tried to up the tail gyro gain from 75 steadily all the way up to 95 chasing a tail wag that I could then back off and have some authority ... this made absolutely no difference to how badly the heli still flew. No change whatsoever.

It is like I have no working gyro?

My DX8 is running AUX2 in trainer and is reversed in servo setup .. I can actually see it (supposedly) working in the monitor screen (switching between -100 and 100 when I push the trainer button), however if I attempt to enter Advanced Programming mode, the swash flicks, then I go to the Flight Log screen and I have no values in the screen?
I get:
FLIGHT LOG
A: ----
B: ----
L: ----
R: ----
and so on ...
I cannot get any values to show up, so I am unable to program anything?

My DX8 is running the latest firmware v3.01.

I know there is a firmware update available for the 180cfx which allows saving settings after you have made changes, but shouldn't I at least be able to see the values in the Flight Log screen?

I don't want to spend (waste) more money buying a USB cable to do a firmware update if this heli is not going to communicate with my DX8 first.

If anyone has any suggestions on how I can get this 180cfx to communicate properly with my DX8 so that I can validate spending more money on this thing, I would really appreciate it.

First impressions of this heli ... Not positive. Look forward to being able to change that and enjoy it (hopefully).

Thanks
orbit is offline        Reply With Quote Quick reply to this message
Old 01-11-2017, 01:03 PM   #27 (permalink)
Registered Users
 
Posts: 2,731
 

Join Date: Nov 2012
Location: UK
Default

Is it second gen dx8? The first gen has no telemetry with the 180cfx. Also if it's 2nd hand could be mechanical errors causing the issues. Worn bearings, bentbfeqther shaft etc etc etc.
__________________
Oxy 2 FE x 2, 180cfx full Rakon uBrain v2 BA-8-1 cyclic H0988UHS tail, 180cfx spartan lynx pro tail, 130 full rotary bx, 130 Xtreme build, 130x stock, nano cpx dbl bl, nano cpx wild bl, DX8, Phoenix sim for practice. For fpv Phantom 3 pro.
Bhujang is offline        Reply With Quote Quick reply to this message
Old 01-11-2017, 08:20 PM   #28 (permalink)
Registered Users
 

Join Date: May 2010
Location: Australia
Default

Quote:
Originally Posted by Bhujang View Post
Is it second gen dx8? The first gen has no telemetry with the 180cfx. Also if it's 2nd hand could be mechanical errors causing the issues. Worn bearings, bentbfeqther shaft etc etc etc.
I have had my DX8 for a few years, so I guess it is a Gen1.
However, there are heaps of Gen1 DX8's on youtube that are getting Telemetry, but for some reason mine shows empty values on the flight log, and I dont know why? ..Never used telemetry before, so is there a hidden setting in the DX8 that I need to turn on to get the flight log to read the values? .. Or is the Receiver in this 180CFX heli faulty?

Thanks
orbit is offline        Reply With Quote Quick reply to this message
Old 06-16-2017, 04:58 PM   #29 (permalink)
Registered Users
 

Join Date: Feb 2017
Location: CT, usa
Default

I just wanted to add a bit of knowledge gained here after googling, and searching several forums without a clear solution.

Problem: I could not get my 180 cfx into servo centering mode using my dx6i, tried a number of things; calibrating, setting up a new model, I even borrowed a dx6 from a buddy, no dice.

Solution: Update the firmware. After updating to 1.53 I was able to enter servo centering mode first shot. Previous software was 1.4X.

I hope this saves someone some hair pulling or internet searching.
__________________
MCX2 (dead) ~ V977 ~ 180CFX~ nano QX
the tech is offline        Reply With Quote Quick reply to this message
Old 08-30-2017, 07:31 PM   #30 (permalink)
Registered Users
 

Join Date: Jan 2008
Location: waterbury ct
Default servo centering issue

heres my issue i recently just swapped out my stock servo's one crapped out so i purchased blue arrow d0313's i turned the ar6335 180 degrees as instructed in the directions i took it for a test flight everything seem ok just some shaking so i asked a question in another post and they say i have to adjust my pid gains so i watched some vidoes on how to do it for the life of me i can not get it to work i cant even get the center servo to work anymore with these servo's im useing a dx9 it workd fine (servo centering ) with the stock servo's any fix to this issue??
BLAZE86DUBZ is online now        Reply With Quote Quick reply to this message
Reply




Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the HeliFreak forums, you must first register.
Please enter your desired user name, your REAL and WORKING email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself. Use a real email address or you will not be granted access to the site. Thank you.
Email Address:
Location
Where do you live? ie: Country, State, City or General Geographic Location please.
Name and Lastname
Enter name and last name here. (This information is not shown to the general public. Optional)
Helicopter #1
Enter Helicopter #1 type and equipment.
Insurance
Please select your insurance company (Optional)
Helicopter #2
Enter Helicopter #2 type and equipment.
Helicopter #3
Enter Helicopter #3 type and equipment.
Helicopter #4
Enter Helicopter #4 type and equipment.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On




Copyright © VerticalScope Inc. All rights reserved.
 

SEO by vBSEO 3.6.1