Fun, Learning, Friendship and Mutual Respect START  HERE


Unregistered
Go Back   HeliFreak > R/C Helicopter Support > Blade Helicopters (eFlite) > Blade 250 CFX



Reply
 
LinkBack Thread Tools Display Modes
Old 12-28-2017, 12:54 PM   #1 (permalink)
Registered Users
 

Join Date: Aug 2015
Default Trim Flight Again?

Hi all. Iím struggling to get my head around the stability setting on this thing.
Ive done a trim flight, and the Heli was fine. Rock solid. Next time I go to fly and its all over the place in stability. If the the Heli is not perfectly level when i connect the battery, then it will drift off. Therefore whatís the point of the trim flight in the first place, if the damn thing re-calibrates every time i connect a new battery.
My flying field is level(ish) but the slightest slope and the Heli drifts.
Yes Iíve done the trim flight by the book and locked in the settings afterwards.
Any help is much appreciated.
HNY.
Drummerman is offline        Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 12-29-2017, 11:56 AM   #2 (permalink)
Registered Users
 
Posts: 730
 

Join Date: Jan 2013
Default

Quote:
Originally Posted by Drummerman View Post
Hi all. Iím struggling to get my head around the stability setting on this thing.
Ive done a trim flight, and the Heli was fine. Rock solid. Next time I go to fly and its all over the place in stability. If the the Heli is not perfectly level when i connect the battery, then it will drift off. Therefore whatís the point of the trim flight in the first place, if the damn thing re-calibrates every time i connect a new battery.
My flying field is level(ish) but the slightest slope and the Heli drifts.
Yes Iíve done the trim flight by the book and locked in the settings afterwards.
Any help is much appreciated.
HNY.
I have never done 1 trim flight on mine and it will fly hands off , however I do initiate on a level surface always , let me try to initiate on the trunk of my car that has a slight slope and see what mine does ...
ks9818 is offline        Reply With Quote Quick reply to this message
Old 12-31-2017, 05:25 PM   #3 (permalink)
Registered Users
 

Join Date: Jan 2014
Default Let me throw this out there.....

if you hit throttle hold after a trim flight, the FBL will NOT save the settings/data it acquired during the flight. If this is the case, after your flight, land in stability mode. Set your radio where it cannot be touched, walk over to the heli and remove the canopy, disconnect battery.

Then...... reverse these steps and it should be saved and stable as a rock! Good Luck and keep us posted. We'll figure it out eventually!

Forgot to add, while I prefer to setup and take off on a perfectly level surface, it has been mentioned by Blade support that the heli can be up to 15į angle and still initiate correctly.
Bill_Van is offline        Reply With Quote Quick reply to this message
Old 01-01-2018, 01:46 PM   #4 (permalink)
Registered Users
Thread Starter Thread Starter
 

Join Date: Aug 2015
Default

Thanks for taking the time to try and help me out.
I am fairly certain I locked in the settings after the trim flight. ie Didn’t use Hold but did hit bind and saw the swash do its thing.
My field may not be perfectly level but its certainly less than 15deg.
I’ll give it another go whenever this rotten weather improves. Had horizontal rain since before Xmas.
Drummerman is offline        Reply With Quote Quick reply to this message
Old 01-05-2018, 05:09 AM   #5 (permalink)
Registered Users
Thread Starter Thread Starter
 

Join Date: Aug 2015
Default

Ok guys. Tried it again this morning. Indoors off a nice flat floor. Trim flight done and locked all settings in. Flew again and it was solid in Agility or Stability mode. Hands off hover no problem. Thought I’d cracked it. After about 2mins in Stability mode it started to drift off needing increasing amounts of forward input to keep it level. After about 3 mins I needed half control input to hold it. It’s like its losing its reference for level as the flight goes on. Any ideas?
Drummerman is offline        Reply With Quote Quick reply to this message
Reply




Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the HeliFreak forums, you must first register.
Please enter your desired user name, your REAL and WORKING email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself. Use a real email address or you will not be granted access to the site. Thank you.
Email Address:
Location
Where do you live? ie: Country, State, City or General Geographic Location please.
Name and Lastname
Enter name and last name here. (This information is not shown to the general public. Optional)
Helicopter #1
Enter Helicopter #1 type and equipment.
Helicopter #2
Enter Helicopter #2 type and equipment.
Helicopter #3
Enter Helicopter #3 type and equipment.
Helicopter #4
Enter Helicopter #4 type and equipment.

Log-in


Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On




Copyright © Website Acquisitions Inc. All rights reserved.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.

SEO by vBSEO 3.6.1