Fun, Learning, Friendship and Mutual Respect START  HERE


Unregistered
Go Back   HeliFreak > R/C Helicopter Support > Goblin 280


Goblin 280 SAB Heli Division - Goblin 280 Helicopters


Like Tree1Likes
  • 1 Post By jbobb1
Reply
 
LinkBack Thread Tools Display Modes
Old 02-01-2018, 06:13 PM   #1 (permalink)
Registered Users
 

Join Date: Dec 2007
Default Brain2 swashplate compensate in opposite

Hi!

Just got a new Fireball with MSH Brain2. I basically get everything in place, swashplate, pitch, tail.....but except the elevator compensation is in opposite direction, when I tilt the helicopter forward the swashplate moves forward to compensate.

Is there any setting in the Brain app can reverse this compensation? Or if I'm overlooked for some simple issue?

I'm using a DX6 with a DSMX satellite receiver.

Any hint will be greatly appreciated!
copo is offline        Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 02-01-2018, 06:15 PM   #2 (permalink)
Registered Users
Thread Starter Thread Starter
 

Join Date: Dec 2007
Default

Some setup photo....
Attached Thumbnails
Click image for larger version

Name:	20180202_074126_1517530458980.jpg
Views:	48
Size:	39.4 KB
ID:	736497   Click image for larger version

Name:	Screenshot_20180201-105334_1517530486884.jpg
Views:	41
Size:	34.6 KB
ID:	736499  
copo is offline        Reply With Quote Quick reply to this message
Old 02-01-2018, 10:32 PM   #3 (permalink)
Registered Users
 
Posts: 3,846
 

Join Date: Apr 2016
Location: USA
Default

Quote:
Originally Posted by copo View Post
Hi!

Just got a new Fireball with MSH Brain2. I basically get everything in place, swashplate, pitch, tail.....but except the elevator compensation is in opposite direction, when I tilt the helicopter forward the swashplate moves forward to compensate.

Is there any setting in the Brain app can reverse this compensation? Or if I'm overlooked for some simple issue?

I'm using a DX6 with a DSMX satellite receiver.

Any hint will be greatly appreciated!
Yes. Just go back and read everything in the gray, left hand panels WORD FOR WORD. You missed a setup step.
Thickfog is online now        Reply With Quote Quick reply to this message
Old 02-01-2018, 10:42 PM   #4 (permalink)
Registered Users
 

Join Date: Apr 2017
Location: Dallas,TX
Default

go to transmitter setup in software and do an elevator stick input with your radio to see if it sees it opposite, if so reverse the servo from your radio.
mychale01 is offline        Reply With Quote Quick reply to this message
Old 02-02-2018, 07:16 PM   #5 (permalink)
Registered Users
 
Posts: 3,846
 

Join Date: Apr 2016
Location: USA
Default

Quote:
Originally Posted by mychale01 View Post
go to transmitter setup in software and do an elevator stick input with your radio to see if it sees it opposite, if so reverse the servo from your radio.
Not a full solution. Flybar unit response is separate from stick response. He missed (and maybe on a few channels) proper tx setup on the tx panel.

After he gets that right he'll need to redo flybar unit response to get everything correct. If he only adjusts the tx at this stage things may not work.
Thickfog is online now        Reply With Quote Quick reply to this message
Old 02-02-2018, 08:10 PM   #6 (permalink)
Registered Users
 
Posts: 4,624
 

Join Date: Sep 2012
Location: Springfireld,Ohio
Default

Do a factory reset and start from scratch. You're better off!
Thickfog likes this.
jbobb1 is offline        Reply With Quote Quick reply to this message
Old 02-03-2018, 03:28 AM   #7 (permalink)
Registered Users
 

Join Date: Feb 2014
Location: Netherlands
Default

Most likely you didn't setup the channel check, servo reversing or unit orientation correctly (in the brain, not in the tx).

The only step where tot have to change transmitter settings are at the first tab in the brain software with all the channel sliders. They have to move the right way and 100%. The rest is all done in the Brain, including channel reversing and even throttle calibration.

Indeed carefully reed the texts on the left.
floriske.nl is offline        Reply With Quote Quick reply to this message
Old 02-03-2018, 04:28 AM   #8 (permalink)
Registered Users
Thread Starter Thread Starter
 

Join Date: Dec 2007
Default

Thanks everybody, I have go through the setup again and now it looks good! Thanks!
copo is offline        Reply With Quote Quick reply to this message
Reply




Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the HeliFreak forums, you must first register.
Please enter your desired user name, your REAL and WORKING email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself. Use a real email address or you will not be granted access to the site. Thank you.
Email Address:
Location
Where do you live? ie: Country, State, City or General Geographic Location please.
Name and Lastname
Enter name and last name here. (This information is not shown to the general public. Optional)
Helicopter #1
Enter Helicopter #1 type and equipment.
Helicopter #2
Enter Helicopter #2 type and equipment.
Helicopter #3
Enter Helicopter #3 type and equipment.
Helicopter #4
Enter Helicopter #4 type and equipment.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On




Copyright © Website Acquisitions Inc. All rights reserved.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2018 DragonByte Technologies Ltd.

SEO by vBSEO 3.6.1