Fun, Learning, Friendship and Mutual Respect START  HERE


Unregistered
Go Back   HeliFreak > R/C Helicopter Support > Blade Helicopters (eFlite) > Blade Nano S2



Reply
 
LinkBack Thread Tools Display Modes
Old 06-20-2019, 09:59 AM   #1 (permalink)
Registered Users
 

Join Date: Sep 2018
Location: Europe
Default Throttle delay in 3D-modus

Good afternoon all,

my dad has bought a Blade S2 and it's driving him nuts...it seems like the Z-modus is active in all modus (save - idle 1 - idle 2).

He bought this little heli with the intention to practice his indoor skills in idle 2 (= full 3D-mode).

Issue - situation - heli in idle 2 = full 3D
1/ get heli in proper hover
2/ give throttle up = heli goes up
3/ give throttle down = heli keeps climbing up for 2 or 3 seconds and than starts going down
4/ give throttle up again = heli still continues going down for 2 or 3 seconds and than starts going up

it seems/feels like the throttle is always in some kind of a delay. Anyone have the same issue? If so, how can this be fixed or what did you do to prevent this from happening again?

Thanks in advance!

grtz
PD
__________________
** Blade Nano CPS & CPS BL** Blade MCPX BL ** Blade 130S ** Blade 230S ** Blade 270 Fusion ** DJI Spark ** Align 450 PRO ** Spektrum DX8E **

Last edited by Psycho_dad; 06-20-2019 at 10:18 AM..
Psycho_dad is offline        Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 06-20-2019, 10:28 AM   #2 (permalink)
Registered Users
 
Posts: 2,597
 

Join Date: Sep 2018
Location: Southeast Snohomish County, WA
Default

What color is the board when it's in Idle 2? It should be red. If not, then you're still in some type of stable mode. If that's the case, check to make sure your Channel 5 output is giving -100% when in Idle 2. If you tie switch B to the Gear channel it should work correctly.
__________________
—Pronounced “zozo” or “Brian”

Aug 2019: Oxy 3+ — Oxy 2 — Nano S2 & CP X — T-Rex 150X — Spirit FBL — FrSky Horus X10S
xoexoe is online now        Reply With Quote Quick reply to this message
Old 06-20-2019, 11:42 AM   #3 (permalink)
Registered Users
Thread Starter Thread Starter
 

Join Date: Sep 2018
Location: Europe
Default

Thanks for your reply Xoexoe.

The color of the main board is red.

Double checked:
- the digital switch set-up and switch B in pos 2 => -100%
- channel input config => 5th gear is tied to switch B

So all settings seems to be right but it still has this annoying delay in throttle
__________________
** Blade Nano CPS & CPS BL** Blade MCPX BL ** Blade 130S ** Blade 230S ** Blade 270 Fusion ** DJI Spark ** Align 450 PRO ** Spektrum DX8E **
Psycho_dad is offline        Reply With Quote Quick reply to this message
Old 06-20-2019, 12:46 PM   #4 (permalink)
Registered Users
 
Posts: 2,597
 

Join Date: Sep 2018
Location: Southeast Snohomish County, WA
Default

I know that if my spindle shaft is bent it can cause a delay-like effect in the pitch command.

Is that a possibility? Or maybe sticky grip bearings? Happened to me.
xoexoe is online now        Reply With Quote Quick reply to this message
Reply




Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the HeliFreak forums, you must first register.
Please enter your desired user name, your REAL and WORKING email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself. Use a real email address or you will not be granted access to the site. Thank you.
Email Address:
Location
Where do you live? ie: Country, State, City or General Geographic Location please.
Name and Lastname
Enter name and last name here. (This information is not shown to the general public. Optional)
Helicopter #1
Enter Helicopter #1 type and equipment.
Helicopter #2
Enter Helicopter #2 type and equipment.
Helicopter #3
Enter Helicopter #3 type and equipment.
Helicopter #4
Enter Helicopter #4 type and equipment.

Log-in


Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On




Copyright © Website Acquisitions Inc. All rights reserved.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.

SEO by vBSEO 3.6.1