Fun, Learning, Friendship and Mutual Respect START  HERE


Unregistered
Go Back   HeliFreak > R/C Helicopter Support > Blade Helicopters (eFlite) > Blade mCPS


Blade mCPS Blade mCPS Helicopters Information and Help


Reply
 
LinkBack Thread Tools Display Modes
Old 06-08-2018, 09:41 PM   #1 (permalink)
Registered Users
 

Join Date: Jun 2018
Default A little help needed

My mCP S was flying great. Had a little crash and now she just won’t lift off the ground. Main gear is properly positioned and my second mPC S flies great on the same battery. What should I check? Any help would be much appreciated.
Cyclicofile is offline        Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 06-10-2018, 12:06 AM   #2 (permalink)
Registered Users
 
Posts: 234
 

Join Date: Oct 2017
Default

Does the rotor still spin? If so Check the two linkages that connect swashplate and blade grips. Make sure they are properly installed.

Sent from my EVA-L09 using Tapatalk
koopa137 is offline        Reply With Quote Quick reply to this message
Old 08-20-2019, 09:53 PM   #3 (permalink)
Registered Users
 
Posts: 60
 

Join Date: Apr 2012
Default

I am basically having the same issue. The blades at rest are very negative pitch and at full throttle I can only get a foot or two off the ground.
dragbug is offline        Reply With Quote Quick reply to this message
Old 08-24-2019, 09:33 AM   #4 (permalink)
Registered Users
 

Join Date: Jul 2019
Location: Hong Kong
Default

Does the main gear moved too low in the main shaft?

Sometimes you have to push it back up a bit and adjust the pushrods to correct the pitch.


Sent from my iPhone using Tapatalk
HumanYeung is offline        Reply With Quote Quick reply to this message
Old 08-25-2019, 03:16 PM   #5 (permalink)
Registered Users
 

Join Date: Sep 2018
Location: Europe
Default

check:
- main gear, it might have moved (lowered) on the main shaft
- feathering spindle, might be bend after crash...resulting in more negative than positive pitch
__________________
THE HANGAR
CPX - CPS - S2 - 180CFX - 270 Fusion (2) - Align 150X - Align 450 PRO - Logo 550SX (on order) ** Spektrum DX8E **
Hangar out: MCPX BL - 130S - 230S V1 Trio - CPS (2)
Psycho_dad is offline        Reply With Quote Quick reply to this message
Old 08-26-2019, 04:12 PM   #6 (permalink)
Registered Users
 
Posts: 60
 

Join Date: Apr 2012
Default

Ended up being the main gear which was a problem with the mCPX as I remember. Thanks for the help.
dragbug is offline        Reply With Quote Quick reply to this message
Reply




Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the HeliFreak forums, you must first register.
Please enter your desired user name, your REAL and WORKING email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself. Use a real email address or you will not be granted access to the site. Thank you.
Email Address:
Location
Where do you live? ie: Country, State, City or General Geographic Location please.
Name and Lastname
Enter name and last name here. (This information is not shown to the general public. Optional)
Helicopter #1
Enter Helicopter #1 type and equipment.
Helicopter #2
Enter Helicopter #2 type and equipment.
Helicopter #3
Enter Helicopter #3 type and equipment.
Helicopter #4
Enter Helicopter #4 type and equipment.

Log-in


Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On




Copyright © Website Acquisitions Inc. All rights reserved.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.

SEO by vBSEO 3.6.1