Fun, Learning, Friendship and Mutual Respect START  HERE


Unregistered
Go Back   HeliFreak > R/C Helicopter Support > 550 Class Electric Helicopters


550 Class Electric Helicopters 550 Class Electric Helicopters manufactured by Align, Tarot, SYMA, Airhog, Chaos, HK and similar.


Reply
 
LinkBack Thread Tools Display Modes
Old 11-19-2020, 07:26 AM   #1 (permalink)
Registered Users
 

Join Date: Nov 2020
Location: singapore
Default Align Trex 550X

Hi i am sorry that i have to post here as I don't know how to use a forum.
Anyways very serious question.
I have a Align Trex 550X with microbeast plus setup. Recently I had a really bad crash due to the one way bearing giving way and becoming 2 way hence it crashed. Now the main problem is that after changing all the damaged parts my servo seems to become really sluggish it was responsive enough before that and really a good helicopter to fly but now everything seems off... Any kind soul has any ideas what happened or has experienced it before? Pardon me i a newbie in this hobby. Many help will be appreciated thank you!
Pang93 is offline        Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 11-19-2020, 04:46 PM   #2 (permalink)
Registered Users
 
Posts: 2,722
 

Join Date: Sep 2011
Location: Paradise Lost
Default

There's a 550 (all brands) dedicated forum down the list. Maybe the mods will relocate it.

Anyways, it could be one or several issues. Whats your BEC voltage like? Assuming your power and architecture are ok, I'd start going over the set up menu (menu LED solid) and ensure all is in spec (servo update rate, center pulse, limits) ect. Down the list and according to your servo specs.

Next I'd re-do / check the parameter menu. (menu LED fast blink) Control styles, stick dead zones ect. Just go down the list.

Hope this helps some.
__________________
If it flies, floats or....... , rent it.

Last edited by Felix the cat; 11-19-2020 at 07:53 PM..
Felix the cat is offline        Reply With Quote Quick reply to this message
Old 11-20-2020, 08:36 AM   #3 (permalink)
Registered Users
Thread Starter Thread Starter
 

Join Date: Nov 2020
Location: singapore
Default

Thanks i think my microbeast plus might be broken.....
Pang93 is offline        Reply With Quote Quick reply to this message
Old 11-20-2020, 08:42 AM   #4 (permalink)
Registered Users
Thread Starter Thread Starter
 

Join Date: Nov 2020
Location: singapore
Default Sluggish servo

A very serious question.
I have a Align Trex 550X with microbeast plus setup. Recently I had a really bad crash due to the one way bearing giving way and becoming 2 way hence it crashed. Now the main problem is that after changing all the damaged parts my servo seems to become really sluggish it was responsive enough before that and really a good helicopter to fly but now everything seems off... Any kind soul has any ideas what happened or has experienced it before? Many help will be appreciated thank you! I have checked the BEC voltage it at 7V the setting for servo refresh rate are set to the highest but nothing seems to works! Is my flight controller damaged?
Pang93 is offline        Reply With Quote Quick reply to this message
Old 11-21-2020, 03:48 AM   #5 (permalink)
HF Support
 
Posts: 35,039
 
My HF Map location
Join Date: May 2006
Default

Quote:
Originally Posted by Pang93 View Post
Hi i am sorry that i have to post here as I don't know how to use a forum.
Anyways very serious question.
I have a Align Trex 550X with microbeast plus setup. Recently I had a really bad crash due to the one way bearing giving way and becoming 2 way hence it crashed. Now the main problem is that after changing all the damaged parts my servo seems to become really sluggish it was responsive enough before that and really a good helicopter to fly but now everything seems off... Any kind soul has any ideas what happened or has experienced it before? Pardon me i a newbie in this hobby. Many help will be appreciated thank you!
Quote:
Originally Posted by Pang93 View Post
A very serious question.
I have a Align Trex 550X with microbeast plus setup. Recently I had a really bad crash due to the one way bearing giving way and becoming 2 way hence it crashed. Now the main problem is that after changing all the damaged parts my servo seems to become really sluggish it was responsive enough before that and really a good helicopter to fly but now everything seems off... Any kind soul has any ideas what happened or has experienced it before? Many help will be appreciated thank you! I have checked the BEC voltage it at 7V the setting for servo refresh rate are set to the highest but nothing seems to works! Is my flight controller damaged?
Please do not crosspost. Your two threads have been merged and moved.
__________________
-Kevin

No helicopters were harmed in the creation of this post.
AMA CD # 7309, Turbine Waiver# RW 890
Click Here For Bergen Intrepid Turbine Build Videos
Skiddz is offline        Reply With Quote Quick reply to this message
Reply




Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the HeliFreak forums, you must first register.
Please enter your desired user name, your REAL and WORKING email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself. Use a real email address or you will not be granted access to the site. Thank you.
Email Address:
Location
Where do you live? ie: Country, State, City or General Geographic Location please.
Name and Lastname
Enter name and last name here. (This information is not shown to the general public. Optional)
Helicopter #1
Enter Helicopter #1 type and equipment.
Helicopter #2
Enter Helicopter #2 type and equipment.
Helicopter #3
Enter Helicopter #3 type and equipment.
Helicopter #4
Enter Helicopter #4 type and equipment.

Log-in


Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On




Copyright © Website Acquisitions Inc. All rights reserved.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2021 DragonByte Technologies Ltd.

SEO by vBSEO 3.6.1