Recovering Firmware in Bump Controller - HeliFreak
Fun, Learning, Friendship and Mutual Respect START  HERE


Unregistered
Go Back   HeliFreak > R/C Electronics Support > FMA/Revolectrix Product Support


FMA/Revolectrix Product Support FMA/Revolectrix Factory Product Support


Reply
 
LinkBack Thread Tools Display Modes
Old 03-09-2017, 08:43 PM   #1 (permalink)
Registered Users
 

Join Date: Jul 2008
Location: Boston, MA
Default Recovering Firmware in Bump Controller

So just got my iOS app and loved that it automatically updated firmware straight from the app. Updated the firmware on the bump controller. Great. Then tried updating the firmware on my PL8. It failed. I had to disconnect, connect to my laptop and update firmware through my laptop. All set. Except ... the bump controller can't figure out that the firmware is all set. Even if I disconnect the charger altogether. Message is attached. Thoughts?
Attached Thumbnails
Click image for larger version

Name:	bump.jpg
Views:	46
Size:	22.6 KB
ID:	698017  
__________________
Compass 7HV (SK720BE w/GPS1)
Gaui X3 (SK720BE) / Oxy3 (SK720 Blue)
JR 11X
Shabill is offline        Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 03-09-2017, 08:59 PM   #2 (permalink)
Registered Users
Thread Starter Thread Starter
 

Join Date: Jul 2008
Location: Boston, MA
Default

Never mind; I figured it out. I turned off channel 1 in the bump controller settings and then turned it back on and that seemed to do the trick.
__________________
Compass 7HV (SK720BE w/GPS1)
Gaui X3 (SK720BE) / Oxy3 (SK720 Blue)
JR 11X
Shabill is offline        Reply With Quote Quick reply to this message
Old 03-09-2017, 09:52 PM   #3 (permalink)
Registered Users
 

Join Date: Sep 2015
Location: USA
Default

Quote:
Originally Posted by Shabill View Post
So just got my iOS app and loved that it automatically updated firmware straight from the app. Updated the firmware on the bump controller. Great. Then tried updating the firmware on my PL8. It failed. I had to disconnect, connect to my laptop and update firmware through my laptop. All set. Except ... the bump controller can't figure out that the firmware is all set. Even if I disconnect the charger altogether. Message is attached. Thoughts?
After the PL8 firmware upgrade failed, did you attempt to retry (after power cycling) ?
Our testing has shown that it will indeed fail occassionally on the first attempt, but has always succeeded on the 2nd attempt ... so curious to see if if everyone else experiences the same.
RevoKelly is offline        Reply With Quote Quick reply to this message
Old 03-10-2017, 12:28 PM   #4 (permalink)
Registered Users
Thread Starter Thread Starter
 

Join Date: Jul 2008
Location: Boston, MA
Default

No, I wasn't able to get it to restart through iOS after it failed. I tried, and when that didn't work, went in through my laptop.

And as an update, as it turns out, now whenever I power on the charger, the same message shows up on the bump controller and I have to go into the bump controller and disable and then re-enable that charger.
__________________
Compass 7HV (SK720BE w/GPS1)
Gaui X3 (SK720BE) / Oxy3 (SK720 Blue)
JR 11X
Shabill is offline        Reply With Quote Quick reply to this message
Old 03-10-2017, 03:42 PM   #5 (permalink)
Registered Users
 

Join Date: Sep 2015
Location: USA
Default

Quote:
Originally Posted by Shabill View Post
No, I wasn't able to get it to restart through iOS after it failed. I tried, and when that didn't work, went in through my laptop.

And as an update, as it turns out, now whenever I power on the charger, the same message shows up on the bump controller and I have to go into the bump controller and disable and then re-enable that charger.
Strange. Ill see if i can recreate it.
RevoKelly is offline        Reply With Quote Quick reply to this message
Old 03-17-2017, 12:23 PM   #6 (permalink)
Registered Users
Thread Starter Thread Starter
 

Join Date: Jul 2008
Location: Boston, MA
Default

No luck recreating? I can't make it stop.

Well, there is one solution (for me) ... since I only have 3 chargers, think instead of using 1,2,3, will use 2,3,4.
__________________
Compass 7HV (SK720BE w/GPS1)
Gaui X3 (SK720BE) / Oxy3 (SK720 Blue)
JR 11X
Shabill is offline        Reply With Quote Quick reply to this message
Old 03-17-2017, 03:01 PM   #7 (permalink)
Registered Users
 

Join Date: Sep 2015
Location: USA
Default

Quote:
Originally Posted by Shabill View Post
No luck recreating? I can't make it stop.

Well, there is one solution (for me) ... since I only have 3 chargers, think instead of using 1,2,3, will use 2,3,4.
I cant recreate yet, but will add a feature to next release that workaround it by resetting that upgrade state anytime the port is enabled/disabled.

If you dont want to wait for that release, just go i to settings -> Factory Reset. That should clear the problem, but youll need to do setup again on the Bump - power supply settings, wiring mode, etc., will revert back to default values.
RevoKelly is offline        Reply With Quote Quick reply to this message
Old 03-17-2017, 05:20 PM   #8 (permalink)
Registered Users
Thread Starter Thread Starter
 

Join Date: Jul 2008
Location: Boston, MA
Default

I can wait for the update. Thanks!
__________________
Compass 7HV (SK720BE w/GPS1)
Gaui X3 (SK720BE) / Oxy3 (SK720 Blue)
JR 11X
Shabill is offline        Reply With Quote Quick reply to this message
Old 04-25-2017, 03:56 AM   #9 (permalink)
Registered Users
 
Posts: 819
 

Join Date: Aug 2011
Location: Halifax, United Kingdom
Default

Quote:
Originally Posted by RevoKelly View Post
After the PL8 firmware upgrade failed, did you attempt to retry (after power cycling) ?
Our testing has shown that it will indeed fail occassionally on the first attempt, but has always succeeded on the 2nd attempt ... so curious to see if if everyone else experiences the same.
I've just had exactly the same issue and even after multiple power cycles, the PL8 firmware will still not update. I just hope I can find my USB cable and update the firmware via my PC
__________________
Kasama UK | Bavarian Demon
wadders248 is offline        Reply With Quote Quick reply to this message
Reply




Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the HeliFreak forums, you must first register.
Please enter your desired user name, your REAL and WORKING email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself. Use a real email address or you will not be granted access to the site. Thank you.
Email Address:
Location
Where do you live? ie: Country, State, City or General Geographic Location please.
Name and Lastname
Enter name and last name here. (This information is not shown to the general public. Optional)
Helicopter #1
Enter Helicopter #1 type and equipment.
Insurance
Please select your insurance company (Optional)
Helicopter #2
Enter Helicopter #2 type and equipment.
Helicopter #3
Enter Helicopter #3 type and equipment.
Helicopter #4
Enter Helicopter #4 type and equipment.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On




Copyright © VerticalScope Inc. All rights reserved.
 

SEO by vBSEO 3.6.1