Fun, Learning, Friendship and Mutual Respect START  HERE


Unregistered
Go Back   HeliFreak > R/C Helicopter Support > Blade Helicopters (eFlite) > mCP X Brushless Mods


mCP X Brushless Mods Blade Micro CPx Brushless Mods and Conversions


Reply
 
LinkBack Thread Tools Display Modes
Old 03-29-2013, 04:24 AM   #1 (permalink)
Registered Users
 

Join Date: Jul 2012
Default BLHeli - Unknown device

Hi,

I am trying to flash the XP-3A ESC with an USB adapter (from Astroid) but I get the "unknown device" message when I use BLHeli software (windows 7 - 64 bits). I am powering the ESC with an external battery... Any idea of what is going on? Maybe the USB adapter has been burned out soldering the cables?

Thanks in advance!
nahemoth is offline        Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 03-29-2013, 07:48 AM   #2 (permalink)
Registered Users
 
Posts: 11,208
 

Join Date: Mar 2011
Default

Quote:
Originally Posted by nahemoth View Post
Hi,

I am trying to flash the XP-3A ESC with an USB adapter (from Astroid) but I get the "unknown device" message when I use BLHeli software (windows 7 - 64 bits). I am powering the ESC with an external battery... Any idea of what is going on? Maybe the USB adapter has been burned out soldering the cables?

Thanks in advance!
Make sure you have the connector soldered to the right positions. You have to swap the red and white positions to use the tool stick Dylan sells.
__________________
Team Newb pilot
All my helis and quads were lost in a tragic boating accident.
DX9, AMA# 966513.
NCcraig is offline        Reply With Quote Quick reply to this message
Old 03-29-2013, 09:47 AM   #3 (permalink)
Registered Users
Thread Starter Thread Starter
 

Join Date: Jul 2012
Default Re: BLHeli - Unknown device

I followed the instructions from Dylan page. I attach a photo of the connections from the programmer to the ESC. Is it wrong?

Thanks!
Attached Thumbnails
Click image for larger version

Name:	uploadfromtaptalk1364568273072.jpg
Views:	199
Size:	60.3 KB
ID:	407538  
nahemoth is offline        Reply With Quote Quick reply to this message
Old 03-29-2013, 10:59 AM   #4 (permalink)
Registered Users
 
My HF Map location
Join Date: Dec 2012
Default

Yes its wrong, I have attached a picture I have edited to make connection of the toolstick Astroid and Topper carry easier to understand.

The BLheli thread was written before these tool sticks became popular. The original "Tool Stick" Had Black, Red, White wires.

These ones have Black, Red, Yellow.

The Red Wire corresponds to the White wire on the original
The Yellow would be red
and the black is black.

Just follow the image and you should be fine!
Attached Thumbnails
Click image for larger version

Name:	programmer connection.jpg
Views:	195
Size:	166.9 KB
ID:	407552  
cnyncrvr is offline        Reply With Quote Quick reply to this message
Old 03-29-2013, 11:02 AM   #5 (permalink)
Registered Users
 

Join Date: Oct 2012
Default

I don't think you have the tool connected to the right place. Just based on the silk screening on the board I'm guessing that's the throttle, +, and - inputs to the board. Check out the first post of the BLHeli sticky thread in this forum. sskaug has done a nice job of showing pictures for a bunch of ESCs (including the XP-3A) with the connection points for power, motor, throttle, and tool stick.

As for which wires on the tool stick go to which connections points marked by sskaug in his pictures, start with what NCCraig says above. If that doesn't work (Topper once told me he has had tool sticks come with reversed connections), then swap the red and white connection points and try again. Getting the red and white points reversed won't hurt anything, but the ESC will not be recognized.

Good luck
Canno is offline        Reply With Quote Quick reply to this message
Old 03-29-2013, 11:07 AM   #6 (permalink)
Registered Users
Thread Starter Thread Starter
 

Join Date: Jul 2012
Default Re: BLHeli - Unknown device

Thanks!

I had to swap yellow and red cables, but now it connects to the ESC and I program it perfectly!

Last edited by nahemoth; 03-30-2013 at 03:37 AM..
nahemoth is offline        Reply With Quote Quick reply to this message
Reply




Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the HeliFreak forums, you must first register.
Please enter your desired user name, your REAL and WORKING email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself. Use a real email address or you will not be granted access to the site. Thank you.
Email Address:
Location
Where do you live? ie: Country, State, City or General Geographic Location please.
Name and Lastname
Enter name and last name here. (This information is not shown to the general public. Optional)
Helicopter #1
Enter Helicopter #1 type and equipment.
Helicopter #2
Enter Helicopter #2 type and equipment.
Helicopter #3
Enter Helicopter #3 type and equipment.
Helicopter #4
Enter Helicopter #4 type and equipment.

Log-in


Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On




Copyright © Website Acquisitions Inc. All rights reserved.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.

SEO by vBSEO 3.6.1