Fun, Learning, Friendship and Mutual Respect START  HERE


Unregistered
Go Back   HeliFreak > R/C Helicopter Support > 150 Class Electric Helicopters


150 Class Electric Helicopters 150 Class Electric Helicopters manufactured by Align, Tarot, SYMA, Airhog, Chaos, HK and similar.


Reply
 
Thread Tools Display Modes
Old 12-02-2016, 09:14 AM   #1
jujiro85
Registered Users
 

Join Date: Nov 2016
Location: Jennings
Default Trex 150x forward drift

Hi Just got the trex 150x up and running after a day or two trying to get it to bind to my old dx7 with a dsm2 receiver .

Now only issue I have is that it drifts forward at all times and i have to correct it ( hold the stick back) 100 percent of the time it's in the air. Was wondering if that was because of the receiver weighing down the front or something else setup wrong .
jujiro85 is offline        Reply With Quote
Old 12-02-2016, 09:09 PM   #2
prairie ville
Registered Users
 
Posts: 303
 

Join Date: Mar 2011
Location: Casper, Wyoming
Default

Do a gyro reset. Level ground powered up heli(not running) and radio. Pull elevator stick all the way down for at least 3 seconds, blue light should flash faster and when finished, blue light will go back to normal.
__________________
DX8 GEN 1, Phoenix R/C 5.5 ,Hyperion 720i DUO w/ MW 600 PS,Trex 250 se, Trex 150X, mCPXv1, mSRX, mSR, Walkera 4G#6S , Blade SR....Maiden: Trex 470LM
prairie ville is offline        Reply With Quote
Old 12-02-2016, 10:35 PM   #3
starryalley
Registered Users
 

Join Date: Nov 2012
Location: Taiwan
Default

Also make sure you do this gyro calibration every time after you crash. I found it will start drifting again after a hard crash (well I crashed more than 5 times hard..)
starryalley is offline        Reply With Quote
Old 12-26-2016, 05:45 PM   #4
gromitvt10
Registered Users
 

Join Date: Mar 2007
Location: Solomons, MD
Default

I have the same problem, drifting forward. I've tried the gyro reset 4 times, still no luck. How did you fix yours? My swashplate level.
__________________
JAM-STRIKE-WIN!!
gromitvt10 is offline        Reply With Quote
Old 12-26-2016, 10:59 PM   #5
cm930
Registered Users
 

Join Date: Jun 2014
Location: Taiwan
Default

Quote:
Originally Posted by gromitvt10 View Post
I have the same problem, drifting forward. I've tried the gyro reset 4 times, still no luck. How did you fix yours? My swashplate level.
If gyro calibration does not fix it, I think the next step is to adjust the accelerometer subtrim using the 150 GRS app.
cm930 is offline        Reply With Quote
Old 12-27-2016, 12:13 AM   #6
bredler
Registered Users
 
Posts: 274
 

Join Date: Feb 2015
Location: Pittsburgh
Default

Put a trash can in front of it and just let it drift right in there where it belongs
__________________
RCHN #825
Blade 550x, Blade 360 cfx, Blade 180 cfx
bredler is offline        Reply With Quote
Old 12-27-2016, 08:56 AM   #7
krauley
Registered Users
 
Posts: 779
 

Join Date: Oct 2011
Location: Callahan, Florida
Default

Quote:
Originally Posted by bredler View Post
Put a trash can in front of it and just let it drift right in there where it belongs
Cant, its full of blade helis and has no more room!
__________________
UH-60 EXI 500 DFC/3GX v5.0 ICE 75 Bec Pro w/4 blade main & tail rotors
Align trex 500DFC Pro w/AR7210bx Oxy 2 FE micro Ikon2 Talon 25 BA 8-1 servos
Oxy 3 Tareq Edition AR7210bx Edge lite 50 Kst 215's
PL6 w/Bump Controller-24v PS DX8 gen2
krauley is offline        Reply With Quote
Reply




Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



Copyright © 2004-2016 by RCGroups.com, LLC except where otherwise indicated. The HeliFreak.com logo is a trademark of RCGroups.com, LLC.