About Engine OS50 Blue Head WC - HeliFreak
Fun, Learning, Friendship and Mutual Respect START  HERE


Unregistered
Go Back   HeliFreak > R/C Helicopter Support > Engines and Mufflers


Engines and Mufflers Having problems or need advice on Engines or Mufflers?


Reply
 
LinkBack Thread Tools Display Modes
Old 04-09-2013, 07:30 PM   #1 (permalink)
Registered Users
 

Join Date: Jun 2009
Location: New York
Default About Engine OS50 Blue Head WC

I have an Align Nitro heli Keeps Burning Glow Plug like Crazy! what cause this to keep happing it time for a New Ring! or carb adjustment! Im getting lots smoke and doesn't seem to be too lean what gives
Ace6767 is offline        Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 04-10-2013, 01:50 AM   #2 (permalink)
Registered Users
 
Posts: 757
 

Join Date: Nov 2008
Location: London
Default

Typical sign of bearings going bad,Time for a bearing change.
__________________
Trex 600N Pro with Vibe 50 Head and YS91RS motor, Vibe 50 VBar FBL, Trex744 VBar FBL MW44 Turbine, Logo 800 XXTreme, Logo 600 12s, Logo 500SE, Vario UH-1D (Building), Scratch built 625mm Quad.
kevinww is offline        Reply With Quote Quick reply to this message
Old 04-10-2013, 10:32 AM   #3 (permalink)
Registered Users
 
Posts: 564
 

Join Date: Mar 2011
Location: South Africa, near Cape Town
Default

Quote:
Originally Posted by kevinww View Post
Typical sign of bearings going bad,Time for a bearing change.
+1, Open that engine before it cause more damage. I's tiny pieces of the rearbearing that short your plug!
__________________
Align T-Rex 600&700 Nitro Pro DFC
SAB Goblin 630 Competition
SAB Trioblin 500
Futaba 8FG Super
cmouton is offline        Reply With Quote Quick reply to this message
Old 04-10-2013, 10:36 AM   #4 (permalink)
Registered Users
 
Posts: 6,375
 
My HF Map location
Join Date: Jan 2005
Location: Jacksonville FL
Default

Bearings are one possibility, so is RTV if you sealed your muffler with it, or simply running too lean.

Examine your plug, if its black and the element looks descimated then its probably lean, if there's silver flecks your bearing is coming apart, if you used RTV and there's orange flecks, then thats getting sucked in and snuffing the plug.
__________________
Andy
AMA 77227
Jacksonville FL
http://www.jaxrc.com
BarracudaHockey is offline        Reply With Quote Quick reply to this message
Reply




Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the HeliFreak forums, you must first register.
Please enter your desired user name, your REAL and WORKING email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself. Use a real email address or you will not be granted access to the site. Thank you.
Email Address:
Location
Where do you live? ie: Country, State, City or General Geographic Location please.
Name and Lastname
Enter name and last name here. (This information is not shown to the general public. Optional)
Helicopter #1
Enter Helicopter #1 type and equipment.
Helicopter #2
Enter Helicopter #2 type and equipment.
Helicopter #3
Enter Helicopter #3 type and equipment.
Helicopter #4
Enter Helicopter #4 type and equipment.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On




Copyright © Website Acquisitions Inc. All rights reserved.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2018 DragonByte Technologies Ltd.

SEO by vBSEO 3.6.1