Problems with my ESC on my 500esp - HeliFreak
Fun, Learning, Friendship and Mutual Respect START  HERE


Unregistered
Go Back   HeliFreak > R/C Helicopter Support > 500 Class Electric Helicopters


500 Class Electric Helicopters 500 Class Electric Helicopters manufactured by Align, Tarot, SYMA, Airhog, Chaos, HK and similar.


Reply
 
LinkBack Thread Tools Display Modes
Old 04-16-2009, 10:39 PM   #1 (permalink)
Registered Users
 
Posts: 1,066
 

Join Date: Mar 2009
Location: Arlington hts, IL
Default Problems with my ESC on my 500esp

I finally got my 500 in the air but it seems that i am getting some jollts in the tail, i thouht it was my gain so i turned it down, but got the same results, no matter which way i went on the gain it seemed the same, i had a friend look at it, and he told me that there may be an issue with my esc, he pointed out that when i plug the battery in it arms way to fast, and what he meant was that it can spool up even before the 3 beeps come on, i hope i made sense, he also mentioned that the gov in the esc needs to be deactivated and thats why i get the small jolts, can anyone help me.
lazsyss350 is offline        Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 04-17-2009, 05:31 AM   #2 (permalink)
Registered Users
 

Join Date: Jun 2004
Location: Northants, England
Default

Hey,

I'm confident your problem is centred around the govenor mode, while it does work it has been found that your better off running the ESC's out of govenor mode and running straight throttle curves.
The kicking on the tail your seeing can be caused by the govenor just not quite on the power and hence stumbling alomost to maintain rpm.

I would try deactivating the govenor mode and setting throttle curves, just remember that ESC's like to be run above 80% throttle setting for long periods.
As an example in normal mode I ramp the throttle curve up very steeply to about the 1/3rd throttle position to get the power in early and before lift off.
Here is my throttle readings from my DSX12 for my T500;

Normal; 0 ~ 76 ~ 83 ~ 85 ~ 85 (83% being mid stick, 0 degrees pitch)

IdleUp1; 92 ~ 95 ~ 100 (95% being mid stick, 0 degrees pitch)

IdleUp2; 100 ~ 95 ~ 100 (95% being mid stick, 0 degrees pitch)

Hope this helps?
.
__________________
Ian Contessa
Coolice Charge Cases & Power Supplies
Coolice is offline        Reply With Quote Quick reply to this message
Old 04-17-2009, 05:43 AM   #3 (permalink)
Registered Users
 
Posts: 1,192
 
My HF Map location
Join Date: Mar 2008
Location: Haifa Israel
Default

I agree with coolice,
your problem is caused by the gov mode.
The spooli g up before 3 beeps is normal (as long as it is you who order it to spool up).
Bottom line, try to turn gov mode off, reconfig your gyro gain and see if it's ok.
And about the throtle curves, both the motor and the ESC likes it over 80. If your I to 3D, go with flat 100.
Good luck!
lavi is offline        Reply With Quote Quick reply to this message
Old 04-17-2009, 07:05 AM   #4 (permalink)
Registered Users
 
Posts: 419
 

Join Date: Apr 2007
Location: Sweden
Default

Im running mine in governor mode. I have lowered my throttle response to medium and I think its working fine now.
/ Ola
ola.c is offline        Reply With Quote Quick reply to this message
Old 04-17-2009, 09:07 AM   #5 (permalink)
Registered Users
 
Posts: 1,066
Thread Starter Thread Starter
 

Join Date: Mar 2009
Location: Arlington hts, IL
Default

thanks guys, problem solved.
lazsyss350 is offline        Reply With Quote Quick reply to this message
Old 04-17-2009, 12:59 PM   #6 (permalink)
Registered Users
 
Posts: 2,083
 

Join Date: Jan 2009
Location: NJ
Default

Some people have noted that the stock gov. can cut out the motor completely in flight. I would be weary if using it.
__________________
Trex 500 Esp, CC Ice 75, Hyperion 1600kv, Gp750, Ds510's , Ar6200, DS650 tail mod.
DX7
Hyperion 250w 6s Charger, Hyperion G3 Battaries
ParkZone T-28 w/ custom flaps+retracts, Ar7000
6s RCLander F-16 - To scared to maiden
JackdaWack is offline        Reply With Quote Quick reply to this message
Reply




Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the HeliFreak forums, you must first register.
Please enter your desired user name, your REAL and WORKING email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself. Use a real email address or you will not be granted access to the site. Thank you.
Email Address:
Location
Where do you live? ie: Country, State, City or General Geographic Location please.
Name and Lastname
Enter name and last name here. (This information is not shown to the general public. Optional)
Helicopter #1
Enter Helicopter #1 type and equipment.
Insurance
Please select your insurance company (Optional)
Helicopter #2
Enter Helicopter #2 type and equipment.
Helicopter #3
Enter Helicopter #3 type and equipment.
Helicopter #4
Enter Helicopter #4 type and equipment.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On




Copyright © VerticalScope Inc. All rights reserved.
 

SEO by vBSEO 3.6.1