Need help with Phoenix 2.5 and DX6i - HeliFreak
Fun, Learning, Friendship and Mutual Respect START  HERE


Unregistered
Go Back   HeliFreak > R/C Simulators Support > Phoenix Flight Sim


Phoenix Flight Sim Phoenix Flight Sim


Reply
 
LinkBack Thread Tools Display Modes
Old 08-06-2009, 01:16 PM   #1 (permalink)
Registered Users
 
Posts: 13
 

Join Date: Apr 2008
Location: Allentown GA
Default Need help with Phoenix 2.5 and DX6i

I have sucessfully loaded Phoenix 2.5 into my computer but am having trouble getting the Spektrum DX6i to work.I've followed all the set-up instructions but then nothing happens.I'm not terribly computer savy so I probably need to have a phone conversation with someone to figure all this out. Call collect 478-962-3627 if you think you can help.I'd really appreciate it. Will be home all Thurs.PM but not after 10 AM EDT Friday Aug7.
mr michael is offline        Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 08-06-2009, 04:04 PM   #2 (permalink)
Registered Users
 
Posts: 13
Thread Starter Thread Starter
 

Join Date: Apr 2008
Location: Allentown GA
Default

Phoenix support just called-all is running smoothly now.Graphics are super !!! Now for some real crashes!!
mr michael is offline        Reply With Quote Quick reply to this message
Old 08-06-2009, 09:18 PM   #3 (permalink)
Registered Users
 
Posts: 119
 

Join Date: Jan 2007
Location: BrisVegas, Australia
Default

Phoenix support call you? WOW!!! That is what you call customer service.
Whopper is offline        Reply With Quote Quick reply to this message
Old 08-07-2009, 01:12 PM   #4 (permalink)
Registered Users
 
Posts: 4,802
 

Join Date: Mar 2008
Default

May be the call from support was from CommonSenseRC as it is now the distributor for Phoenix in the US. CommonSenseRC has one of the best customer service in this Hobby. I'd an esc that went bad. One phone call and a replacement was in the mail and was received the next day.

CommonSenseRC, Readyheli and Flyhelirus are three of the best for service.
BenHeli is offline        Reply With Quote Quick reply to this message
Old 08-07-2009, 10:55 PM   #5 (permalink)
Registered Users
 
Posts: 615
 

Join Date: Jun 2008
Default

Does anyone else have problems with phoenix registering an ON/OFF throttle situation? No matter what on phoenix, the throttle is either 100 percent or 0 No in between. The throttle and pitch curves are set up and on the transmitter set up page of phoenix it shows smooth throttle movement. Whats the deal, is it supposed to work like this? pitch is fine. It just makes spooling up unrealistic as well as making normal mode impossible to replicate.
cbrian4 is offline        Reply With Quote Quick reply to this message
Old 08-08-2009, 09:59 PM   #6 (permalink)
Registered Users
 
Posts: 119
 

Join Date: Jan 2007
Location: BrisVegas, Australia
Default

Its the main rotor govenor doing its job, switch off the govenor if you don't like it.
Whopper is offline        Reply With Quote Quick reply to this message
Reply




Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the HeliFreak forums, you must first register.
Please enter your desired user name, your REAL and WORKING email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself. Use a real email address or you will not be granted access to the site. Thank you.
Email Address:
Location
Where do you live? ie: Country, State, City or General Geographic Location please.
Name and Lastname
Enter name and last name here. (This information is not shown to the general public. Optional)
Helicopter #1
Enter Helicopter #1 type and equipment.
Insurance
Please select your insurance company (Optional)
Helicopter #2
Enter Helicopter #2 type and equipment.
Helicopter #3
Enter Helicopter #3 type and equipment.
Helicopter #4
Enter Helicopter #4 type and equipment.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On




Copyright © Website Acquisitions Inc. All rights reserved.
 

SEO by vBSEO 3.6.1