Fun, Learning, Friendship and Mutual Respect START  HERE


Unregistered
Go Back   HeliFreak > R/C Helicopter Support > Blade Helicopters (eFlite) > mCP X


mCP X Blade Micro CPx Helicopters Information and Help


Reply
 
LinkBack Thread Tools Display Modes
Old 10-17-2014, 01:55 PM   #1 (permalink)
Registered Users
 

Join Date: Oct 2010
Default Cyclic control

Is this normal? Not my video but mine does the same,when I take off I find I have no cyclic control.

Problem with Blade MCPX V2, out of the box stuck servos (3 min 22 sec)
shawzie is offline        Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 10-17-2014, 02:08 PM   #2 (permalink)
Registered Users
 
Posts: 2,508
 

Join Date: Aug 2011
Default

I never had a problem like that out of the box. Now after some bad crashes yes but not out the box
__________________
Oxy 3 (285) , Oxy4, DX8 Gen2, have retired my 120SR, MCPx, MCPxBL and 230S
kona0915 is online now        Reply With Quote Quick reply to this message
Old 10-17-2014, 02:13 PM   #3 (permalink)
Registered Users
Thread Starter Thread Starter
 

Join Date: Oct 2010
Default

Did you find what was causing it?
shawzie is offline        Reply With Quote Quick reply to this message
Old 10-17-2014, 04:29 PM   #4 (permalink)
Registered Users
 
Posts: 2,508
 

Join Date: Aug 2011
Default

Not specifically. When it happened I would tear the head apart looking for a bent feathering shaft, put everything back together, reset my swash level and zero pitch at midstick and problem solved. One time I did have a bad elevator servo and had to swap it out but I had a ton of flights and some wicked crashes with it
__________________
Oxy 3 (285) , Oxy4, DX8 Gen2, have retired my 120SR, MCPx, MCPxBL and 230S
kona0915 is online now        Reply With Quote Quick reply to this message
Old 10-17-2014, 06:14 PM   #5 (permalink)
Registered Users
 

Join Date: Sep 2013
Default

Not normal
My 130x board had a slightly similar issue, where throttle up to activate the gyro

With no stick input or motor plugged in
the swash would drift to the right and the tail pulls a left yaw
slow but constant, it would eventually lead to the endpoints

where-after any heavy collective/cyclic would lock it up hard (exactly as per video,however for me it tended to lock up in the last known position)

Sent the board back to the shop within a week and got a free replacement a few weeks later, problem solved right there.

Not sure if any tx mixing per ccpm or servo setup may cause this behavior for mcpx, but it can't hurt checking again

It may be worth testing servos individually in each socket just to be sure..
If one servo has an issue, all of them are likely to receive feedback and play up
Re-test with motor unplugged, throttle up then roll and pitch the model around to the extremes.
Birdstrike is offline        Reply With Quote Quick reply to this message
Old 10-17-2014, 07:20 PM   #6 (permalink)
Registered Users
Thread Starter Thread Starter
 

Join Date: Oct 2010
Default

That's the thing though,it only does that when there's throttle???? I checked and nothing is binding,cleaned the servos,switched them around and tested each servo on its own as well as replaced all servos.
shawzie is offline        Reply With Quote Quick reply to this message
Old 10-18-2014, 10:22 AM   #7 (permalink)
Registered Users
 

Join Date: Sep 2013
Default

Have the AS3X replaced asap

Sounds like a messed up calibration, nothing you can do to fix that unless you can interface with the board and do some magic.
Birdstrike is offline        Reply With Quote Quick reply to this message
Old 10-21-2014, 04:10 AM   #8 (permalink)
Registered Users
 

Join Date: Feb 2013
Default

hello
you video is ok.
it is normal.
this is cause system flybarless.
i have two blade mcpx.
the system flybarless have 2 mode of work.
mode n1 : motor to OFF. When the motor are OFF the swashplate follow your input stick ciclos immediately( AILE, ELEV, PITCH ). you prove with throttle hold (MOTOR OFF ) , you see swashplate follow your stick ciclos immediately.
mode n 2 : motor to ON. When the motor are ON the swashplate is to control by flybarless to 100% (i think....) . Now when you move your stick ciclos ( only AILE TX and ELEV TX ) , the flybarless take your input da TX and will that MCPX to do this and wait that MCPX move. If MCPX is stop on the table , the flybarless to run to give input to swashplate without time till that MCPX to arrive at inclination EQUAL as your input stick CICLOS TX ,and ONLY AFTER THE FLYBARLESS LEVEL YOUR MCPX with servo AILE and ELEV ( servo PITCH IS ALWAYS control by your PITCH TX ) , IF YOU NOT TOUCH YOUR STICK AILE TX and ELEV TX ; NEVER !.
this flybarless work so : the SERVO PITCH is ONLY Always live with your stick PITCH TX.
the SERVO AILE is Always live with your stick AILE TX + your stick PITCH TX (only for PITCH ) ONLY with MOTOR TO OFF. With MOTOR TO ON , the SERVO AILE is control by FLYBALESS ( inclination + level ) + your stick AILE TX + your stick PITCH TX ( only for PITCH ).

The servo ELEV is Always live with your stick ELEV TX + your stick PITCH TX (only for PITCH) ONLY with MOTOR TO OFF. With MOTOR TO ON , the SERVO ELEV is control by FLYBARLESS ( inclination + level ) + your stick ELEV TX + your stick PITCH TX ( only for PITCH ).
I HOPE THAT YOU UNDERSTAND ME , I'M ITALIAN AND NOT WRITE GOOD ENGLISH , SORRY.

Last edited by aranciata; 10-21-2014 at 05:16 AM..
aranciata is offline        Reply With Quote Quick reply to this message
Old 10-21-2014, 09:13 AM   #9 (permalink)
Registered Users
 

Join Date: Feb 2013
Default

i forget.....
when i buy my first mcpx also i send my board to HH with video that show this behavior.
The HH change me board for like, but my second board is equal to first.
After more time i buy second mcpx and i ceck that board is equal to board original the my first mcpx and i understand that board is ok!
on the video your i see your main gear that isn't good put. you push main gear good close main frame.
aranciata is offline        Reply With Quote Quick reply to this message
Reply




Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the HeliFreak forums, you must first register.
Please enter your desired user name, your REAL and WORKING email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself. Use a real email address or you will not be granted access to the site. Thank you.
Email Address:
Location
Where do you live? ie: Country, State, City or General Geographic Location please.
Name and Lastname
Enter name and last name here. (This information is not shown to the general public. Optional)
Helicopter #1
Enter Helicopter #1 type and equipment.
Helicopter #2
Enter Helicopter #2 type and equipment.
Helicopter #3
Enter Helicopter #3 type and equipment.
Helicopter #4
Enter Helicopter #4 type and equipment.

Log-in


Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On




Copyright © Website Acquisitions Inc. All rights reserved.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.

SEO by vBSEO 3.6.1