Fun, Learning, Friendship and Mutual Respect START  HERE


Unregistered
Go Back   HeliFreak > R/C Helicopter Support > Blade Helicopters (eFlite) > mCP X


mCP X Blade Micro CPx Helicopters Information and Help


Reply
 
LinkBack Thread Tools Display Modes
Old 03-31-2011, 09:29 AM   #101 (permalink)
Registered Users
 
Posts: 282
 
My HF Map location
Join Date: Aug 2006
Default

Quote:
Originally Posted by g13b View Post
my strange problem with Mcp.

Brought it today, first battery was fine nice stable flying.

second battery totally different- wouldnt lift off and was skating all over the ground.
holding it in hand, noticed on throttle up it was going negitive pitch.
AUX was off and hi/lo was high.

switching the AUX did nothing, hi/lo did nothing

pressing the bind/ trainer button made it go from negitive to positive but only while holding the botton down, once you let it go it goes back to neg.

any ideas?
Possibly a bad battery. I got a bad battery right out of the package, fully charged and cant fly with it, goes dead right away.
__________________
Blade 130 X, Trex 700E DFC, SAB Goblin 700, Gaui x5 FES.
DX 18QQ
cb3d is offline        Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 03-31-2011, 06:18 PM   #102 (permalink)
Registered Users
 

Join Date: Feb 2007
Default

I had a tough time getting my mCPx flying right the first day or two, but now the thing fly's like a champ. I also had the negative pitch problem out of the box, but what was really weird is that it would go back to zero pitch after a crash. Then after another crash it would go back to negative pitch. This occurred 3-4 times. I ended up making the mechanical adjustment, which was approximately 3 turns out on all 3-cyclic ball-links. Now it stays relatively correct at zero pitch center stick.

I haven't had bearing problems yet at all. I've got 30-40 flights on it. I've been able to do quite a few 3D moves pretty well. I've pummeled the thing relentlessly indoors and out. It definitely is preferable to fly this over grass.

I did stuff it really good yesterday on grass and when I got it back together and ready to fly one of the servos wouldn't operate properly. Upon further inspection, it turned out that the little servo motor had backed out of position and the servo gears were no longer making contact. I was able to slide the little motor down again and make it work OK.

I've spent $20 on parts, but I'm trying to fix a broken boom without buying a new one. Hopefully it'll work. My biggest problem has been breaking tail-booms.

Right before I stuffed it yesterday I had the best flight on it so far. It was really quite amazing to see this little thing doing backwards & forward hurricanes, tail-down funnels, fig.8 funnels, piro-funnels. I haven't tried a tictoc or piroflip. I don't think it'll tictoc--not enough power. But it might be able to piroflip. All-in-all this is a pretty amazing little bird.

My suggestion is to hang in there guys. This thing takes a little getting used to. But it'll do quite a few of the things the big birds do. I'm sure HH will make everything right with all the problems. But you need to spend some time doing the basics before getting crazy, and definitely get this thing down before bringing in doors where the crashes are much worse. I already ruined the lampshade on my wife side of the bed--ouch!

BTW, mines BNF w/Dx7
__________________
Rick
______________________________________

RC Helicopters: as addicting as crack, only more expensive!

(T-Rex 450SE, 401, 9650, hs-65mg) x 2
T-Rex 600CF, 401, 9654, S3151

Last edited by Gravitysucks; 03-31-2011 at 10:54 PM..
Gravitysucks is offline        Reply With Quote Quick reply to this message
Old 03-31-2011, 10:13 PM   #103 (permalink)
Registered Users
 
Posts: 464
 
My HF Map location
Join Date: Nov 2008
Default

Quote:
Originally Posted by silver2003tl View Post
New issue? Never flown, taken apart to do bearing mod and was waiting for the locktite to set. Sorry kind of long, feel free to jump to 1:00

http://www.youtube.com/watch?v=hyy5ueD8MFw


I've had a few 3 Blade MSR in the past and have repaired them about 10x each, usually only when the main board dies it's done. My guess is the main board is defective, or some strange noise/interference/voltage sag from the motors.

Question, when you spin (with your finger) the main large, white, gear, does it jump teeth on the motor gear? Mine does. Is the motor supposed to be really that tight?
I am not sure what is wrong there, maybe I did not watch far enough. If you are worried about the swash movement then don't be. It is a flybarless system. So if you hold the heli still, as you are doing, the swash will act strange because the gyros are looking for movement in that direction and will hold that way until they feel it.
Rago is offline        Reply With Quote Quick reply to this message
Old 03-31-2011, 10:59 PM   #104 (permalink)
Registered Users
 

Join Date: Feb 2009
Default

Quote:
Originally Posted by cb3d View Post
Possibly a bad battery. I got a bad battery right out of the package, fully charged and cant fly with it, goes dead right away.
Doesnt seem like battery because it does it with both batteries now.
And when i press the trainer button definalty changes it to positive pitch and tries to pull it our of my hand with plenty of power.

Ive tried re binding it but nothing.

I havnt crashed it, the first flight was just basic hovering with a few piros.

Maybe i need to crash it ;-)
g13b is offline        Reply With Quote Quick reply to this message
Old 04-04-2011, 08:00 AM   #105 (permalink)
Registered Users
 
Posts: 1,581
 
My HF Map location
Join Date: Nov 2009
Default

120sr tail wiring.

https://www.helifreak.com/showthread.php?t=294127

check it out. Works great.
__________________
-Joe
"Helis - wallet weight reduction made easy"
HeliArt Jskrapper @ youtube
Jskrapper is offline        Reply With Quote Quick reply to this message
Old 04-04-2011, 04:58 PM   #106 (permalink)
Registered Users
 

Join Date: Jan 2009
Default

Quote:
Originally Posted by g13b View Post
Doesnt seem like battery because it does it with both batteries now.
And when i press the trainer button definalty changes it to positive pitch and tries to pull it our of my hand with plenty of power.

Ive tried re binding it but nothing.

I havnt crashed it, the first flight was just basic hovering with a few piros.

Maybe i need to crash it ;-)
look at the bolded text - this is normally the case, if a non computerized TX hab been bound in computerized mode or vice versa (pos/neg pitch traversed).

I'd suggest trying to rebind it again and taking note of each single step (note that "GEAR full LEFT") while doing the binding proc. After final (thinks it's trainer button), your mCPX must be blinking (indicating TH-HOLD) if binding to "non computerized TX" has been successful.

HTH
Uli
UliZ is offline        Reply With Quote Quick reply to this message
Old 04-07-2011, 10:37 PM   #107 (permalink)
Registered Users
 

Join Date: Mar 2011
Default Bad mCP x Experience

I bought an SR at my LHS. They popped a battery in it, fired it up, adjusted the blade tracking, and flew it in the isle to make sure it was working correctly. Great service. Today, my 36 year old son stops by my work to show me his new purchase from the same LHS. Yep, an mCP x. I'd never seen one of these heli's before, so I got on HeliFreak to see what I could find. Man, was I impressed with the videos of this thing flying! Then I discovered some of the problems and the recall on the rotor head.

After work, I went to the LHS, and talked to the guy who sold it to my son. I asked him about the recall, and he gives me the "deer in the headlights look" and says all of the ones they have been getting were OK. I said did you check, and he says no. While driving home, I call my son and tell him not to fly it till I get there, and to check the blade grips for the "B". He doesn't think his has it. About 5 minutes later he calls me back and tells me the blades flew off of it and almost hit him. I said I thought I told you not to fly it, and he says all he did was spool it up while he held it in his hand. I think the screw came out that hold the blade grips on, but not sure. Needless to say we will both be visiting the LHS tomorrow, and returning this heli for one that is OK or a refund!
crazysheip is offline        Reply With Quote Quick reply to this message
Old 04-08-2011, 04:39 PM   #108 (permalink)
Registered Users
 
Posts: 132
 

Join Date: Dec 2010
Default

Just get the type 'b' blade grips
__________________
_______________________________
mCX2, mSR, mCPX, DX7, Phoenix Sim, Align 450 Sport, 2200mah Outrage 35C, 208B iCharger
UKBananas is offline        Reply With Quote Quick reply to this message
Old 04-09-2011, 09:28 AM   #109 (permalink)
Registered Users
 

Join Date: Jul 2009
Default

Quote:
Originally Posted by fly2day View Post
Third crash and bang rear ball on swashplate snapped off...looks like it is a major weak point since the local hobby store is sold out of swash plates already and they just got them and the mCPx in on Friday...%$#@...!

fix--- Buy extras... I am sure there will be an aluminum aftermarket out soon
I took a small needle heated it up and carefully made a hole where the ball broke off and tied the servo ball link to the swash with fishing line to the. works better then ever and hasn't broke yet.
rchelikiller is offline        Reply With Quote Quick reply to this message
Old 04-09-2011, 11:48 AM   #110 (permalink)
Registered Users
 
Posts: 1,903
 

Join Date: Sep 2009
Default

Quote:
Originally Posted by rchelikiller View Post
I took a small needle heated it up and carefully made a hole where the ball broke off and tied the servo ball link to the swash with fishing line to the. works better then ever and hasn't broke yet.
This is another great fix.
Heli G is offline        Reply With Quote Quick reply to this message
Old 04-09-2011, 01:02 PM   #111 (permalink)
Registered Users
 

Join Date: May 2006
Default

Quote:
Originally Posted by g13b View Post
my strange problem with Mcp.

Brought it today, first battery was fine nice stable flying.

second battery totally different- wouldnt lift off and was skating all over the ground.
holding it in hand, noticed on throttle up it was going negitive pitch.
AUX was off and hi/lo was high.

switching the AUX did nothing, hi/lo did nothing

pressing the bind/ trainer button made it go from negitive to positive but only while holding the botton down, once you let it go it goes back to neg.

any ideas?
If there's nothing physically wrong with the heli (like the main gear has slipped down), then try a rebind, mine does the same thing sometimes..I think its happens if you turn the heli on to quickly after turning the Tx on.
__________________
Warning this hobby is very addictive and may damage your wealth.

Last edited by Pigs dont fly; 04-09-2011 at 02:58 PM..
Pigs dont fly is offline        Reply With Quote Quick reply to this message
Old 04-10-2011, 01:02 PM   #112 (permalink)
Registered Users
 

Join Date: Mar 2011
Default

I noticed after a good crash into the side walk that I had a bad high speed wobble or vibration. I replaced. Main shaft, feathering shaft, checked drive gear, replaced the rotor blades swash plate, still could not remedy the shake, finally replaced the grips after all that was the only thing left to replace and. Walla. Vibration solved. The grips looked good but were the problem all. Along 2 days worth of severe frustration I hope this helps anyone else that might be suffering.
xlineapex is offline        Reply With Quote Quick reply to this message
Old 04-11-2011, 02:51 PM   #113 (permalink)
Registered Users
 
Posts: 821
 

Join Date: Jan 2011
Default

Hey, if we are talking about mCPX issues, I was searching for some E-Flite spares , including for the mCPX, and wandered across a good deal for some parts I wanted for a scale project.

Bottom line: Be careful of who you deal with in the online arena. Some are willing to go the extra mile, and somee... well...

Just wanted to share a quick heads up if you are looking for mcpx parts like I was, buyer beware of sharp practices:

http://www.rcgroups.com/forums/showp...97&postcount=1
tracknoob is offline        Reply With Quote Quick reply to this message
Old 04-15-2011, 02:03 AM   #114 (permalink)
Registered Users
 

Join Date: Sep 2010
Default

This is to g13b make sure your hi/low rate switch is set to high (If using the DX4E) when you plug your heli in or it will always do that. It always happens to me because I use low rate in the house for safety reasons.
heligod is offline        Reply With Quote Quick reply to this message
Old 04-17-2011, 02:10 AM   #115 (permalink)
Registered Users
 

Join Date: Apr 2011
Default

Quote:
Originally Posted by Pigs dont fly View Post
If there's nothing physically wrong with the heli (like the main gear has slipped down), then try a rebind, mine does the same thing sometimes..I think its happens if you turn the heli on to quickly after turning the Tx on.
I had the exact same symptoms and fixed it with a rebind.
Grymm is offline        Reply With Quote Quick reply to this message
Old 04-17-2011, 02:13 AM   #116 (permalink)
Registered Users
 

Join Date: Apr 2011
Default

A warning to everyone, I just had a blade fire off (man do they fly when they let go!) while spinning up on the ground preparing for takeoff. (Already ordered the replacement recall part).

Anyway when the blade/grip flew off it broke the weak pitch ball/pivot on the back of the swashplate that has been mentioned as a weak point... so here I am.... new chopper with a busted swashplate =(
Grymm is offline        Reply With Quote Quick reply to this message
Old 04-17-2011, 06:12 AM   #117 (permalink)
Registered Users
 

Join Date: Apr 2011
Default

Quote:
Originally Posted by g13b View Post
Doesnt seem like battery because it does it with both batteries now.
And when i press the trainer button definalty changes it to positive pitch and tries to pull it our of my hand with plenty of power.

Ive tried re binding it but nothing.

I havnt crashed it, the first flight was just basic hovering with a few piros.

Maybe i need to crash it ;-)

The re-binding is a bit tricky, took me several goes to get it right.
Lunar is offline        Reply With Quote Quick reply to this message
Old 04-17-2011, 06:28 PM   #118 (permalink)
Registered Users
 
Posts: 1,277
 
My HF Map location
Join Date: Nov 2009
Default

The blade grip failed on me the second flight with my mCP. I replaced the bearings using the proper orientation and flew about 50+ flights with no problems, then I had another failure. This was after I had just checked out the heli including the feathering shaft, the outer bearing failed. I have replaced the bearings with Walkera and as well as the feathering shaft. I will see how it holds up this time.
__________________
AMA #844172 DJI S1000 Lightbridge Zen for 5D, S900 LB Zen for BMPCC, DJI Phantom 2 Vision +, P2Z2 with Data Link, P2Z3 with LB DJI Forum Support
Tahoe Ed is offline        Reply With Quote Quick reply to this message
Old 04-18-2011, 07:55 PM   #119 (permalink)
Registered Users
 

Join Date: Mar 2011
Default

how can i fix a broken swash ball? its the one in the back
ShivumDOui is offline        Reply With Quote Quick reply to this message
Old 04-19-2011, 08:04 AM   #120 (permalink)
Registered Users
 

Join Date: Mar 2011
Default

me too. love it. and it's saved a fortune because it generally doesnt break on crashes and when it does it's cheap to fix.
yawdamper is offline        Reply With Quote Quick reply to this message
Reply




Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the HeliFreak forums, you must first register.
Please enter your desired user name, your REAL and WORKING email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself. Use a real email address or you will not be granted access to the site. Thank you.
Email Address:
Location
Where do you live? ie: Country, State, City or General Geographic Location please.
Name and Lastname
Enter name and last name here. (This information is not shown to the general public. Optional)
Helicopter #1
Enter Helicopter #1 type and equipment.
Helicopter #2
Enter Helicopter #2 type and equipment.
Helicopter #3
Enter Helicopter #3 type and equipment.
Helicopter #4
Enter Helicopter #4 type and equipment.

Log-in


Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On




Copyright © Website Acquisitions Inc. All rights reserved.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.

SEO by vBSEO 3.6.1