Fun, Learning, Friendship and Mutual Respect START  HERE


Unregistered
Go Back   HeliFreak > R/C Helicopter Support > Blade Helicopters (eFlite) > mCP X


mCP X Blade Micro CPx Helicopters Information and Help


Reply
 
LinkBack Thread Tools Display Modes
Old 03-12-2011, 09:00 PM   #1 (permalink)
Registered Users
 

Join Date: Oct 2010
Default Does your mCPX have a vibration?

Got mine yesterday. Can not get it to take off straight up. Don't know if this is the problem but while throttling up. just at the point before it lifts off it gets this loud vibration. Do they all do that?

Thanks!
__________________
_______________________________________
Mavic Pro - Inspire 1V2 - Blade Apache AH-64 - NanoCPS - Trex 600N - Spektrum DX7G2 - Assorted Blade small helicopters - Pitts S1-S airplane
Keith C. is offline        Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 03-12-2011, 09:02 PM   #2 (permalink)
Registered Users
 
Posts: 12,296
 

Join Date: Aug 2010
Default

How is it in the air.

All Cp helis want to go right on take off.

Check your blade grips to make sure there isn't any play

Sent from my A854 using Tapatalk
Jeff_Barrett is offline        Reply With Quote Quick reply to this message
Old 03-12-2011, 09:03 PM   #3 (permalink)
Registered Users
 
Posts: 320
 

Join Date: Jan 2011
Default

Quote:
Originally Posted by Keith C. View Post
Got mine yesterday. Can not get it to take off straight up. Don't know if this is the problem but while throttling up. just at the point before it lifts off it gets this loud vibration. Do they all do that?

Thanks!
Check that your main gear has not dropped down. You should be able to see 2mm of shaft extending below the gear.
davidpe is offline        Reply With Quote Quick reply to this message
Old 03-12-2011, 09:05 PM   #4 (permalink)
Registered Users
 
My HF Map location
Join Date: Jan 2008
Default

I get it once in a while to. Ground resonance maybe. A little quicker through the collective, and no problems.
thetable is offline        Reply With Quote Quick reply to this message
Old 03-12-2011, 09:31 PM   #5 (permalink)
Registered Users
 

Join Date: Jan 2011
Default

Every time I get vibration on the ground, the reason is the main gear has slipped after a crash.
__________________
Wayne Bengston
Gootch 450 Pro, Walkera 4G3 & 4G6
Blade 120 SR and mCP X
PZ Night Vapor, Ember and UM Mosquito. M-A-E Penguin
VaderSS is offline        Reply With Quote Quick reply to this message
Old 03-12-2011, 09:38 PM   #6 (permalink)
Registered Users
 
Posts: 7,587
 

Join Date: Feb 2010
Default

Are you sure it is not just the tail motor spinning up?This caught me off guard,I go to take off and hear this incredible high pitched whine.....It turns out it is the little tail motor screaming up to speed....They sound real bad if the blades are not twisted evenly,if you look close you can see if they are out of track..
__________________
700 class nitro,2X 600class electric,2X 450class,250 class,130 class,a few mcpx class().Dx-7.All helis fbl...If I had a dollar for every dollar I've spent on heli's ...I would break even.
.Who is John Galt?
755 robert is offline        Reply With Quote Quick reply to this message
Old 03-12-2011, 10:21 PM   #7 (permalink)
Registered Users
 

Join Date: Mar 2011
Default Servo Noise

Is Anyone elses mcp x making servo noise when you plug in the battery and its just sitting there?
bryan_mccombs2001@yahoo.c is offline        Reply With Quote Quick reply to this message
Old 03-12-2011, 10:50 PM   #8 (permalink)
Registered Users
Thread Starter Thread Starter
 

Join Date: Oct 2010
Default

Still having problems. Took your advice...Was a little play in the blade grips--I snugged the screws up til it was gone. My main gear had dropped down--the end of the shaft was up in the gear, I fixed that. Still have the vibration but like thetable said it goes away once you get past a certain point of accelleration

Still can not get it to fly straight. It take off and goes hard to the left and rear. I tried trim and subtrim and it just falls over before it takes off. Can't get it to hover in the confines of a '20 X '20 room with minimal furniture which I thought I would be able to. According to the video that came with it you should be able to raise the throttle and without touching the cyclic it should hover. I'll keep working on it but any more suggestions would be great. Thanks to all!
__________________
_______________________________________
Mavic Pro - Inspire 1V2 - Blade Apache AH-64 - NanoCPS - Trex 600N - Spektrum DX7G2 - Assorted Blade small helicopters - Pitts S1-S airplane
Keith C. is offline        Reply With Quote Quick reply to this message
Old 03-12-2011, 11:12 PM   #9 (permalink)
Registered Users
 
Posts: 537
 

Join Date: Nov 2008
Default touching the cyclic

don't touch the rudder either
__________________
Nailed the $20 landing , now what ?
chrisconn2 is offline        Reply With Quote Quick reply to this message
Old 03-13-2011, 12:28 AM   #10 (permalink)
Registered Users
 
Posts: 12,296
 

Join Date: Aug 2010
Default

Quote:
Originally Posted by Keith C. View Post
Still having problems. Took your advice...Was a little play in the blade grips--I snugged the screws up til it was gone. My main gear had dropped down--the end of the shaft was up in the gear, I fixed that. Still have the vibration but like thetable said it goes away once you get past a certain point of accelleration

Still can not get it to fly straight. It take off and goes hard to the left and rear. I tried trim and subtrim and it just falls over before it takes off. Can't get it to hover in the confines of a '20 X '20 room with minimal furniture which I thought I would be able to. According to the video that came with it you should be able to raise the throttle and without touching the cyclic it should hover. I'll keep working on it but any more suggestions would be great. Thanks to all!
Zero out all trim and subtrim on your TX before plugging in your heli. Most FBL units get mixed up with trim since the FBL unit itself does the mixing, not the TX.
Jeff_Barrett is offline        Reply With Quote Quick reply to this message
Old 03-13-2011, 12:29 AM   #11 (permalink)
Registered Users
 
Posts: 12,296
 

Join Date: Aug 2010
Default

Quote:
Originally Posted by [email protected] View Post
Is Anyone elses mcp x making servo noise when you plug in the battery and its just sitting there?
Yep. Typical of FBL system ... my Rondo and Skookum units all cause the servos to buzz / hum a little. Remember, all of your servos are now attached to a gyro instead of only one (your rudder).
Jeff_Barrett is offline        Reply With Quote Quick reply to this message
Old 03-13-2011, 12:46 AM   #12 (permalink)
Registered Users
 

Join Date: Jan 2011
Default

Quote:
Originally Posted by Keith C. View Post
Still h
Still can not get it to fly straight. It take off and goes hard to the left and rear. I tried trim and subtrim and it just falls over before it takes off. Can't get it to hover in the confines of a '20 X '20 room with minimal furniture which I thought I would be able to. According to the video that came with it you should be able to raise the throttle and without touching the cyclic it should hover. I'll keep working on it but any more suggestions would be great. Thanks to all!

With the exception of pitch, you should have no trims in.

The first few time I spooled mine up, it tipped over. The next time, I tried just popping it in the air and it flew straight at a book shelf. I tried to catch it, could not, and pulled TH.

The next time, when it tried to tilt on the ground, I put in correction on the cyclic and played with it until it stopped wanting to tilt, then I took off and achieved hover.

Mine still wants to tip over at times, and I just correct it with the cyclic until it is holding level on the ground, and then take off.
__________________
Wayne Bengston
Gootch 450 Pro, Walkera 4G3 & 4G6
Blade 120 SR and mCP X
PZ Night Vapor, Ember and UM Mosquito. M-A-E Penguin
VaderSS is offline        Reply With Quote Quick reply to this message
Old 03-13-2011, 01:23 AM   #13 (permalink)
Registered Users
Thread Starter Thread Starter
 

Join Date: Oct 2010
Default

Quote:
Originally Posted by Crazy_Canuck View Post
Zero out all trim and subtrim on your TX before plugging in your heli. Most FBL units get mixed up with trim since the FBL unit itself does the mixing, not the TX.
So this means if your heli shoots off to the left on takeoff you don't add any trim? Ok I'll try anything at this point.

Thanks again, all great ideas.
__________________
_______________________________________
Mavic Pro - Inspire 1V2 - Blade Apache AH-64 - NanoCPS - Trex 600N - Spektrum DX7G2 - Assorted Blade small helicopters - Pitts S1-S airplane
Keith C. is offline        Reply With Quote Quick reply to this message
Old 03-13-2011, 10:31 AM   #14 (permalink)
Registered Users
 
Posts: 79
 

Join Date: Feb 2010
Default

My heli has a bad vibrations here and there..Straight out the box is had it..I started going thru different things and noticed the head had some vertical slop..slid the gear up and it helped but fast forward fllight it comes back..I talked to a lhs and they said they talked to hh about this problem.I guess hh said it sounds like you know alot about helis, so if you figure it out,call us and let us know what the problem is..Lhs said its only $150 heli,you get what you pay for..What kind of crap is that??Any advice??
smokingcopter is offline        Reply With Quote Quick reply to this message
Old 03-13-2011, 10:34 AM   #15 (permalink)
Registered Users
 

Join Date: Jun 2007
Default

Quote:
Originally Posted by Crazy_Canuck View Post
Zero out all trim and subtrim on your TX before plugging in your heli. Most FBL units get mixed up with trim since the FBL unit itself does the mixing, not the TX.
sub trim is ok but you need to rebind after setting it
the heli should see it as the new center for the channel
__________________
DX8
mSR, T-rex 500ESP 3G, Compass 6HV Savox servos Vbar 5.3Pro Rail Blades
AMA#948801
Elios000 is offline        Reply With Quote Quick reply to this message
Old 03-13-2011, 10:40 AM   #16 (permalink)
Registered Users
 
Posts: 942
 
My HF Map location
Join Date: Sep 2006
Default

mine has a bad pulsating vibration out of the box,comes and goes . am going to try snugging up the blades as posted above . also I'm real disappointed in the fact the tail wont hold ,blows out just trying to do slow backward flight
OHIOBOWHUNTER is offline        Reply With Quote Quick reply to this message
Old 03-13-2011, 10:44 AM   #17 (permalink)
Registered Users
 
Posts: 12,296
 

Join Date: Aug 2010
Default

I disagree. There's not one fbl system out therev that advocates the use of trim or subtrim. The manuals all tell you to remove all trim and subtrim.

Yeah, it might work, but its not the best fix for possible poor mechanical setup.

Sent from my A854 using Tapatalk
Jeff_Barrett is offline        Reply With Quote Quick reply to this message
Old 03-13-2011, 10:45 AM   #18 (permalink)
Registered Users
 

Join Date: Jun 2007
Default

Quote:
Originally Posted by Crazy_Canuck View Post
I disagree. There's not one fable system out therev that advocates the use of trim or subtrim.

Yeah, it might work, but its not the best fix for possible poor mechanical setup.

Sent from my A854 using Tapatalk
3G is fine with sub trim but you must rebind to use it for the system to see it as the new centers
again only sub trim still cant use normal trim but sub trim is fine
__________________
DX8
mSR, T-rex 500ESP 3G, Compass 6HV Savox servos Vbar 5.3Pro Rail Blades
AMA#948801
Elios000 is offline        Reply With Quote Quick reply to this message
Old 03-13-2011, 01:24 PM   #19 (permalink)
Registered Users
 
Posts: 79
 

Join Date: Feb 2010
Default

My mcp x just has so much vibrations,Im ready to send it back to hh..Should have waited to find out peoples thoughts about the heli..Just not a very happy camper..
smokingcopter is offline        Reply With Quote Quick reply to this message
Old 03-13-2011, 02:22 PM   #20 (permalink)
Registered Users
 
Posts: 942
 
My HF Map location
Join Date: Sep 2006
Default

Quote:
Originally Posted by smokingcopter View Post
My mcp x just has so much vibrations,Im ready to send it back to hh..Should have waited to find out peoples thoughts about the heli..Just not a very happy camper..
+1 i wish I had the 170.00 back I tried looser grips ,tighter grips and the bullet blades....still shakes like crazy ,oh and the fact that the tail does'nt hold any more than a rate gyro. I guess the one HH used to make the pitch video was a "custom job " not like the production ones. shoulda known better than to buy anything from HH !!!:argg g:
OHIOBOWHUNTER is offline        Reply With Quote Quick reply to this message
Reply




Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the HeliFreak forums, you must first register.
Please enter your desired user name, your REAL and WORKING email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself. Use a real email address or you will not be granted access to the site. Thank you.
Email Address:
Location
Where do you live? ie: Country, State, City or General Geographic Location please.
Name and Lastname
Enter name and last name here. (This information is not shown to the general public. Optional)
Helicopter #1
Enter Helicopter #1 type and equipment.
Helicopter #2
Enter Helicopter #2 type and equipment.
Helicopter #3
Enter Helicopter #3 type and equipment.
Helicopter #4
Enter Helicopter #4 type and equipment.

Log-in


Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On




Copyright © Website Acquisitions Inc. All rights reserved.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.

SEO by vBSEO 3.6.1