Fun, Learning, Friendship and Mutual Respect START  HERE


Unregistered
Go Back   HeliFreak > R/C Helicopter Support > Blade Helicopters (eFlite) > mCP X


mCP X Blade Micro CPx Helicopters Information and Help


Reply
 
LinkBack Thread Tools Display Modes
Old 03-17-2011, 12:19 AM   #1 (permalink)
Registered Users
 
Posts: 24
 

Join Date: Jun 2008
Default Terrible vibration..?

I've had this little heli for a week now and it was fine Foward flight , flipping, yesterday i broke a swash .. replaced it and today it had a horrible vibration.. so i replaced the blades, grips, main hub, spindle.. and it still has the vibration.. my blades are loose not too tight .. i'm lost...it also seems like i lost a bit of my positive pitch.. but the gear is up all the way.. just wondering if someone has narrowed it down yet.. i love this little heli other than this i have no complaints.. any help would be greatly appreciated!
crzyhare2344 is offline        Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 03-17-2011, 12:21 AM   #2 (permalink)
Registered Users
 
Posts: 821
 

Join Date: Jan 2011
Default

Quote:
Originally Posted by crzyhare2344 View Post
I've had this little heli for a week now and it was fine Foward flight , flipping, yesterday i broke a swash .. replaced it and today it had a horrible vibration.. so i replaced the blades, grips, main hub, spindle.. and it still has the vibration.. my blades are loose not too tight .. i'm lost...it also seems like i lost a bit of my positive pitch.. but the gear is up all the way.. just wondering if someone has narrowed it down yet.. i love this little heli other than this i have no complaints.. any help would be greatly appreciated!
Highlighted part makes it a dead give away -- your maingear has almost certainly slid down the shaft. You need to gently but firmly snap it back home where it belongs.
tracknoob is offline        Reply With Quote Quick reply to this message
Old 03-17-2011, 12:25 AM   #3 (permalink)
Registered Users
 
Posts: 24
Thread Starter Thread Starter
 

Join Date: Jun 2008
Default

I have also replaced the main gear with i forgot to mention in the above post.. i can push on the gear as hard as i can and it won't go up any farther.. there isn't any play in the shaft.. i'm wondering if its the FBL unit..
crzyhare2344 is offline        Reply With Quote Quick reply to this message
Old 03-17-2011, 12:45 AM   #4 (permalink)
Registered Users
 
Posts: 292
 
My HF Map location
Join Date: Nov 2006
Thumbs up

Did you make sure to line up the flat on the shaft and the main gear?
There should be about 1mm of the main shaft sticking out below the gear.
__________________
I want just one Heli... so I got some !!!!!! and a bunch of other stuff too
Russers is offline        Reply With Quote Quick reply to this message
Old 03-17-2011, 12:56 AM   #5 (permalink)
Registered Users
 
Posts: 24
Thread Starter Thread Starter
 

Join Date: Jun 2008
Default

Yes i have made sure the flat spot lines up, and yes there is at least a 1mm sticking out under the gear.. i'm just baffled haha i hate when i can't fix things lol
crzyhare2344 is offline        Reply With Quote Quick reply to this message
Old 03-17-2011, 01:27 AM   #6 (permalink)
Registered Users
 
Posts: 7,587
 

Join Date: Feb 2010
Default

You might check the servos,make sure the brass end keepers have not moved ..
__________________
700 class nitro,2X 600class electric,2X 450class,250 class,130 class,a few mcpx class().Dx-7.All helis fbl...If I had a dollar for every dollar I've spent on heli's ...I would break even.
.Who is John Galt?
755 robert is offline        Reply With Quote Quick reply to this message
Old 03-18-2011, 11:14 PM   #7 (permalink)
Registered Users
 
Posts: 24
Thread Starter Thread Starter
 

Join Date: Jun 2008
Default

Finally figured it out ! thanks to 755 robert .. swapped out the board with a friends and it still acted up replaced everything double checked everything and then finally realized it was my aileron servo pulsating up and down very fast when the problem would occur.. don't know if there's any way to fix this other than to replace the servo..but at least now i don't have to send it back to HH and wait for weeks or possibly months for the new " better improved" mcpx's that they are going to replace with. Hopefully they will send me a replacement servo due to the fact they are back ordered.., but its definately the servo. I even swapped it with my pitch servo to make sure it wasn't the board .. its definately that particular servo. hope this helps with some other headaches this little thing has caused!
crzyhare2344 is offline        Reply With Quote Quick reply to this message
Old 03-18-2011, 11:47 PM   #8 (permalink)
Registered Users
 
Posts: 1,242
 

Join Date: Mar 2008
Default

Quote:
Originally Posted by crzyhare2344 View Post
Finally figured it out ! thanks to 755 robert .. swapped out the board with a friends and it still acted up replaced everything double checked everything and then finally realized it was my aileron servo pulsating up and down very fast when the problem would occur.. don't know if there's any way to fix this other than to replace the servo..but at least now i don't have to send it back to HH and wait for weeks or possibly months for the new " better improved" mcpx's that they are going to replace with. Hopefully they will send me a replacement servo due to the fact they are back ordered.., but its definately the servo. I even swapped it with my pitch servo to make sure it wasn't the board .. its definately that particular servo. hope this helps with some other headaches this little thing has caused!
I know this is going to sound crazy, but try rebinding it to your radio. I had this very same problem! I had lost some positive pitch and it would violently shake a couple times a flight. my main gear was pushed up all the way as I check this after each crash. Finless and I had the same problem at the field last weekend, and we couldn't figure it out. Two hours later he calls my phone and lets me know a friend of ours suggested Rebinding. Bob said what the hell and tried it, sure enough he relayed that message to me, I rebinded on the same model without changing anything and it flew like it did the first day I got her. I cant explain why, but Finless does a pretty good job with his explanation how it works with the servos, its kind of like leveling your swash after so many crashes and slop in the servos occur. Give it a try and and let me know if it fixes the problem
__________________
That's right Iceman, I am dangerous
trainwreck is offline        Reply With Quote Quick reply to this message
Old 03-21-2011, 02:41 PM   #9 (permalink)
Registered Users
 
My HF Map location
Join Date: Nov 2010
Default

Check this thread also - seems less likely since yours is relatively new but....

https://www.helifreak.com/showthread.php?t=289666
__________________
Always learning, and enjoying the process!
mejmea is offline        Reply With Quote Quick reply to this message
Old 03-21-2011, 03:57 PM   #10 (permalink)
Registered Users
 
Posts: 12,944
 
My HF Map location
Join Date: May 2010
Location: Longuyland, NY
Default

Also... Check the studs on your swash hub, they are the next component in line (after the blades, grips and spindle) to take shock when you crash. And last but not least, after a hard inverted crash the servo-swash push rods on my mCP pushed in slightly, giving me a few degrees of negative pitch at zero stick along with a tilted swash.

After I zeroed it out at center stick it was perfect.

First and foremost, check for anything bent, seperated, popped out, slipped or broken first. Just as stated above.
__________________
~SAB~ Goblin 700 ~Compass~ Warp 360 ~Blade~ mCP X (BL)
AMA# 977012
**Team BOCA Bearings**
BaconRaygun is offline        Reply With Quote Quick reply to this message
Reply




Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the HeliFreak forums, you must first register.
Please enter your desired user name, your REAL and WORKING email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself. Use a real email address or you will not be granted access to the site. Thank you.
Email Address:
Location
Where do you live? ie: Country, State, City or General Geographic Location please.
Name and Lastname
Enter name and last name here. (This information is not shown to the general public. Optional)
Helicopter #1
Enter Helicopter #1 type and equipment.
Helicopter #2
Enter Helicopter #2 type and equipment.
Helicopter #3
Enter Helicopter #3 type and equipment.
Helicopter #4
Enter Helicopter #4 type and equipment.

Log-in


Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On




Copyright © Website Acquisitions Inc. All rights reserved.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.

SEO by vBSEO 3.6.1