down and out - HeliFreak
Fun, Learning, Friendship and Mutual Respect START  HERE


Unregistered
Go Back   HeliFreak > R/C Helicopter Support > Blade Helicopters (eFlite) > Blade 400


Blade 400 Blade Helicopters (eFlite) 400 Helicopters


Reply
 
LinkBack Thread Tools Display Modes
Old 10-06-2011, 07:29 PM   #1 (permalink)
Registered Users
 

Join Date: Sep 2009
Location: new westminster,B.C. canada
Default down and out

I was flying my blade 400 and thump. Blade fell out of the sky.No real damage but receiver was flashing steadily. I rebound it to transmitter and after the three beeps it continued blinking continuously.Any ideas whats going on? I put in a brand new receiver that i got from horizonhobby but after binding the led starts flashing and all cyclic servos go up and down at the same time, same thing it didwhen it origionally fell from the sky.I am stumped.
turko is offline        Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 10-07-2011, 03:17 AM   #2 (permalink)
Registered Users
 

Join Date: Feb 2009
Location: uk
Default

Quote:
Originally Posted by turko View Post
I was flying my blade 400 and thump. Blade fell out of the sky.No real damage but receiver was flashing steadily. I rebound it to transmitter and after the three beeps it continued blinking continuously.Any ideas whats going on? I put in a brand new receiver that i got from horizonhobby but after binding the led starts flashing and all cyclic servos go up and down at the same time, same thing it didwhen it origionally fell from the sky.I am stumped.
I got a spectrum receiver yesterday in the post it binded and i was doing tests on my heli , When i went back the next day there was a red blinking light , i tried the rebind many times but it just wouldnt so i have sent an email to the hobby shop . Just want to point out i dont think it matters how much you pay out for good quality goods there still probably made in china as cheap as possible
dazzzer30 is offline        Reply With Quote Quick reply to this message
Old 10-07-2011, 09:04 AM   #3 (permalink)
Registered Users
 
Posts: 5,418
 

Join Date: Apr 2008
Location: Central Ca
Default

Reciever will flash if you never cycled the radio between batterys ..meaning if you change batterys without turning the radio off and on it will flash , this is normal .
__________________
700LE : 105HZR AR7200BX JR8917 Multi gov , JR9503
600ESP : 100AMP Castle. Scorpion Motor . AMA #962896
400 Blade : Scorpion 2221-6 ,Castle ICE 50 Sonix Head and t
Align 450 pro V2 3G MKS DS95 MSR , 2 x MCPX (brushless C05 & HP05), Blade 130X.
whoanelly is offline        Reply With Quote Quick reply to this message
Old 10-07-2011, 12:45 PM   #4 (permalink)
Registered Users
Thread Starter Thread Starter
 

Join Date: Sep 2009
Location: new westminster,B.C. canada
Default problem solved

It turns out that it was my tail servo that died taking the elevator servo with it that caused all my problems.good old trial and error solved the problem and im back in the air as soon as the rain stops.
turko is offline        Reply With Quote Quick reply to this message
Reply




Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the HeliFreak forums, you must first register.
Please enter your desired user name, your REAL and WORKING email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself. Use a real email address or you will not be granted access to the site. Thank you.
Email Address:
Location
Where do you live? ie: Country, State, City or General Geographic Location please.
Name and Lastname
Enter name and last name here. (This information is not shown to the general public. Optional)
Helicopter #1
Enter Helicopter #1 type and equipment.
Helicopter #2
Enter Helicopter #2 type and equipment.
Helicopter #3
Enter Helicopter #3 type and equipment.
Helicopter #4
Enter Helicopter #4 type and equipment.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On




Copyright © Website Acquisitions Inc. All rights reserved.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2018 DragonByte Technologies Ltd.
 

SEO by vBSEO 3.6.1