Tail pitch control yoke unscrewed - HeliFreak
Fun, Learning, Friendship and Mutual Respect START  HERE


Unregistered
Go Back   HeliFreak > R/C Helicopter Support > Electric Micro/Mini Helicopters > Zoom/Shogun 400


Zoom/Shogun 400 Electric - Zoom - Shogun 400 Specific Discussion


Reply
 
LinkBack Thread Tools Display Modes
Old 06-25-2007, 08:48 AM   #1 (permalink)
Registered Users
 

Join Date: Aug 2006
Location: Norway
Default Tail pitch control yoke unscrewed

Hi there fellas.
I'm pretty newbie and living in Norway over seas.

How do i mount this brass slider which is screwed into the aluminum control yoke of the tail pitch control unit?
I have a zap400 v2 and it suddently unscrewed under a hovering excersise.

Exsample pictures of the simular problem can be viewed here:
https://www.helifreak.com/viewtopic.php?t=40875
skybird is offline        Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 06-26-2007, 12:52 PM   #2 (permalink)
Registered Users
 

Join Date: Jul 2005
Location: Illinois
Default

i don't recell the stock slider having threads. if i remember right, the innner race of the pitch slider bearing is a press fit over the plastic slider itself which has a brass bushing installed between the plastic slider and tailshaft. apply some ca and press it back in place being careful not to get ca on the moving parts.
hueyman is offline        Reply With Quote Quick reply to this message
Old 06-27-2007, 03:08 PM   #3 (permalink)
Registered Users
Thread Starter Thread Starter
 

Join Date: Aug 2006
Location: Norway
Default

hueyman: Hi there and thanx for your answer. The brass bushing did have some threads, but it was impossible to screw it back on, so i took some locktite and applied it to the brass and slided the parts together and added some more locktite to the yoke part, making sure i didn't spill any glue on the shaft. This worked perfectly ;-)
skybird is offline        Reply With Quote Quick reply to this message
Old 06-29-2007, 07:26 PM   #4 (permalink)
Registered Users
Thread Starter Thread Starter
 

Join Date: Aug 2006
Location: Norway
Default

I fixed it :-)
skybird is offline        Reply With Quote Quick reply to this message
Reply




Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the HeliFreak forums, you must first register.
Please enter your desired user name, your REAL and WORKING email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself. Use a real email address or you will not be granted access to the site. Thank you.
Email Address:
Location
Where do you live? ie: Country, State, City or General Geographic Location please.
Name and Lastname
Enter name and last name here. (This information is not shown to the general public. Optional)
Helicopter #1
Enter Helicopter #1 type and equipment.
Helicopter #2
Enter Helicopter #2 type and equipment.
Helicopter #3
Enter Helicopter #3 type and equipment.
Helicopter #4
Enter Helicopter #4 type and equipment.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On




Copyright © Website Acquisitions Inc. All rights reserved.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2018 DragonByte Technologies Ltd.
 

SEO by vBSEO 3.6.1