DX6i timer weirdness - HeliFreak
Fun, Learning, Friendship and Mutual Respect START  HERE


Unregistered
Go Back   HeliFreak > R/C Electronics Support > JR and Spektrum Radios and Electronics


JR and Spektrum Radios and Electronics JR and Spektrum Radios, Gyros, Servos, Etc.


Reply
 
LinkBack Thread Tools Display Modes
Old 05-05-2012, 03:59 AM   #1 (permalink)
Registered Users
 
Posts: 423
 
My HF Map location
Join Date: Jun 2007
Location: El Cajon, CA
Default DX6i timer weirdness

I've had this radio, which I purchased new, for 11 months now and everything has been fine, but I had only 2 models on it, and both were helis. In the last 2 months I have expanded my fleet to include 2 MCPx's, a UMx GeeBee, a Twisted Hobbies EPP foamie, and a Miss Hyperion hydrofoam. All of the model selections and all of the control functions work fine on the various models, but the timer keeps randomly resetting. I have all of my models set to count down, and use the timer switch to activate. Now I notice my timer is counting up instead of down, and it switches randomly from one model to the next, so that I have to check it every time I fly a particular model. I have tried setting all of the switch's to "0" before I turn it off, I've tried not turning it off before flying a model I switch to, and every other senario you can think of. Nothing seems to help or make a difference. As I said, it is quite random. It wouldnt even really be a problem, but it always resets to 6 min., and not everything I have flies for 6 min. Just curious if anyone else has had or knows of this issue, or am I just the "lucky one"?
__________________
My Dawgz Got Madd Skillzz!
Heli #1:Gaui 200V?/FBL/BeastX V2.05/Gaui 5600/CC25/5065 MG's/DS09 GMD/Spektrum Sat.
Heli #2:Gaui 200V?/FBL/Gaui 5600/CC 25 ESC/65 MG's/BeastX V3.08/DS09 GMD/Spektrum Sat.
dynodude is offline        Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 05-05-2012, 11:28 AM   #2 (permalink)
Registered Users
 
Posts: 4,006
 
My HF Map location
Join Date: Oct 2009
Location: Lafayette, LA., USA
Default

Sounds like you might be one of the "Lucky ones" . I think there is a service bulletin out on the issue. It has come up before. You might check Spektrum's website.

https://www.helifreak.com/search.php?searchid=9254944
__________________
Trex 500-3226-1600, 14T, Koby 90LV, HS-5245MG, DS655, AR7200BX, DFC
Trex 450 Sport-2221-8, 15T, CC Edge 50 Lite, HS-5065MG, HSG-5084MG, AR7200BX, DFC
DX8
wanderer56 is offline        Reply With Quote Quick reply to this message
Old 05-06-2012, 05:18 AM   #3 (permalink)
Registered Users
 
Posts: 423
Thread Starter Thread Starter
 
My HF Map location
Join Date: Jun 2007
Location: El Cajon, CA
Default

Yep, you're right. I did a search and found this is a well known problem. Seems to be some type of firmware issue. What is odd is I have seen alot of discussion on the problem, but not a fix. Seems you have to send TX and no one does. Might give Horizon or Spektrum a call and see what they have to say about it.Thanks for the heads up.
__________________
My Dawgz Got Madd Skillzz!
Heli #1:Gaui 200V?/FBL/BeastX V2.05/Gaui 5600/CC25/5065 MG's/DS09 GMD/Spektrum Sat.
Heli #2:Gaui 200V?/FBL/Gaui 5600/CC 25 ESC/65 MG's/BeastX V3.08/DS09 GMD/Spektrum Sat.
dynodude is offline        Reply With Quote Quick reply to this message
Old 05-06-2012, 07:07 AM   #4 (permalink)
Registered Users
 
Posts: 4,006
 
My HF Map location
Join Date: Oct 2009
Location: Lafayette, LA., USA
Default

That's ashame. The DX6i was such a trouble free tx. It seems like a lot of these started with the DSMX release.
__________________
Trex 500-3226-1600, 14T, Koby 90LV, HS-5245MG, DS655, AR7200BX, DFC
Trex 450 Sport-2221-8, 15T, CC Edge 50 Lite, HS-5065MG, HSG-5084MG, AR7200BX, DFC
DX8
wanderer56 is offline        Reply With Quote Quick reply to this message
Old 05-08-2012, 01:34 PM   #5 (permalink)
Registered Users
 

Join Date: Apr 2012
Location: Seattle, WA, USA
Default Same problem....

intermittant-not all the time.

Unfortunaley I modded my Tx (backlight) and now I can't send it back?

Tedolph
Tedolph is offline        Reply With Quote Quick reply to this message
Old 05-11-2012, 09:08 AM   #6 (permalink)
Registered Users
 
Posts: 1,275
 

Join Date: Oct 2011
Location: Noblesville, IN
Default

I have the same issue with mine, in addition to two other issues.

About 5 months back I was at an indoor fly-in event and my Blade 450 3D was tipping on spool up. Since I had the RTF version I just copied and preset over to "fix the issue and go fly."

Fast forward to a couple weeks ago with the T -Rex. It tipped after a full idle up spool and shredded the blades when I went to lift off. After the walk of shame and mandatory cool off period I looked at the T-Rex model settings and discovered my BL MCPX settings were copied to the Trex model memory, 1 swash servo, extremely high servo travel range on rudder, expo, etc!

I haven't yet called Horizon. Just got a 9503 in the mail to replace the 6i.
__________________
dan ░▒▓█ x7 / x5 / 450 pro v2 / 300cfx / 230s night / 2*180cfx / 2*130x / nano cpx / nano qx & 3D / x9503 █▓▒░
lucidchaos is offline        Reply With Quote Quick reply to this message
Old 05-14-2012, 02:39 AM   #7 (permalink)
Registered Users
 
Posts: 2,149
 
My HF Map location
Join Date: Jan 2012
Location: Kansas City, MO
Default

I had this happen on my mCPX profile; it seemed to (mostly) occur when I switched the TX off without resetting the timer manually after having stopped it. Can't remember if it was over-time or had been stopped under when it happened most often, but the next time I powered the TX on (and until I fixed it) it'd be set to UP mode with some time on the clock (either 4:30 or 6:00) and reset to 0:00 when started and count up.

Remembering to reset the timer before shutting the TX off has become a habit though, and it hasn't happened again in about 5 months since I'd started doing that.
__________________
Blade: mCX2, mSR, mSRX, Nano-CPX, 2x mCPX (v1), mCPX-BL, 120SR, 450 X
Spektrum DX8, DX6i
Talesin is offline        Reply With Quote Quick reply to this message
Reply




Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the HeliFreak forums, you must first register.
Please enter your desired user name, your REAL and WORKING email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself. Use a real email address or you will not be granted access to the site. Thank you.
Email Address:
Location
Where do you live? ie: Country, State, City or General Geographic Location please.
Name and Lastname
Enter name and last name here. (This information is not shown to the general public. Optional)
Helicopter #1
Enter Helicopter #1 type and equipment.
Helicopter #2
Enter Helicopter #2 type and equipment.
Helicopter #3
Enter Helicopter #3 type and equipment.
Helicopter #4
Enter Helicopter #4 type and equipment.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On




Copyright © Website Acquisitions Inc. All rights reserved.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2018 DragonByte Technologies Ltd.
 

SEO by vBSEO 3.6.1