Flymentor problem: Tail Servo swings hard right on power up - HeliFreak
Fun, Learning, Friendship and Mutual Respect START  HERE


Unregistered
Go Back   HeliFreak > R/C Electronics Support > Flight Stabilization


Flight Stabilization Flight Stabilization


Reply
 
LinkBack Thread Tools Display Modes
Old 06-25-2012, 07:40 PM   #1 (permalink)
Registered Users
 
Posts: 4,611
 
My HF Map location
Join Date: Aug 2008
Location: Blue Bell, PA USA
Default Flymentor problem: Tail Servo swings hard right on power up

I finally got my Flymentor installed.

I think I have sorted out my Aileron, Pitch, and Elevator servos... I still may need to play with the settings a bit, but the basically operate the way they are supposed to.

My problem is my tail servo. When I power up, it swings hard to the right and tries to keep going right (but it is mechanically being stopped by the linkages). I've switched servo directions, but nothing I do seems to change the behavior.

Anyone experience anything like this issue? Any ideas of what could be causing it?
__________________
Walkera 4#3B, 4G6
Align 250SE, Gaui 200
Tarot 450PRO
Align 550L Dominator
Steve Joblin is offline        Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 06-25-2012, 09:23 PM   #2 (permalink)
Registered Users
 
Posts: 5,904
 

Join Date: Aug 2008
Location: London, Uk
Default

In order to set the FM tail gyro you need to reduce the gyro gain in Helibal into the normal zone where it is in rate mode rather than HH mode. Once you do that the gyro should center the servo, if not that is where you mechanically set your links to do so. Also the distance on the ball link (mechanical gain) should be set correctly for the size of the heli. You can then start to set the correction and rudder direction. Hope this helps.
__________________
T-Rex600-ICE100,WR10ABEC,Scorp4025-1100+17T,Kasama head,QUK Swash CNC Tail,G-Force blocks,3152,DS760+BLS251,DX7+AR7000,FM.
Blade400
-CC ICE50,Scorp2221-8+12T,Sonix Head&Tail,5A BEC,HS65HB,Quark+3500G,AR7000,Align Carbon blades,TRex500 Skids,Flymentor.
pril250 is offline        Reply With Quote Quick reply to this message
Old 06-26-2012, 12:49 PM   #3 (permalink)
Registered Users
 
Posts: 4,611
Thread Starter Thread Starter
 
My HF Map location
Join Date: Aug 2008
Location: Blue Bell, PA USA
Default

Finally isolated the issue! my Tail Gyro is bad! Always something! My Tail Servo was a cheap analog servo... I must have fried it when I hooked it up to my new GA-250 gyro (which in reading the manual, says you must use a DIGITAL servo). Although I am bummed, I am glad I isolated the issue and know why it failed!
__________________
Walkera 4#3B, 4G6
Align 250SE, Gaui 200
Tarot 450PRO
Align 550L Dominator
Steve Joblin is offline        Reply With Quote Quick reply to this message
Old 06-26-2012, 01:58 PM   #4 (permalink)
Registered Users
 

Join Date: Mar 2008
Location: Plymouth devon UK
Default

Piezo gyro's will allway's move to one end of the travel in HH mode ( including the FM tail gyro ) and it is not a problem. If the travel is to much then it should bre reduced useing the FM programme.
As Pril said it will move to centre in normal mode and so the tail should be set up in normal mode before changing the HH.
Ivor Hill is offline        Reply With Quote Quick reply to this message
Old 06-26-2012, 03:46 PM   #5 (permalink)
Registered Users
 
Posts: 4,611
Thread Starter Thread Starter
 
My HF Map location
Join Date: Aug 2008
Location: Blue Bell, PA USA
Default

I took everything apart and started from scratch. The first thing I did was to just hook up the ESC, my old Detrum GY48V Gyro, and Tail Servo to my RX. Nothing else. I powered it up and the servo slammed hard right and tried to keep going right. I disconnected the servo and replaced it with another cheap servo that I had laying around (not digital). I powered it up and it worked as expected. Thus, I have determined that the servo is the bad component. I will have to order a decent digital tail servo to continue with the installation process.
__________________
Walkera 4#3B, 4G6
Align 250SE, Gaui 200
Tarot 450PRO
Align 550L Dominator
Steve Joblin is offline        Reply With Quote Quick reply to this message
Old 12-15-2012, 04:25 PM   #6 (permalink)
Registered Users
 

Join Date: Mar 2011
Location: nz
Default

[QUOTE=Ivor Hill;4055465]Piezo gyro's will allway's move to one end of the travel in HH mode ( including the FM tail gyro ) and it is not a problem. If the travel is to much then it should bre reduced useing the FM programme. ....

hey, Thanks man...ive been trolling forums for an age, trying to find a definitive answer as to why the FM tail moves to one end and stops....people have been saying that it's normal behaviour but its NOT. ....not for all of my other gyros (mems gyro's).

you explain it simply, its a piezo gryo, and thats what piezo gyros do..

im on the verge ...almost ready to pull this FM unit off my heli. my tail wont hold.
i am an experienced pilot, just thought id give this fly-mentor a crack on my atom 500, to make it less squirrelly with the big fancy moves ;-)

anyway, thanks.

mike.

Last edited by cr@sh; 12-15-2012 at 06:10 PM.. Reason: amendment
cr@sh is offline        Reply With Quote Quick reply to this message
Old 12-15-2012, 06:24 PM   #7 (permalink)
Registered Users
 

Join Date: Mar 2011
Location: nz
Default

ok, i just spent a few more minutes with the atom FM equipped.... i decided that it was far from a tail wag situation ( tail mechanics silky smooth) so i upped the tail gain, using the FM software from 70 to 80, the tail now has a rock solid stop ccw.... still a funny bounce in a clockwise piro but hey.... im almost there, i have renewed faith. the swash balancing i had set to zero (off condition) so that i could concentrate on the tail.... set to 70... this proved to be too much gain...heli was all over the place, i settled on 40, shes pretty stable now =).

by the way, if people are having problems trying to get the flymentor software to work, i found that changing the com port settings in windows got it working, simply choose a com port not in use.

windows xp: device manager/ports (com&lpt) /kds link line.
i changed mine to com2 which was un-used on my computer, and viola!!! it connected to the
heli =)

good luk people!!!!

mike.
cr@sh is offline        Reply With Quote Quick reply to this message
Old 12-17-2012, 11:26 AM   #8 (permalink)
Registered Users
 

Join Date: Nov 2012
Location: land of lincoln
Default

Not jacking the thread but i have the same issue. i am using a FM gyro and the gray wire is connected to the RX. i did set my gyro gain to 50% on my TX and 0% to my programmer. then i did center my tail pitch slider. but when i tried to hover it and set my gyro gain to 70% on my TX and my FM programmer my helicopter is just turning CCW turning left so bad. i really need to sub trim is so bad to the right at least 100 click to stop it
sparrow06 is offline        Reply With Quote Quick reply to this message
Old 12-18-2012, 05:14 AM   #9 (permalink)
Registered Users
 

Join Date: Mar 2008
Location: Plymouth devon UK
Default

Quote:
Originally Posted by sparrow06 View Post
Not jacking the thread but i have the same issue. i am using a FM gyro and the gray wire is connected to the RX. i did set my gyro gain to 50% on my TX and 0% to my programmer. then i did center my tail pitch slider. but when i tried to hover it and set my gyro gain to 70% on my TX and my FM programmer my helicopter is just turning CCW turning left so bad. i really need to sub trim is so bad to the right at least 100 click to stop it
Centering the tail pitch slider is not going to make it work. Please read the sticky at the top. The tail must first be set up mechanicaly in normal mode ( servo centred ) and with little or no gain set. adjust the position of the slider untill the tail holds without useing trim or stick then switch to HH and set the best gain.
If it is a trex or trex clone you will end up with the slider offset towards the boom, the tail will not be perfect but it will hold.
Ivor Hill is offline        Reply With Quote Quick reply to this message
Reply




Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the HeliFreak forums, you must first register.
Please enter your desired user name, your REAL and WORKING email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself. Use a real email address or you will not be granted access to the site. Thank you.
Email Address:
Location
Where do you live? ie: Country, State, City or General Geographic Location please.
Name and Lastname
Enter name and last name here. (This information is not shown to the general public. Optional)
Helicopter #1
Enter Helicopter #1 type and equipment.
Insurance
Please select your insurance company (Optional)
Helicopter #2
Enter Helicopter #2 type and equipment.
Helicopter #3
Enter Helicopter #3 type and equipment.
Helicopter #4
Enter Helicopter #4 type and equipment.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On




Copyright © VerticalScope Inc. All rights reserved.
 

SEO by vBSEO 3.6.1