YS 60SR - very frustrated.... UPDATE - HeliFreak
Fun, Learning, Friendship and Mutual Respect START  HERE


Unregistered
Go Back   HeliFreak > R/C Helicopter Support > Engines and Mufflers


Engines and Mufflers Having problems or need advice on Engines or Mufflers?


Reply
 
LinkBack Thread Tools Display Modes
Old 09-06-2012, 08:04 AM   #1 (permalink)
Registered Users
 
Posts: 1,889
 
My HF Map location
Join Date: Nov 2009
Location: Hillsville, VA, USA
Default YS 60SR - very frustrated.... UPDATE

I figure you drop 4 bills for an engine, you should be able to bolt it on, put a plug in it, break it in and have lots of fun. Well, if that is what you are looking for then don't bother with the 60SR.

I have been flying nitro helis for almost three years, and have tuned lots of different motors. I have had the 60's for 3.5 weeks now and haven't had a minutes worth of peace since. I should have kept my 55's...


I bought 2 of these engines, broke them in gently, and hear are the results.

Engine 1: Pulls really strong at around 165 degrees, any leaner/warmer it detonates horribly. I ordered another head shim, but the engine gave it up before it came in. Very strange, the piston/ring/liner/head all looked new, but the crankshaft and crankcase were badly scored where they meet under the carb. Never seen anything like it before... It is now at the warranty center, we will see how that goes...

Engine 2: Installed an additional head shim, engines runs great around 190 degrees (almost factory needle settings for a very short flight), but eats os #8 glow plugs every other flight... I have ordered an assortment of colder glow plugs to try and resolve this issue...

my setup is as follows:

30% Magnum Heli fuel (5 of us have been running it all summer in multiple types of engines and love it)

OS 8 glow plug

Funtech B323 pipe

I am around 3000' elevation

Anything less than near factory needle settings (should be so rich they won't run) and these engines detonate like crazy, when they do run, they eat glow plugs like candy...


I am hoping to have some luck with YS service, but I have no clue as to how to fix this situation...


So far I have dropped over a grand in these engines and pipes, and have NOTHING to show for it! Awesome
__________________
Trex 700L Dominator X 2, Trex 450L Dominator X 2

Last edited by fastone93; 09-07-2012 at 08:05 AM..
fastone93 is offline        Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 09-06-2012, 05:28 PM   #2 (permalink)
Registered Users
 

Join Date: Jul 2005
Location: Lewis Center, OH
Default

Contact Buzz at Magnum Fuels. He was working on an adaptor to allow the use of an OS carb on the YS60. He has a similar adaptor for the YS120 and he said it solves all the tuning issues.
Gscott is offline        Reply With Quote Quick reply to this message
Old 09-07-2012, 08:05 AM   #3 (permalink)
Registered Users
 
Posts: 1,889
Thread Starter Thread Starter
 
My HF Map location
Join Date: Nov 2009
Location: Hillsville, VA, USA
Default

Update, the second engine ate itself last night! Yeah!!!!!!!!!!!


Same thing as the other one. As far as the adapter goes, I think I will use the OS carb, but attached to an OS engine...
__________________
Trex 700L Dominator X 2, Trex 450L Dominator X 2
fastone93 is offline        Reply With Quote Quick reply to this message
Old 09-07-2012, 03:36 PM   #4 (permalink)
 
My HF Map location
Join Date: Jan 2010
Location: US colorado lakewood
Default

here are some pictures of what Buzz has for the YS 120

here is a video as well no fuel magnets full tank run

[ame]http://www.youtube.com/watch?v=lUXlUqpEj4w[/ame]
Attached Thumbnails
Click image for larger version

Name:	DSC01837.jpg
Views:	604
Size:	53.6 KB
ID:	347080   Click image for larger version

Name:	DSC01838.jpg
Views:	536
Size:	46.2 KB
ID:	347081   Click image for larger version

Name:	DSC01839.jpg
Views:	496
Size:	39.2 KB
ID:	347082   Click image for larger version

Name:	DSC01840.jpg
Views:	522
Size:	48.0 KB
ID:	347083   Click image for larger version

Name:	DSC01902.jpg
Views:	551
Size:	58.0 KB
ID:	347084  

codfish124 is offline        Reply With Quote Quick reply to this message
Old 09-16-2012, 09:49 PM   #5 (permalink)
Registered Users
 
Posts: 92
 

Join Date: Jan 2011
Location: Destin, Fl
Default YS 60

I have had 2-56's and now the 60sr. I had the same problem with tuning the 56 when I live in Blacksburg, Va. I was going through OS #8 glow plugs everyother flight, I switched to Enya 3 plugs and now that is all I run in the smaller YS engines. Try one out.
__________________
Thanks,
Pete G
velocityguy is offline        Reply With Quote Quick reply to this message
Old 09-23-2012, 06:11 PM   #6 (permalink)
Registered Users
 

Join Date: Nov 2011
Location: Lafayette, indiana
Default

Just back from the field. Mine was running very rich and very cool. Spitting fuel from the muffler. All of a sudden POP. And a bunch of smoke. Haven't pulled the motor but I can already see a hole in the top of the piston. I am so frustrated. There are way to many guys having problems with this motor.
craig1980 is offline        Reply With Quote Quick reply to this message
Old 09-23-2012, 09:20 PM   #7 (permalink)
Registered Users
 

Join Date: Jul 2005
Location: Lewis Center, OH
Default

Funny you mention that Craig because mine did the exact same thing today. Mine was running rich then a sudden drop in power and pop. My onboard temp monitor showed nearly 500 degrees.
Gscott is offline        Reply With Quote Quick reply to this message
Old 09-24-2012, 11:21 AM   #8 (permalink)
Registered Users
 
Posts: 1,889
Thread Starter Thread Starter
 
My HF Map location
Join Date: Nov 2009
Location: Hillsville, VA, USA
Default

Sorry to hear about that guys, be specific in your letters to YS. Tell them exactly what you expect from them...

Good Luck!
__________________
Trex 700L Dominator X 2, Trex 450L Dominator X 2
fastone93 is offline        Reply With Quote Quick reply to this message
Old 09-24-2012, 01:27 PM   #9 (permalink)
Registered Users
 
Posts: 968
 

Join Date: Apr 2011
Location: USA, NE, Lincoln
Default

Crap!! I'm a little nervous to take mine out again.
__________________
Minicopter Diabolo-14s-Pyro 800-Kosmik-Vbar
Voodoo 400 SK540
ChadL is offline        Reply With Quote Quick reply to this message
Old 09-24-2012, 04:36 PM   #10 (permalink)
Registered Users
 
Posts: 1,889
Thread Starter Thread Starter
 
My HF Map location
Join Date: Nov 2009
Location: Hillsville, VA, USA
Default

maybe you got a good one ChadL...

Just curious about the other two failures, what fuel, pipe, and plug were you guys running?

Thanks
__________________
Trex 700L Dominator X 2, Trex 450L Dominator X 2
fastone93 is offline        Reply With Quote Quick reply to this message
Old 09-24-2012, 06:38 PM   #11 (permalink)
Registered Users
 

Join Date: Nov 2011
Location: Lafayette, indiana
Default

I had the Hatori, Cool Power 30, OS 8.
craig1980 is offline        Reply With Quote Quick reply to this message
Old 09-24-2012, 08:13 PM   #12 (permalink)
Registered Users
 

Join Date: Jul 2005
Location: Lewis Center, OH
Default

I was running the Funtech, Enya 3, and Magnum DS 30 fuel.
Gscott is offline        Reply With Quote Quick reply to this message
Old 09-24-2012, 08:32 PM   #13 (permalink)
Registered Users
 
Posts: 968
 

Join Date: Apr 2011
Location: USA, NE, Lincoln
Default

Mine hasn't imploded yet, but fwiw.....Hatori pipe, Rotor Rage masters blend 30%, Enya #4.

Chad
__________________
Minicopter Diabolo-14s-Pyro 800-Kosmik-Vbar
Voodoo 400 SK540
ChadL is offline        Reply With Quote Quick reply to this message
Old 09-24-2012, 09:14 PM   #14 (permalink)
Registered Users
 

Join Date: Nov 2011
Location: Lafayette, indiana
Default

I just typed my letter to YS and might have cooled down enough to pull the motor and get it ready to ship. Let's keep this post updated as we go and see where we all end up. I must say this sucks I can't fly this weekend or next week. Heck who knows how long it will be.
craig1980 is offline        Reply With Quote Quick reply to this message
Old 09-26-2012, 06:30 AM   #15 (permalink)
Registered Users
 

Join Date: Nov 2011
Location: Lafayette, indiana
Default

Pulled my engine last night. I didnt even open it i am just sending it as is. I looked through the muffler port and the top of the piston is almost in two pieces. There is a hole in the middle then a crack that goes to the side where there is another large chunk gone from the side just above the ring. To me it looks like the chunk from the side must have somehow caught on something and broke off. Just a guess from looking at it. Im sending it out today.
craig1980 is offline        Reply With Quote Quick reply to this message
Old 09-26-2012, 08:43 AM   #16 (permalink)
Registered Users
 
Posts: 1,889
Thread Starter Thread Starter
 
My HF Map location
Join Date: Nov 2009
Location: Hillsville, VA, USA
Default

Both of my engines showed signs of very uneven combustion. There was a "hot" spot on the front left side of the piston where all of the firing was happening...
__________________
Trex 700L Dominator X 2, Trex 450L Dominator X 2
fastone93 is offline        Reply With Quote Quick reply to this message
Old 09-26-2012, 06:01 PM   #17 (permalink)
Registered Users
 
Posts: 968
 

Join Date: Apr 2011
Location: USA, NE, Lincoln
Default

What would cause that? Poorly shaped combustion chamber?
__________________
Minicopter Diabolo-14s-Pyro 800-Kosmik-Vbar
Voodoo 400 SK540
ChadL is offline        Reply With Quote Quick reply to this message
Old 09-27-2012, 08:20 AM   #18 (permalink)
Registered Users
 
Posts: 1,889
Thread Starter Thread Starter
 
My HF Map location
Join Date: Nov 2009
Location: Hillsville, VA, USA
Default

could be pipe back pressure, poor engine timing (intake port not positioned properly, etc.)

who knows, but the severely off center burn could cause lots of problems...
__________________
Trex 700L Dominator X 2, Trex 450L Dominator X 2
fastone93 is offline        Reply With Quote Quick reply to this message
Old 09-28-2012, 06:02 AM   #19 (permalink)
Registered Users
 

Join Date: Aug 2010
Location: England, Essex
Default

I run 2 120s one has caused problems and has too run richer than the other any attempts too wind in the main needle it goes lean...I have wondered if the ring has not seated properly in this engine...could this be a problem that the YS engines are having.....
jwatts007 is offline        Reply With Quote Quick reply to this message
Old 09-29-2012, 11:35 AM   #20 (permalink)
Registered Users
 

Join Date: Jul 2005
Location: Lewis Center, OH
Default

Has anyone received their motor back from YS with an explanation?
Gscott is offline        Reply With Quote Quick reply to this message
Reply




Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the HeliFreak forums, you must first register.
Please enter your desired user name, your REAL and WORKING email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself. Use a real email address or you will not be granted access to the site. Thank you.
Email Address:
Location
Where do you live? ie: Country, State, City or General Geographic Location please.
Name and Lastname
Enter name and last name here. (This information is not shown to the general public. Optional)
Helicopter #1
Enter Helicopter #1 type and equipment.
Helicopter #2
Enter Helicopter #2 type and equipment.
Helicopter #3
Enter Helicopter #3 type and equipment.
Helicopter #4
Enter Helicopter #4 type and equipment.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On




Copyright © Website Acquisitions Inc. All rights reserved.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2018 DragonByte Technologies Ltd.
 

SEO by vBSEO 3.6.1