YS 60SR - very frustrated.... UPDATE - Page 2 - HeliFreak
Fun, Learning, Friendship and Mutual Respect START  HERE


Unregistered
Go Back   HeliFreak > R/C Helicopter Support > Engines and Mufflers


Engines and Mufflers Having problems or need advice on Engines or Mufflers?


Reply
 
LinkBack Thread Tools Display Modes
Old 09-29-2012, 03:32 PM   #21 (permalink)
Registered Users
 

Join Date: Nov 2011
Location: Lafayette, indiana
Default

They should have mine on Monday so I hope to hear something next week. I will update you guys.
craig1980 is offline        Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 10-05-2012, 01:09 PM   #22 (permalink)
Registered Users
 

Join Date: Jul 2005
Location: Lewis Center, OH
Default

YS has to have seen a few of these by now. Any updates?
Gscott is offline        Reply With Quote Quick reply to this message
Old 10-05-2012, 06:38 PM   #23 (permalink)
Registered Users
 

Join Date: Nov 2011
Location: Lafayette, indiana
Default

Tracking shows they recieved mine on 9/28. No communication from them yet.
craig1980 is offline        Reply With Quote Quick reply to this message
Old 10-12-2012, 08:43 PM   #24 (permalink)
Registered Users
 

Join Date: Nov 2011
Location: Lafayette, indiana
Default

Update. Well no update really. End of week two with no motor or communication
craig1980 is offline        Reply With Quote Quick reply to this message
Old 10-13-2012, 10:25 AM   #25 (permalink)
Registered Users
 

Join Date: Jul 2005
Location: Lewis Center, OH
Default

That's not good. I finally sent mine on Thursday. Have you tried contacting them for an update?
Gscott is offline        Reply With Quote Quick reply to this message
Old 10-13-2012, 08:07 PM   #26 (permalink)
Registered Users
 

Join Date: Nov 2011
Location: Lafayette, indiana
Default

No I haven't called. I figured I would give it another week. I work a ton of hours myself so I am very understanding of a busy shop.
craig1980 is offline        Reply With Quote Quick reply to this message
Old 10-15-2012, 04:29 PM   #27 (permalink)
Registered Users
 
Posts: 1,889
Thread Starter Thread Starter
 
My HF Map location
Join Date: Nov 2009
Location: Hillsville, VA, USA
Default

Sorry for the long silence guys, but my issue was finally solved today. I received two new in box engines after a couple of firm conversations with YS. Not happy with this engine design and do not plan to keep them, but you couldn't ask for much more from an engine manufacturer as far as service goes.
__________________
Trex 700L Dominator X 2, Trex 450L Dominator X 2
fastone93 is offline        Reply With Quote Quick reply to this message
Old 10-16-2012, 09:46 AM   #28 (permalink)
Registered Users
 

Join Date: Jul 2005
Location: Lewis Center, OH
Default

Did they ever say what caused the issue? If you could expand on your conversation with YS that would be great since several of us will soon be in the same boat.
Gscott is offline        Reply With Quote Quick reply to this message
Old 10-16-2012, 10:13 AM   #29 (permalink)
Registered Users
 
Posts: 1,889
Thread Starter Thread Starter
 
My HF Map location
Join Date: Nov 2009
Location: Hillsville, VA, USA
Default

I was told that the problem came from my setup, which hadn't changed in 2.5 years except for these new engines. "Something in your setup is generating heat" obviously it is the engine...

I received a call from YS and was told that the crank and case had been replaced and it was shipped that day. I told the gentleman that I wasn't going to accept a 3 week old engine that obviously had metal go throughout it's internals and I wished he would have called me like he said he would, before any repairs were made, and oh yeah, by the way my other engine is on it's way to you right now. I said that at a minimum the case, crank, piston, ring, liner, and bearings needed to be replaced. His response was that is pretty much a new engine, and I agreed. I said I would accept nothing less than new engines. He said that he would think about it, and I said that I was going to refuse the package that he had shipped. I called him again after he had both of my engines in hand, we had another discussion pretty much the same as the one above, and I received new engines.
__________________
Trex 700L Dominator X 2, Trex 450L Dominator X 2
fastone93 is offline        Reply With Quote Quick reply to this message
Old 10-24-2012, 08:37 AM   #30 (permalink)
Registered Users
 
Posts: 951
 

Join Date: Oct 2009
Location: Ashton, ID
Default

I realy wanted to try one of these, but now I think I'll have to stick with the OS 55 for a while. Maybe YS will get these right in a year or so.
__________________
Blade MCP-X Brushless, 300CFX, , Trex 600 ESP 6s 3GX v.3.1 and KDE head, Trex 600 LE, OS 55 Hyper Limited Edition, Trex 700 Nitro, Futaba 12Z controle!!
Stevendavis is offline        Reply With Quote Quick reply to this message
Old 11-01-2012, 08:05 PM   #31 (permalink)
Registered Users
 

Join Date: Nov 2011
Location: Lafayette, indiana
Default

Well I got mine back two days ago. No explanation and no communication unless it was me calling them. New piston, sleeve, and rear bearing. Only good news is I just got home from trading mine for a 55hzr. Did the trade with a guy from the local field. He was there when mine blew so he knows the whole story so I feel good about the deal. Good luck guys
craig1980 is offline        Reply With Quote Quick reply to this message
Old 12-07-2012, 03:07 PM   #32 (permalink)
Registered Users
 

Join Date: May 2010
Location: India
Default

guys need your advice, I am planning to buy YS 60SR
gotoyogesh007 is offline        Reply With Quote Quick reply to this message
Old 12-11-2012, 03:42 PM   #33 (permalink)
 

Join Date: Apr 2006
Location: USA
Default

My advice - Don't. I have a YS 56 with continual tuning problems and two YS 120s, one of which is on its way to YS for repair: a 3/4 inch long by 1cm wide piece of the piston broke off. And I'm not the first one that's had this problem. My motor temps have never been above 186 degrees right after a flight and my head speed on the 120s is 1920 to 1930. The motor I sent in for repair was purchased in April. It was easy to tune for break-in, started right up and had gobs of power, that's why I bought a second one this fall. After reading this thread I'm concerned that the other 120 is doomed for failure too. I shipped mine off to YS one week ago and know they received it last Friday. Haven't heard anything yet and hope it's a lot sooner than some have posted here. Good luck if you purchase a YS60.
Bobs is offline        Reply With Quote Quick reply to this message
Old 12-21-2012, 11:33 AM   #34 (permalink)
Registered Users
 

Join Date: May 2010
Location: India
Default

Quote:
Originally Posted by Bobs View Post
My advice - Don't. I have a YS 56 with continual tuning problems and two YS 120s, one of which is on its way to YS for repair: a 3/4 inch long by 1cm wide piece of the piston broke off. And I'm not the first one that's had this problem. My motor temps have never been above 186 degrees right after a flight and my head speed on the 120s is 1920 to 1930. The motor I sent in for repair was purchased in April. It was easy to tune for break-in, started right up and had gobs of power, that's why I bought a second one this fall. After reading this thread I'm concerned that the other 120 is doomed for failure too. I shipped mine off to YS one week ago and know they received it last Friday. Haven't heard anything yet and hope it's a lot sooner than some have posted here. Good luck if you purchase a YS60.
Sad to hear that Bob will stick with YS 50 for some more time until YS fixes all the bugs they have with YS 60 SR .

"Wish you a Happy Christmas".
gotoyogesh007 is offline        Reply With Quote Quick reply to this message
Old 01-13-2013, 02:08 AM   #35 (permalink)
Registered Users
 
My HF Map location
Join Date: Nov 2004
Location: NSW Australia
Default YS 60SR - very frustrated.... UPDATE

Having good results with this one on the Hatori 60 muffler so far

[ame]http://www.youtube.com/watch?v=2sWSTkRsqSg&sns=em[/ame]
__________________
Team Lynx
Team Mad 4 Heli
Gens Ace Batteries
Citizen # 310
jody is offline        Reply With Quote Quick reply to this message
Old 01-27-2013, 05:25 PM   #36 (permalink)
Registered Users
 

Join Date: Jul 2007
Location: Toronto, CANADA
Default YS120 with OS carb modification

http://www.youtube.com/watch?feature...&v=A4s2NhNTuz8

YS120 with OS carb modification
bhush101 is offline        Reply With Quote Quick reply to this message
Old 02-01-2013, 11:53 AM   #37 (permalink)
Registered Users
 

Join Date: Aug 2010
Location: England, Essex
Default

Quote:
Originally Posted by bhush101 View Post
With OS carbs you adjust the needles too get them too run...with the YS you adjust them too tune em....
jwatts007 is offline        Reply With Quote Quick reply to this message
Old 04-14-2013, 02:55 AM   #38 (permalink)
Registered Users
 

Join Date: Mar 2013
Location: Germany
Default

I have bought an ys 60, since 4 weeks ago.... I fly Velocity 50N2 with Msh Brain and the GOV of the brain.... Fuel is 30% Rappicon...

I have no Problems with this engine,he is running very very well and the power.....
3D Tommy is offline        Reply With Quote Quick reply to this message
Old 04-22-2013, 10:11 AM   #39 (permalink)
Registered Users
 
Posts: 142
 

Join Date: Jan 2012
Location: Richmond, Virginia
Default

I had the exact same thing to happen to me. I was running very rich with fuel spitting out of the muffler. I was in a hover and then suddenly I heard a pop sound and the engine cut off. Was not able to restart it. This has been 3 weeks of frustration with this engine. I hope it's not blown already.
__________________
_________________________________
Trex 700N,600N,700e DFC, Fusion, Goblin500, Blade450x, Helix G700(in progress)
Frankcm1 is offline        Reply With Quote Quick reply to this message
Old 04-26-2013, 12:35 PM   #40 (permalink)
 
My HF Map location
Join Date: Jan 2010
Location: US colorado lakewood
Default

Quote:
Originally Posted by Frankcm1 View Post
I had the exact same thing to happen to me. I was running very rich with fuel spitting out of the muffler. I was in a hover and then suddenly I heard a pop sound and the engine cut off. Was not able to restart it. This has been 3 weeks of frustration with this engine. I hope it's not blown already.

send me a pm with your phone number ill have Buzz give you a call about the os carb mod i know hes got a few running on the 60 with great results
codfish124 is offline        Reply With Quote Quick reply to this message
Reply




Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the HeliFreak forums, you must first register.
Please enter your desired user name, your REAL and WORKING email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself. Use a real email address or you will not be granted access to the site. Thank you.
Email Address:
Location
Where do you live? ie: Country, State, City or General Geographic Location please.
Name and Lastname
Enter name and last name here. (This information is not shown to the general public. Optional)
Helicopter #1
Enter Helicopter #1 type and equipment.
Insurance
Please select your insurance company (Optional)
Helicopter #2
Enter Helicopter #2 type and equipment.
Helicopter #3
Enter Helicopter #3 type and equipment.
Helicopter #4
Enter Helicopter #4 type and equipment.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On




Copyright © VerticalScope Inc. All rights reserved.
 

SEO by vBSEO 3.6.1