YS 60SR - very frustrated.... UPDATE - Page 3 - HeliFreak
Fun, Learning, Friendship and Mutual Respect START  HERE


Unregistered
Go Back   HeliFreak > R/C Helicopter Support > Engines and Mufflers


Engines and Mufflers Having problems or need advice on Engines or Mufflers?


Reply
 
LinkBack Thread Tools Display Modes
Old 12-31-2013, 02:51 PM   #41 (permalink)
Registered Users
 

Join Date: Jan 2009
Location: ....
Default

Hi guys,

i have also a new YS 60SR with 12 flights now.

Today, the engine runs abrupt lean. Damn ..... after a autorotation i checked the engine.
The engine was all right, but the glow plug was broken. The engine runs now with a rich carburator setting (and new OS 8) still lean.

I think the check valve was damaged. I replaced it and tomorrow i will take a new test flight.

Happy New Year!

Last edited by Sky_; 12-31-2013 at 05:15 PM..
Sky_ is offline        Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 01-01-2014, 03:59 AM   #42 (permalink)
Registered Users
 

Join Date: Jan 2009
Location: ....
Default

Hi,

pressure is now OK! But the engine runs still lean.
IMO the cause of the lean run is definitively the carburator.

Now i order a new OS 55 HZ-R + OS Powerboost Pipe II Limited Edition!
I had never any issues with my other OS HZ-Rs.
Sky_ is offline        Reply With Quote Quick reply to this message
Old 01-03-2014, 10:20 AM   #43 (permalink)
Registered Users
 

Join Date: Jan 2009
Location: ....
Default

Hi,

after cleaning from the carburator, the YS 60SR runs very well.

No comment....




P.S.: I'd used a fuel filter!
Sky_ is offline        Reply With Quote Quick reply to this message
Old 01-06-2014, 04:46 PM   #44 (permalink)
Registered Users
 
Posts: 8,982
 

Join Date: Oct 2008
Location: Midland, MI - USA
Default

Is that an insect? Probably crawled in the open carb from the fan shroud pretty easily. Little bastard!
__________________
= Rb43 =
Rob43 is offline        Reply With Quote Quick reply to this message
Old 01-07-2014, 02:47 AM   #45 (permalink)
Registered Users
 

Join Date: Jan 2009
Location: ....
Default

I'm not sure. Maybe it was a nitro junkie bee from japan.
Sky_ is offline        Reply With Quote Quick reply to this message
Old 01-25-2014, 08:17 PM   #46 (permalink)
Registered Users
 
Posts: 8,982
 

Join Date: Oct 2008
Location: Midland, MI - USA
Default

Hah! LOL!
__________________
= Rb43 =
Rob43 is offline        Reply With Quote Quick reply to this message
Reply




Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the HeliFreak forums, you must first register.
Please enter your desired user name, your REAL and WORKING email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself. Use a real email address or you will not be granted access to the site. Thank you.
Email Address:
Location
Where do you live? ie: Country, State, City or General Geographic Location please.
Name and Lastname
Enter name and last name here. (This information is not shown to the general public. Optional)
Helicopter #1
Enter Helicopter #1 type and equipment.
Insurance
Please select your insurance company (Optional)
Helicopter #2
Enter Helicopter #2 type and equipment.
Helicopter #3
Enter Helicopter #3 type and equipment.
Helicopter #4
Enter Helicopter #4 type and equipment.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On




Copyright © VerticalScope Inc. All rights reserved.
 

SEO by vBSEO 3.6.1