TT X50 broken motor mount issues - HeliFreak
Fun, Learning, Friendship and Mutual Respect START  HERE


Unregistered
Go Back   HeliFreak > R/C Helicopter Support > Thunder Tiger 30/50 > Titan X50


Titan X50 Thunder Tiger Titan X50 Helicopters


Reply
 
LinkBack Thread Tools Display Modes
Old 09-16-2012, 05:01 PM   #1 (permalink)
Registered Users
 
Posts: 1,570
 
My HF Map location
Join Date: Mar 2008
Location: roseville MI
Default TT X50 broken motor mount issues

anyone break any motor mounts that were not caused from a wreck? i have 3 under my belt atm and all are not due to crashing. i have no vibrations and my helis are tight and locked in. cant understand why this is happening.
__________________
TT E700, TT X50, Compass Warp Mikado Logo 550sx
johnbs8 is offline        Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 09-16-2012, 05:06 PM   #2 (permalink)
Member
 
My HF Map location
Join Date: Dec 2008
Location: Negaunee, Michigan
Default

Sorry to hear that, John. My original one never broke. Can't remember how many flights off hand, maybe 50? Botched an inverted auto that came down hard on the skids and crushed the muffler from underneath. Motor mount wasn't affected by it. Maybe you got some poorly casted? Not sure how exactly its made.

Sent from my phone
__________________
):>
Bob O is offline        Reply With Quote Quick reply to this message
Old 09-16-2012, 05:14 PM   #3 (permalink)
Registered Users
 
Posts: 1,570
Thread Starter Thread Starter
 
My HF Map location
Join Date: Mar 2008
Location: roseville MI
Default

sry to hear about the muffler Bob. yah this is number 4 that ive had break. one last year do to a wreck and three since then that are not from a wreck. the first one i bought a new one and called it done. now its here again. wierd!!
__________________
TT E700, TT X50, Compass Warp Mikado Logo 550sx
johnbs8 is offline        Reply With Quote Quick reply to this message
Reply




Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the HeliFreak forums, you must first register.
Please enter your desired user name, your REAL and WORKING email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself. Use a real email address or you will not be granted access to the site. Thank you.
Email Address:
Location
Where do you live? ie: Country, State, City or General Geographic Location please.
Name and Lastname
Enter name and last name here. (This information is not shown to the general public. Optional)
Helicopter #1
Enter Helicopter #1 type and equipment.
Insurance
Please select your insurance company (Optional)
Helicopter #2
Enter Helicopter #2 type and equipment.
Helicopter #3
Enter Helicopter #3 type and equipment.
Helicopter #4
Enter Helicopter #4 type and equipment.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On




Copyright © VerticalScope Inc. All rights reserved.
 

SEO by vBSEO 3.6.1