An Almost Crash - HeliFreak
Fun, Learning, Friendship and Mutual Respect START  HERE


Unregistered
Go Back   HeliFreak > R/C Helicopter Support > 450 Class Electric Helicopters


450 Class Electric Helicopters 450 Class Electric Helicopters manufactured by Align, Tarot, SYMA, Airhog, Chaos, HK and similar.


Reply
 
LinkBack Thread Tools Display Modes
Old 09-18-2007, 07:34 PM   #1 (permalink)
Registered Users
 
Posts: 740
 
My HF Map location
Join Date: Sep 2007
Location: Van Wert, Ohio
Default An Almost Crash

Well, before I start I should introduce myself. Hey everyone, Chad here. I am new to helifreak, came over from RR. I don't like their setup at all. Why lump the trex 600 with the 450s? Not the same heli or setups at all...just mt 2 cents.

Well, here is my setup.
Trex SE
CC35
TP2100 3C prolites
401w/S9650
430XL motor
DX6 Radio

I wanted to try a higher head speed to get used to idle up mode(I am a noob so bear with me). I have just been hovering in normal mode. I set the normal throttle curve at 0,85,100. I had already done two previous flights with these settings. Charged the batteries. Started my 3rd flight for the evening, and all hell broke loose. The heli was about 20ft up when the motor just lost power. It felt like I still had the radio control. Then about 3ft off the ground the motor powered up again and it shot up to 15ft. I regained control, but then the motor cut out again and I thought it was going to slam hard. Again the motor came back on. I was able to regain control and pump the throttle to get into a hover. Fortunately I set it down easy. The only thing I found broken was the tail belt. Weird... Im not sure it the ground broke the belt or if the motor starting and stoppping did it. The motor cutting in and out was soft...not instant on off.

I was just checking my castle creations 35 ESC settings. I think the problem might be the current limiting setting. It was on normal. Could this be an issue with the TP2100 lipos (430XL motor 3700kv) and the current limiting setting? The TP lipos are only 15C.

Anybody have any insight on this situation?
__________________
<<450SE V2, CC35, Kong Power 3S 25C 2200, 430XL, 401 w/9650, HS65MG, tail weight mod>>
<<Blade MCX with glow-in-the-dark setup, carbon fiber canopy>>
<<Yellow 600SNP, 8717s, 770 & 8900G, AR7100, Multigov Pro, Align 2 in 1(used for glow driver only)>>
chadjay is offline        Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 09-18-2007, 07:39 PM   #2 (permalink)
Registered Users
 
My HF Map location
Join Date: Apr 2007
Location: STL
Default

Well although I cant comment on your particular problem, wanted to say welcome, and youve picked a good site. Someone here should respond with some help shortly.
Good luck.
Oldboy is offline        Reply With Quote Quick reply to this message
Reply




Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the HeliFreak forums, you must first register.
Please enter your desired user name, your REAL and WORKING email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself. Use a real email address or you will not be granted access to the site. Thank you.
Email Address:
Location
Where do you live? ie: Country, State, City or General Geographic Location please.
Name and Lastname
Enter name and last name here. (This information is not shown to the general public. Optional)
Helicopter #1
Enter Helicopter #1 type and equipment.
Insurance
Please select your insurance company (Optional)
Helicopter #2
Enter Helicopter #2 type and equipment.
Helicopter #3
Enter Helicopter #3 type and equipment.
Helicopter #4
Enter Helicopter #4 type and equipment.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On




Copyright © VerticalScope Inc. All rights reserved.
 

SEO by vBSEO 3.6.1