Trex 450 problem - HeliFreak
Fun, Learning, Friendship and Mutual Respect START  HERE


Unregistered
Go Back   HeliFreak > R/C Helicopter Support > 450 Class Electric Helicopters


450 Class Electric Helicopters 450 Class Electric Helicopters manufactured by Align, Tarot, SYMA, Airhog, Chaos, HK and similar.


Reply
 
LinkBack Thread Tools Display Modes
Old 12-02-2012, 06:24 PM   #1 (permalink)
Registered Users
 

Join Date: Dec 2012
Location: Charleston, SC
Default Trex 450 problem

I'm brand new to the hobby and just purchased a TREX 450 RTF. After waiting 30 days for it's arrival, I read all the manuals, practiced on a simulator, installed my training gear and attempted to "taxi" around my driveway. Things went well at first and I barely got it moving after a few trim adjustments. I was very cautions moving around, but never attempted to lift-off. After 15 minutes on getting familiar and making a few more trim changes, I idled back, and when I attempted to power up again, nothing happened. All the servos seemed to be working properly, but when advanced the left stick, I got no rotation of the blades, but the rotor head servos moved just like the when I moved the right stick! Even though the battery was fully charged, I charged it again with the same results. Any thoughts? I'm a total novice so please be kind! Thanks
ecvoelker is offline        Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 12-02-2012, 08:03 PM   #2 (permalink)
Registered Users
 

Join Date: Apr 2012
Location: Ohio
Default

Check your receiver wires and all connections, which radio are you using? Did you hit any switches on the Transmitter? You could have it in Hold, servo's will work but it will not spool up.
das962 is offline        Reply With Quote Quick reply to this message
Old 12-02-2012, 08:20 PM   #3 (permalink)
Registered Users
 
Posts: 931
 

Join Date: Aug 2010
Location: Louisville, kentucky
Default

+1 for throttle hold
__________________
Alees Rush 700 x3, Alees Rush 750, XLPower 520, NX4, 250 quad racers, Tesla Power servos, Force batteries
cajkat1073 is offline        Reply With Quote Quick reply to this message
Old 12-09-2012, 01:08 PM   #4 (permalink)
Registered Users
 

Join Date: Dec 2012
Location: California
Default

Is it the 450 Plus DFC? I noticed this problem with mine. Im pretty sure the throttle lead going into the 3GX MR was not pushed in all the way. Check that all the leads are plugged into it fully. The bird ships from overseas and Im sure gets thrown around so double check all the connections, bolts, and also use the manual to confirm all the correct settings in the transmitter. Humans put it together.
dwdw910 is offline        Reply With Quote Quick reply to this message
Old 12-09-2012, 03:54 PM   #5 (permalink)
Registered Users
 

Join Date: Nov 2011
Location: Illinois
Default

Your battery may be below ESC/motor cut off voltage. Was the heli running on and off for 15min? You may want to charge the battery and see if it works.

Edit,

Never mind. Just read your posting again and saw you mentioned battery has been charged.


Are you powering up the heli with the throttle(left stick) all the way down position?
nameci is online now        Reply With Quote Quick reply to this message
Old 12-09-2012, 11:01 PM   #6 (permalink)
Registered Users
 

Join Date: Jul 2011
Location: Australia
Default

Check if motor wires are connected?
StevenC is offline        Reply With Quote Quick reply to this message
Reply




Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the HeliFreak forums, you must first register.
Please enter your desired user name, your REAL and WORKING email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself. Use a real email address or you will not be granted access to the site. Thank you.
Email Address:
Location
Where do you live? ie: Country, State, City or General Geographic Location please.
Name and Lastname
Enter name and last name here. (This information is not shown to the general public. Optional)
Helicopter #1
Enter Helicopter #1 type and equipment.
Insurance
Please select your insurance company (Optional)
Helicopter #2
Enter Helicopter #2 type and equipment.
Helicopter #3
Enter Helicopter #3 type and equipment.
Helicopter #4
Enter Helicopter #4 type and equipment.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On




Copyright © VerticalScope Inc. All rights reserved.
 

SEO by vBSEO 3.6.1