Fun, Learning, Friendship and Mutual Respect START  HERE


Unregistered
Go Back   HeliFreak > Multi Rotor Support > Invertix 400 Multirotor Support


Invertix 400 Multirotor Support Invertix 400 Multirotor Support


Reply
 
LinkBack Thread Tools Display Modes
Old 07-19-2015, 01:23 PM   #1 (permalink)
Registered Users
 
Posts: 422
 

Join Date: Mar 2009
Default All 4 motors stopped in mid-flight - what is broken?

Hello,
all 4 motors stopped suddenly and my Invertix crashed into the ground. The battery was not empty!

And now, the Invertix does not beep after connecting the battery.

Is the nano Wii broken, or the BEC? Or something different?
__________________
T-Rex 700 Pro DFC BEASTX | BLADE Fusion 270 | Spektrum DX18G2
-=RAGE=- is offline        Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 07-19-2015, 02:34 PM   #2 (permalink)
Registered Users
 

Join Date: Dec 2007
Default

I would guess the bec, because everything gets the power from there.
no beeps mean not motor control, esc's need the power from the bec , if 1 of them should be busted you would still hear some beeps from the others

I got a 'new, but 2nd hand' invertix which falls from the sky too, it just freaks out mid air
zomaar is online now        Reply With Quote Quick reply to this message
Old 07-20-2015, 03:12 PM   #3 (permalink)
Registered Users
 
Posts: 8,114
 

Join Date: Jun 2009
Location: Edmonton, Alberta, Canada
Default

Email tech support if you can't figure it out. The service is great. Sounds like
the BEC.
__________________
Diabolo 700 BE, 600, Synergy-696, E5SS, Logo 600, 200, Goblin Raw 700, VCT, VBar, Egodrift, Scorpion, Kontronik, MKS, XPert, KST
Freeskiken is offline        Reply With Quote Quick reply to this message
Old 07-20-2015, 03:14 PM   #4 (permalink)
Registered Users
 
Posts: 8,114
 

Join Date: Jun 2009
Location: Edmonton, Alberta, Canada
Default

ZOMAR could it the Nano Wii board ?
__________________
Diabolo 700 BE, 600, Synergy-696, E5SS, Logo 600, 200, Goblin Raw 700, VCT, VBar, Egodrift, Scorpion, Kontronik, MKS, XPert, KST
Freeskiken is offline        Reply With Quote Quick reply to this message
Old 07-20-2015, 06:01 PM   #5 (permalink)
Registered Users
 

Join Date: Aug 2005
Default

Same thing with me. The bec gets fried.

Don't know why????
larryfl is offline        Reply With Quote Quick reply to this message
Old 07-20-2015, 07:41 PM   #6 (permalink)
Registered User
 

Join Date: Jul 2012
Default

Some times the worst case scenario is not figured in to the design. Meaning it all works fine until you add some other goodies on like FPV camera and transmitter, the system gets over loaded. The BEC being the heart of the system supplying power has to be rated for the absolute worst case current draw.

If you can replace that as a separate module, I would suggest getting one that is rated to supply a much higher current. Your system will only draw what it needs to run but if it needs more current to stay running, it's nice to have it on tap. Other wise the BEC gets flogged and fries.
setishock is offline        Reply With Quote Quick reply to this message
Old 07-21-2015, 05:55 AM   #7 (permalink)
Registered Users
 

Join Date: Dec 2007
Default

IMHO you don't need more.
Stock BEC is enough for stock gear. If they get fried maybe they should check quality


Hell, it's rated for 2,5 A @5 v that's 12,5 watt
More then enough to supply a nanowii and 4 esc's it's pure to power some ic's and minor electronics.

If you add fpv gear that's another matter....
zomaar is online now        Reply With Quote Quick reply to this message
Old 07-21-2015, 02:08 PM   #8 (permalink)
Registered Users
 

Join Date: Aug 2005
Default

i found the issue...

looked at invertix support faq and it says if a capictor on the esc comes lose it will toast the bec...

sure enough opened all 4 up and 1 of them did break loose on one leg.....

time to solder put a new bec in and test....
larryfl is offline        Reply With Quote Quick reply to this message
Old 07-21-2015, 05:04 PM   #9 (permalink)
Registered Users
 
Posts: 422
Thread Starter Thread Starter
 

Join Date: Mar 2009
Default

Thank you, all, I've found the reason for the motor cut off. The BEC died, because one capacitator broke off from one esc.

Never crashed. Foam was under each esc and lot's of rubber between the cap. and the circuit board.
__________________
T-Rex 700 Pro DFC BEASTX | BLADE Fusion 270 | Spektrum DX18G2
-=RAGE=- is offline        Reply With Quote Quick reply to this message
Old 07-21-2015, 11:43 PM   #10 (permalink)
Registered Users
 

Join Date: Dec 2007
Default

At least the invertix is a lot of fun too fly ��
3mins of Whoooooooohaaaaaaaaaaa

Only took invertixes to the field yesterday and had fun. +15 flights probably. 1 crash = 2 props.

I seem to get issues with the motors (or esc) after a lot of crashes.

Got a 2nd hand invertix (damn this invertix really had a bad life, the amount of crashes on this one is skyhigh ) anyway I got it knowing it had issues, crashed it twice when I collected it (broke arm and 2 or 3 props)
Agreed with the vendor I would have a look and pay for it when I found it. Otherwise I could return it.

Anyway it had 1 motor that just made the invertix crash. The windings in the motor seem to be damaged because of crashing. And quickly reversing it probably made the motor arc and then it went down.
Swapped motor everything fine. So vendor agrees to lower the price with the amount of a motor so good deal I guess.

Notice the wear on the motor thread this invertix had a lot of prop switches.

Picture of the messed up winding

On my other invertix one of the motors is sometimes 'slow', its like the timing is messed up, on a reverse and if you are close too the ground, you do not have much time to counteract this. As said had 1 crash because of this yesterday, 2 props so just swapped and finished the battery

So my wish for a v2 invertix would be closed motors, so dirt can't get in so easily.
zomaar is online now        Reply With Quote Quick reply to this message
Old 07-22-2015, 08:27 AM   #11 (permalink)
Registered Users
 
Posts: 422
Thread Starter Thread Starter
 

Join Date: Mar 2009
Default

After a closer investigation, I definitely can say, that there was two cold soldering joints.
I've re-soldered the capacitor, applied some hot-melt adhesive and now I'm waiting for a new BEC and two arms, to get the Invertix back in the air.
__________________
T-Rex 700 Pro DFC BEASTX | BLADE Fusion 270 | Spektrum DX18G2
-=RAGE=- is offline        Reply With Quote Quick reply to this message
Reply




Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the HeliFreak forums, you must first register.
Please enter your desired user name, your REAL and WORKING email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself. Use a real email address or you will not be granted access to the site. Thank you.
Email Address:
Location
Where do you live? ie: Country, State, City or General Geographic Location please.
Name and Lastname
Enter name and last name here. (This information is not shown to the general public. Optional)
Helicopter #1
Enter Helicopter #1 type and equipment.
Helicopter #2
Enter Helicopter #2 type and equipment.
Helicopter #3
Enter Helicopter #3 type and equipment.
Helicopter #4
Enter Helicopter #4 type and equipment.

Log-in


Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On




Copyright © Website Acquisitions Inc. All rights reserved.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2021 DragonByte Technologies Ltd.

SEO by vBSEO 3.6.1