Fun, Learning, Friendship and Mutual Respect START  HERE


Unregistered
Go Back   HeliFreak > R/C Electronics Support > Gryphon Electronics


Gryphon Electronics Gryphon Electronics Factory Support Forum


Reply
 
LinkBack Thread Tools Display Modes
Old 11-14-2015, 01:28 PM   #1 (permalink)
Registered Users
 

Join Date: Nov 2013
Location: Aberdeen, UK
Default Quasar 7075 LMT sudden failure

I had a lucky escape with my G630 today. I want to the field for a few flights with the Goblins and my Chase 360. I flew the chase first, all was fine, then went to fly the Goblin.

I powered up the Goblin and all seemed ok, the LED on the Spirit FBL lit up and the servos centred, then I realised I'd stupidly not changed model memories in the Tx so I had no bind with the heli. I powered down the heli changed model memory and powered back up. This time when I powered up the heli the servos and FBL didn't initiate The ESC/motor beeped to count off the cells, so I knew power was on at the ESC but apparently the BEC wasnt outputting voltage to the FBL. It's fitted with Gryphon Quasar 7075 LMT, I noticed that it wasn't lighting up like it normally does. There was no obvious wiring or connection fault so I had to abandon flying the Goblin for the day.

When I got home I tested the BEC and it was dead as a door nail, no LED's, zero volts at the output, nada. Luckily I had a spare which I had put aside for my Kasama Dune so I fitted the spare and all started working fine. I opened up the faulty one but there was nothing obviously wrong, it wasn't a broken wire because my multimeter told me that power was getting through to the PCB, there were no obviously burned components.

So anyone ever experienced anything similar? Seems like it failed during the power down and power up cycle when I changed model memories.
__________________
Gob Kraken |Gob 700 BT 'T' | Gob 770 Comp | SoXos Strike 7 | Henseleit TDR, TDSF & TDR2 | Kasama Dune | OMP M1&M2 | UK stockist for OMPHobby M1/M2 ScotiaRC.co.uk
Smoggie is offline        Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 11-14-2015, 03:56 PM   #2 (permalink)
Registered Users
 
Posts: 1,425
 

Join Date: Nov 2012
Default

I have a similar result after powering up. But it wasn't because I chose a current model. I think others have problems with this product.

I opened it up & could not see any burn marks & signs of failure. I gave up & went to straight 2S lipo.
dgunawan is offline        Reply With Quote Quick reply to this message
Old 11-14-2015, 05:31 PM   #3 (permalink)
Registered Users
Thread Starter Thread Starter
 

Join Date: Nov 2013
Location: Aberdeen, UK
Default

Thanks for the feedback. I'm sure changing models had nothing to do it other than it caused me to power cycle the BEC.
__________________
Gob Kraken |Gob 700 BT 'T' | Gob 770 Comp | SoXos Strike 7 | Henseleit TDR, TDSF & TDR2 | Kasama Dune | OMP M1&M2 | UK stockist for OMPHobby M1/M2 ScotiaRC.co.uk
Smoggie is offline        Reply With Quote Quick reply to this message
Reply




Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the HeliFreak forums, you must first register.
Please enter your desired user name, your REAL and WORKING email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself. Use a real email address or you will not be granted access to the site. Thank you.
Email Address:
Location
Where do you live? ie: Country, State, City or General Geographic Location please.
Name and Lastname
Enter name and last name here. (This information is not shown to the general public. Optional)
Helicopter #1
Enter Helicopter #1 type and equipment.
Helicopter #2
Enter Helicopter #2 type and equipment.
Helicopter #3
Enter Helicopter #3 type and equipment.
Helicopter #4
Enter Helicopter #4 type and equipment.

Log-in


Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On




Copyright © Website Acquisitions Inc. All rights reserved.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2021 DragonByte Technologies Ltd.

SEO by vBSEO 3.6.1