Commander 160A SBEC won't arm - HeliFreak
Fun, Learning, Friendship and Mutual Respect START  HERE


Unregistered
Go Back   HeliFreak > R/C Electronics Support > Scorpion ESC and Motor Support


Scorpion ESC and Motor Support Scorpion Power Systems ESC and Motor Factory Support Forum


Reply
 
LinkBack Thread Tools Display Modes
Old 09-26-2017, 05:13 AM   #1 (permalink)
Registered Users
 
Posts: 301
 
My HF Map location
Join Date: Jul 2008
Location: Lithuania, EU
Question Commander 160A SBEC won't arm

Please help me on this, or in end up in the mental house.
I'm assembling my Goblin and setting up this damn ESC for 2 days now. I read a bunch of threads with no answer.
My scorpion commander 160A SBEC version won't arm when connect it to BRAIN with 2 dsm2 sats. It just beeps all day and LED flashing orange.
This happens JUST when I use internal BEC.
BUT !
When I connect first other power source to power up Brain, and then plug ESC it will arm without any problems.
I set up throttle range.
Another interesting thing, that I can set up ESC just via USB support. With programming card the IR Receiver LED just flashes and It won't confirm my inputs from the programming card.
Please help me on this.... Im desparate.
__________________
Trex 800Pro DFC, Trex 500Pro DFC, Blade 180CFX
DerClown is offline        Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 09-26-2017, 06:09 AM   #2 (permalink)
Registered Users
 
Posts: 301
Thread Starter Thread Starter
 
My HF Map location
Join Date: Jul 2008
Location: Lithuania, EU
Default

I made a video of my problem:

Scorpion commander 160A SBEC problem with Brain (1 min 19 sec)
__________________
Trex 800Pro DFC, Trex 500Pro DFC, Blade 180CFX
DerClown is offline        Reply With Quote Quick reply to this message
Old 09-26-2017, 06:43 AM   #3 (permalink)
Registered Users
 
Posts: 301
Thread Starter Thread Starter
 
My HF Map location
Join Date: Jul 2008
Location: Lithuania, EU
Default

Okay, I managed to figure out what has been causing this.
When connected internal BEC, the Brain sometimes manages to initialize (lights turn up) and ESC to arm properly, but this happens every 5-10 time when I connect it. All other times satellites light up, but lights on Brains remain dark. When it does, the ESC won't arm. That makes sense.
BUT:
When I connect external BEC, the BRAIN manages to initialize every single time and off course ESC arms.
What can cause Brain refuse to initialize when connected to ESC internal BEC ?
P.S.
And I haven't connected the small red Anti spark plug anywhere, maybe that does sense ?
__________________
Trex 800Pro DFC, Trex 500Pro DFC, Blade 180CFX
DerClown is offline        Reply With Quote Quick reply to this message
Reply




Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the HeliFreak forums, you must first register.
Please enter your desired user name, your REAL and WORKING email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself. Use a real email address or you will not be granted access to the site. Thank you.
Email Address:
Location
Where do you live? ie: Country, State, City or General Geographic Location please.
Name and Lastname
Enter name and last name here. (This information is not shown to the general public. Optional)
Helicopter #1
Enter Helicopter #1 type and equipment.
Insurance
Please select your insurance company (Optional)
Helicopter #2
Enter Helicopter #2 type and equipment.
Helicopter #3
Enter Helicopter #3 type and equipment.
Helicopter #4
Enter Helicopter #4 type and equipment.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On




Copyright © VerticalScope Inc. All rights reserved.
 

SEO by vBSEO 3.6.1