Fun, Learning, Friendship and Mutual Respect START  HERE


Unregistered
Go Back   HeliFreak > R/C Helicopter Support > Other Makes and Models Helicopters > V977/K110/K120



Like Tree39Likes
Reply
 
LinkBack Thread Tools Display Modes
Old 08-22-2020, 10:21 AM   #161 (permalink)
Registered Users
 

Join Date: Dec 2006
Default

You don't happen to have throttle hold on do you?

Have you selected the correct flight mode that you programmed with the linear curve?
__________________
Don't quote me to answer please, just add a comment.
Andy from Sandy is online now        Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 08-22-2020, 10:56 AM   #162 (permalink)
Registered Users
 

Join Date: May 2020
Location: Melbourne, Australia
Default

Quote:
Originally Posted by Andy from Sandy View Post
You don't happen to have throttle hold on do you?

Have you selected the correct flight mode that you programmed with the linear curve?
No throttle hold and throttle output is verified to be at 100% (2012 us) through the transmitter screen (output monitor).

I did change the max throttle to 1980 within BLHeli Suite. So my guess is that I'm not hitting that threshold and therefore the ESC doesn't recognise that my throttle stick is at 100%. There must be some conversion between the transmitter and the receiver causing the 2012 not to be recognised.

Should I lower this to something way below maximum in BLHeli Suite (e.g. 1200) and then set the range through the transmitter? Is that the purpose of this exercise?
TedAud is offline        Reply With Quote Quick reply to this message
Old 08-23-2020, 03:07 PM   #163 (permalink)
Registered Users
 

Join Date: Feb 2007
Location: England
Default

Quote:
Originally Posted by TedAud View Post
Hi Mikej,

I've tried your instructions but don't get the confirmation beeps other than the usual start up beeps. What I did was turn on the transmitter, using a linear 0-100 throttle curve, move the throttle stick to the highest position, then connect the battery to the ESC (as per usual when flying). I then get the usual startup sequence of beeps, but nothing beyond that.

Any advice would be appreciated.

Also, what's the difference setting the throttle this way to setting the min and max throttle in BLHeli Suite?

Thanks.
You will need to have "Programming by Tx" box ticked. I found that it gave better calibration (more resolution, and more HS) than doing it via the software
Mikej is offline        Reply With Quote Quick reply to this message
Old 08-23-2020, 03:13 PM   #164 (permalink)
Registered Users
 

Join Date: Feb 2007
Location: England
Default

Quote:
Originally Posted by TedAud View Post
Thanks for sharing this guide e92.M3. Have you tried connecting only two wires (ground and signal, without connecting the 5V) for an even cleaner mod? I've seen ESCs that only need ground and signal, so just wondering if that applies to this ESC.

Cheers
Without the red wire you won't have any power going to the Flight Contorller / servos etc. with this ESC, some ESCs for quads etc use only 2 wires - but they generally have separate power for the FC etc.
Mikej is offline        Reply With Quote Quick reply to this message
Old 08-24-2020, 09:25 AM   #165 (permalink)
Registered Users
 

Join Date: May 2020
Location: Melbourne, Australia
Default

Thanks Mike. I've managed to flash BLHeli and then remove the wires I soldered as the cable to the receiver (ground and signal only) can be used for programming once BLHeli bootloader is installed (as part of the BLHeli firmware). I power the ESC through the existing battery connector.
TedAud is offline        Reply With Quote Quick reply to this message
Old 08-24-2020, 03:26 PM   #166 (permalink)
Registered Users
 

Join Date: Feb 2007
Location: England
Default

Quote:
Originally Posted by TedAud View Post
Thanks Mike. I've managed to flash BLHeli and then remove the wires I soldered as the cable to the receiver (ground and signal only) can be used for programming once BLHeli bootloader is installed (as part of the BLHeli firmware). I power the ESC through the existing battery connector.
That's what I do with most of mine Ted - works a treat. I have left the programming wires on some of them (but I always solder on a short lead with a small plug on the end) purely because the first toolstick that I bought only handled 4-wire comms. I subsequently bought another toolstick that does 4-wire and the servo lead comms.

I've now got about 6 or 7 ESC's using BLHeli - it gave a new life to ESCs that I had given up on due to the lack of a decent Governer.

Have you managed to calibrate your throttle OK?
Mikej is offline        Reply With Quote Quick reply to this message
Old 08-24-2020, 11:48 PM   #167 (permalink)
Registered Users
 

Join Date: May 2020
Location: Melbourne, Australia
Default

Quote:
Originally Posted by Mikej View Post
Have you managed to calibrate your throttle OK?
Unfortunately not. I broke my Arduino (long story!) so have to wait for a new one to arrive in the mail before I can get back into BLHeli to lower the max throttle point. I think 1980 is too high, causing the ESC to not recognise the throttle high point when I power it up. So I can't get into calibration mode at the moment.

On a separate but related matter, what do you guys seek to achieve with the BLHeli tweaks? Is it just to set a fixed head speed so that
collective, cyclic and tail behave more consistently? Any other performance tweaks?

Also, I know that throttle curve and governor % are different. What I'm not clear about is how they interact. Does the governor dictate the maximum allowed head speed, with the throttle % acting as a multiplier? E.g. Governor set to 90% and throttle set to 50% = 45% of max possible motor speed?

Thanks.
TedAud is offline        Reply With Quote Quick reply to this message
Old 09-02-2020, 10:23 AM   #168 (permalink)
Registered Users
 

Join Date: May 2020
Location: Melbourne, Australia
Default

Hi Mike

I've reset the PPM Min Throttle and PPM Max Throttle to default values and attempted to calibrate the ESC again. Unfortunately, still no luck.

Mind taking a look at this short video to see where I'm going wrong?

Unsuccessful ESC calibration (0 min 56 sec)


Thanks
TedAud is offline        Reply With Quote Quick reply to this message
Old 09-02-2020, 02:03 PM   #169 (permalink)
Registered Users
 

Join Date: Feb 2007
Location: England
Default

Can you check that you had "Programming by Tx" box ticked when you check the BLHeli config - if not it will ignore the throttle completely, you needed this enabled to calibrate the end points
Mikej is offline        Reply With Quote Quick reply to this message
Old 09-02-2020, 07:01 PM   #170 (permalink)
Registered Users
 

Join Date: May 2020
Location: Melbourne, Australia
Default

Quote:
Originally Posted by Mikej View Post
Can you check that you had "Programming by Tx" box ticked when you check the BLHeli config - if not it will ignore the throttle completely, you needed this enabled to calibrate the end points
Hi Mike, yes I did check that and it's definitely ticked.

I presume channel 6 output is irrelevant to this process?
TedAud is offline        Reply With Quote Quick reply to this message
Old 09-05-2020, 02:29 AM   #171 (permalink)
Registered Users
 

Join Date: Feb 2007
Location: England
Default

Sorry, I don't know what Channel 6 output is...

I'm stumped now - it has always worked for me - with a little messing about with end points etc. occassionally
Mikej is offline        Reply With Quote Quick reply to this message
Old 09-05-2020, 03:25 AM   #172 (permalink)
Registered Users
 

Join Date: May 2020
Location: Melbourne, Australia
Default

No worries Mike. I've just set the min and max to default in BLHeli suite. Thanks.
TedAud is offline        Reply With Quote Quick reply to this message
Old 09-05-2020, 05:35 AM   #173 (permalink)
Registered Users
 
Posts: 1,549
 

Join Date: Jul 2012
Location: Austin, UT USA
Default

Quote:
Originally Posted by TedAud View Post
... attempted to calibrate the ESC again. Unfortunately, still no luck.

Mind taking a look at this short video to see where I'm going wrong? ...
You can't simply power up the heli at full throttle - you need to power up and initialize the FBL/RX before sending the 100% Thr signal to the ESC. This requires powering up the FBL/RX with the ESC signal line disconnected (and the Thr channel from the Tx @0%), and then apply 100% throttle, and then connect the signal line to the ESC. The FBL/RX will not send out any signal to the ESC until it sees 0% from the Tx (and that is why your technique is not working). Its all explained in the following post by BirdBarber...

K110 ESC Calibration and Programming

Here's the pertinant part:
Quote:
Originally Posted by BirdBarber View Post
...
-- How to Enter Calibration Mode --

The sequence to calibrate the ESC to match your transmitter's throttle range is:
1 Remove white ESC wire pin from the ESC to receiver plug by lifting the plastic pin retaining tab with a safety pin, or use the modified cable mentioned above.
2.Unplug tail motor wire and REMOVE THE MAIN GEAR for safety.
3 Power on TX, 0% throttle, throttle hold off.
4 Power on V977, wait until it initializes and you can move the servos with the TX stick.
5 ESC should beep every second or so.
6 Raise throttle to 100% - Throttle hold still off
7 Plug in white wire - a double beep will play
8 Wait about 2 seconds and no more, then lower the throttle to 0%.
9 Let it set for a few seconds until it beeps then unplug the heli battery, it should now be calibrated.
To accomplish this, he manually removes the signal wire from the connector, which is kinda fiddly/difficuly - I built myself a custom adapter with an in-line switch on the signal line to make this process much easier.

Hope this helps!
ridge-runner is online now        Reply With Quote Quick reply to this message
Old 09-06-2020, 03:13 AM   #174 (permalink)
Registered Users
 

Join Date: May 2020
Location: Melbourne, Australia
Default

Quote:
Originally Posted by ridge-runner View Post
Quote:
Originally Posted by TedAud View Post
... attempted to calibrate the ESC again. Unfortunately, still no luck.

Mind taking a look at this short video to see where I'm going wrong? ...
You can't simply power up the heli at full throttle - you need to power up and initialize the FBL/RX before sending the 100% Thr signal to the ESC. This requires powering up the FBL/RX with the ESC signal line disconnected (and the Thr channel from the Tx @0%), and then apply 100% throttle, and then connect the signal line to the ESC. The FBL/RX will not send out any signal to the ESC until it sees 0% from the Tx (and that is why your technique is not working). Its all explained in the following post by BirdBarber...

K110 ESC Calibration and Programming

Here's the pertinant part:
Quote:
Originally Posted by BirdBarber View Post
...
-- How to Enter Calibration Mode --

The sequence to calibrate the ESC to match your transmitter's throttle range is:
1 Remove white ESC wire pin from the ESC to receiver plug by lifting the plastic pin retaining tab with a safety pin, or use the modified cable mentioned above.
2.Unplug tail motor wire and REMOVE THE MAIN GEAR for safety.
3 Power on TX, 0% throttle, throttle hold off.
4 Power on V977, wait until it initializes and you can move the servos with the TX stick.
5 ESC should beep every second or so.
6 Raise throttle to 100% - Throttle hold still off
7 Plug in white wire - a double beep will play
8 Wait about 2 seconds and no more, then lower the throttle to 0%.
9 Let it set for a few seconds until it beeps then unplug the heli battery, it should now be calibrated.
To accomplish this, he manually removes the signal wire from the connector, which is kinda fiddly/difficuly - I built myself a custom adapter with an in-line switch on the signal line to make this process much easier.

Hope this helps! [IMG class=inlineimg]https://www.helifreak.com/images/smilies/icon_biggrin.gif[/IMG]
Thank you! I got both my K110s calibrated now.

Cheers.
TedAud is offline        Reply With Quote Quick reply to this message
Old 05-13-2021, 04:41 PM   #175 (permalink)
Registered Users
 

Join Date: Jul 2014
Default

Can somebody help me figure out how to connect my arduino nano to the speed controller?

Last week I flashed it with blheli, i soldered the 3 wires and used my arduino uno to flash without any problems, i read so many times on this thread that once you flash it with blheli you can take the three small wires off which I did,

I decided to try and save some weight by soldering the motors wires directly to the esc wires, afterwards I realized I switched two of the wires because the rotor was spinning backwards, I dont want to flip two motors wires, makes a lot more sense to just reverse it in blheli and would be nice to alter other settings as well.

I am trying to connect with my arduino nano, i followed instructions from last page, i connect white wire to d2 pin and ground wire to ground pin. I load up blhelisuite and I select SILABS BLheli Bootloader (4way-if), i have the correct com port selected and click connect, it has no problem connecting to the arduino nano, but once I click read setup it says

"connection to esc #1 failed! please check data- und power-connections to the ESC"

I make sure to connect the battery before trying to connect, it just doesn't want to work

Am i missing a step? Do i need to create a new interface? in make interface tab I chose arduino 4-way interface and flashed it with the MULTI file.

Any help is appreciated
dinsum is offline        Reply With Quote Quick reply to this message
Old 05-13-2021, 04:42 PM   #176 (permalink)
Registered Users
 

Join Date: Jul 2014
Default

Quote:
Originally Posted by TedAud View Post
Took me a good part of the day to figure out, but finally sorted.

Once you've flashed BLHeli (revision 13.2 and above), the bootloader will automatically be installed. Once you have the bootloader installed, you can then remove the connectors/wires you've soldered on.

To connect to BLHeli in the future (using BLHeli Suite), you just need to use the existing connector that plugs into the flight controller, utilising only two pins (black = ground, and white = signal).

Within BLHeli Suite, select the SILABS BLHeli 4-way interface (this is using an Arduino board) and away you go. I'm using an Arduino Nano board, so the signal pin from the ESC goes to Digital pin 2, and ground to ground.

The attached manual shows how to use the different programming connectors you may have in your toolbox.


Can somebody help me figure out how to connect my arduino nano to the speed controller?

Last week I flashed it with blheli, i soldered the 3 wires and used my arduino uno to flash without any problems, i read so many times on this thread that once you flash it with blheli you can take the three small wires off which I did,

I decided to try and save some weight by soldering the motors wires directly to the esc wires, afterwards I realized I switched two of the wires because the rotor was spinning backwards, I dont want to flip two motors wires, makes a lot more sense to just reverse it in blheli and would be nice to alter other settings as well.

I am trying to connect with my arduino nano, i followed instructions from last page, i connect white wire to d2 pin and ground wire to ground pin. I load up blhelisuite and I select SILABS BLheli Bootloader (4way-if), i have the correct com port selected and click connect, it has no problem connecting to the arduino nano, but once I click read setup it says

"connection to esc #1 failed! please check data- und power-connections to the ESC"

I make sure to connect the battery before trying to connect, it just doesn't want to work

Am i missing a step? Do i need to create a new interface? in make interface tab I chose arduino 4-way interface and flashed it with the MULTI file.

Any help is appreciated
dinsum is offline        Reply With Quote Quick reply to this message
Old 05-15-2021, 08:34 AM   #177 (permalink)
Registered Users
 

Join Date: Jul 2014
Default

Sorry for the double post,

I figured it out, that post was wrong saying to use pin D2 and ground, its actually pin D3 and ground, I figured the post was correct because nobody corrected it.... all good now
dinsum is offline        Reply With Quote Quick reply to this message
Reply




Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the HeliFreak forums, you must first register.
Please enter your desired user name, your REAL and WORKING email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself. Use a real email address or you will not be granted access to the site. Thank you.
Email Address:
Location
Where do you live? ie: Country, State, City or General Geographic Location please.
Name and Lastname
Enter name and last name here. (This information is not shown to the general public. Optional)
Helicopter #1
Enter Helicopter #1 type and equipment.
Helicopter #2
Enter Helicopter #2 type and equipment.
Helicopter #3
Enter Helicopter #3 type and equipment.
Helicopter #4
Enter Helicopter #4 type and equipment.

Log-in


Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On




Copyright © Website Acquisitions Inc. All rights reserved.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2021 DragonByte Technologies Ltd.

SEO by vBSEO 3.6.1