Fun, Learning, Friendship and Mutual Respect START  HERE


Unregistered
Go Back   HeliFreak > R/C Helicopter Support > Blade Helicopters (eFlite) > 270CFX


270CFX Blade 270CFX Helicopters Information and Help


Reply
 
LinkBack Thread Tools Display Modes
Old 02-04-2018, 05:46 PM   #1 (permalink)
Registered Users
 

Join Date: Dec 2010
Default 270cfx not flying

I thought I put in all the proper settings as per manual, got bail out but, when I try to lift off it acts like it is throttle hold
sing23 is offline        Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 02-04-2018, 05:59 PM   #2 (permalink)
Registered Users
 
Posts: 9,358
 

Join Date: Feb 2013
Location: Fargo ND (Home of the NDSU Thundering Herd)
Default

Throttle Hold?

As in motor shutdown?
__________________
nCPX(3)*mCPX(25)*130X(10)*130X-L(6)*180CFX(3)*300X/CFX(3)
450X(7)*470LP*GauiX3*nanoQX*180QX*DX9*HF180060*AMA 988253
JonJet is online now        Reply With Quote Quick reply to this message
Old 02-04-2018, 09:34 PM   #3 (permalink)
Registered Users
Thread Starter Thread Starter
 

Join Date: Dec 2010
Default 270cfx

The blades and the servos move but heli motor does not start up.
sing23 is offline        Reply With Quote Quick reply to this message
Old 02-04-2018, 09:41 PM   #4 (permalink)
Registered Users
 
Posts: 9,358
 

Join Date: Feb 2013
Location: Fargo ND (Home of the NDSU Thundering Herd)
Default

What Tx are you using...

Perhaps the Talon ESC is not seeing zero throttle so the startup cannot occur
__________________
nCPX(3)*mCPX(25)*130X(10)*130X-L(6)*180CFX(3)*300X/CFX(3)
450X(7)*470LP*GauiX3*nanoQX*180QX*DX9*HF180060*AMA 988253
JonJet is online now        Reply With Quote Quick reply to this message
Old 02-04-2018, 10:09 PM   #5 (permalink)
Registered Users
 
Posts: 7,997
 

Join Date: Jun 2016
Default

Try lowering the throttle trim all the way down. If that fixes it you need to do throttle calibration.
BrokeDad is online now        Reply With Quote Quick reply to this message
Old 02-05-2018, 05:56 AM   #6 (permalink)
Registered Users
 
Posts: 10,670
 

Join Date: Feb 2012
Location: Northern, VA
Default

Do you hear the tones from the motor?
__________________
-Ben
Oxy 2/3/4/5; Specter 700; Kraken; Jeti DS-14/DX9

EGODRIFT Team, Lynx/Oxy Field Rep
jrman83 is offline        Reply With Quote Quick reply to this message
Old 02-05-2018, 06:09 AM   #7 (permalink)
Registered Users
Thread Starter Thread Starter
 

Join Date: Dec 2010
Default 270cfx

I am using the dx6 v2 and I here the tones for the start up tones. I have my thr. trim all the way down.
sing23 is offline        Reply With Quote Quick reply to this message
Old 02-05-2018, 05:25 PM   #8 (permalink)
Registered Users
 
Posts: 10,670
 

Join Date: Feb 2012
Location: Northern, VA
Default

Quote:
Originally Posted by sing23 View Post
I am using the dx6 v2 and I here the tones for the start up tones. I have my thr. trim all the way down.
So you hear the very first musical part, then a tone for however many cells you are hooked in with, I assume 6, after that do you hear a final tone?
__________________
-Ben
Oxy 2/3/4/5; Specter 700; Kraken; Jeti DS-14/DX9

EGODRIFT Team, Lynx/Oxy Field Rep
jrman83 is offline        Reply With Quote Quick reply to this message
Old 02-05-2018, 11:54 PM   #9 (permalink)
Registered Users
 
Posts: 9,358
 

Join Date: Feb 2013
Location: Fargo ND (Home of the NDSU Thundering Herd)
Default

270CFX Castle Creations ESC Throttle Programming

1) Radio on - All blades removed or motor disengaged from pinion
2) Throttle Curve 0-25-50-75-100
3) Throttle Travel set to 30 at high and low travel positions
4) Throttle at max position - plug in battery - wait for beeps to verify programming mode
5) Adjust max throttle travel upward to around 100 until ESC beeps
6) Throttle stick to low position - Adjust low throttle travel upward until ESC beeps
7) Exit Travel menu - disconnect battery
8) With throttle stick at low reconnect battery - wait for initialization to complete - signifying the ESC/FBL is ready

Throttle should work just fine now - test at will before re-engaging motor pinion or installing the blades

Lots of vids on YouTube
__________________
nCPX(3)*mCPX(25)*130X(10)*130X-L(6)*180CFX(3)*300X/CFX(3)
450X(7)*470LP*GauiX3*nanoQX*180QX*DX9*HF180060*AMA 988253
JonJet is online now        Reply With Quote Quick reply to this message
Old 02-15-2018, 01:00 PM   #10 (permalink)
Registered Users
Thread Starter Thread Starter
 

Join Date: Dec 2010
Default 270cfx

Problem solved, thanks for last post.
sing23 is offline        Reply With Quote Quick reply to this message
Reply




Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the HeliFreak forums, you must first register.
Please enter your desired user name, your REAL and WORKING email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself. Use a real email address or you will not be granted access to the site. Thank you.
Email Address:
Location
Where do you live? ie: Country, State, City or General Geographic Location please.
Name and Lastname
Enter name and last name here. (This information is not shown to the general public. Optional)
Helicopter #1
Enter Helicopter #1 type and equipment.
Helicopter #2
Enter Helicopter #2 type and equipment.
Helicopter #3
Enter Helicopter #3 type and equipment.
Helicopter #4
Enter Helicopter #4 type and equipment.

Log-in


Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On




Copyright © Website Acquisitions Inc. All rights reserved.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.

SEO by vBSEO 3.6.1