Governor is Oscillating really bad - HeliFreak
Fun, Learning, Friendship and Mutual Respect START  HERE


Unregistered
Go Back   HeliFreak > R/C Electronics Support > Futaba Radios and Electronics > Futaba CGY750 FBL System


Futaba CGY750 FBL System Futaba CGY750 Help and features Support Forum


Reply
 
LinkBack Thread Tools Display Modes
Old 05-09-2018, 07:22 AM   #1 (permalink)
Registered Users
 

Join Date: May 2006
Location: Wayne NJ
Default Governor is Oscillating really bad

Iím flying a furry 55 with YS60SR and I canít get the gov. To stop oscillating. The gov gain was at 45 I got it down to 10 and got better but still oscillating. What else can I do to stop the gov from oscillating?
joecass2 is online now        Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 05-09-2018, 11:03 AM   #2 (permalink)
Registered Users
 
Posts: 1,458
 

Join Date: Jan 2015
Location: Santa Cruz
Default

Is it possibly the tune?
__________________
Steve
smittylube is offline        Reply With Quote Quick reply to this message
Old 05-09-2018, 12:33 PM   #3 (permalink)
Registered Users
Thread Starter Thread Starter
 

Join Date: May 2006
Location: Wayne NJ
Default

Quote:
Originally Posted by smittylube View Post
Is it possibly the tune?
Could be I will try that thanks
joecass2 is online now        Reply With Quote Quick reply to this message
Old 05-09-2018, 12:50 PM   #4 (permalink)
Registered Users
 
Posts: 1,458
 

Join Date: Jan 2015
Location: Santa Cruz
Default

did it work right before?

I had an idle needle fall out because the spring that holds it broke. I was wondering why it was running weird.
__________________
Steve
smittylube is offline        Reply With Quote Quick reply to this message
Old 05-09-2018, 02:08 PM   #5 (permalink)
Registered Users
Thread Starter Thread Starter
 

Join Date: May 2006
Location: Wayne NJ
Default

I changed to different nitro and messed around with the needles but I think Iím pretty close on the tune. Can be more then a click or 2 away. Itís making good power and running really well.
joecass2 is online now        Reply With Quote Quick reply to this message
Old 05-09-2018, 06:45 PM   #6 (permalink)
Registered Users
 
Posts: 1,458
 

Join Date: Jan 2015
Location: Santa Cruz
Default

sensor magnet fell out?
__________________
Steve
smittylube is offline        Reply With Quote Quick reply to this message
Old 05-09-2018, 06:50 PM   #7 (permalink)
Registered Users
Thread Starter Thread Starter
 

Join Date: May 2006
Location: Wayne NJ
Default

Iíll check that too thanks man
joecass2 is online now        Reply With Quote Quick reply to this message
Old 05-09-2018, 07:21 PM   #8 (permalink)
Registered Users
Thread Starter Thread Starter
 

Join Date: May 2006
Location: Wayne NJ
Default

Iím using spectrum back plate sensor so Iím good there.
joecass2 is online now        Reply With Quote Quick reply to this message
Reply




Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the HeliFreak forums, you must first register.
Please enter your desired user name, your REAL and WORKING email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself. Use a real email address or you will not be granted access to the site. Thank you.
Email Address:
Location
Where do you live? ie: Country, State, City or General Geographic Location please.
Name and Lastname
Enter name and last name here. (This information is not shown to the general public. Optional)
Helicopter #1
Enter Helicopter #1 type and equipment.
Helicopter #2
Enter Helicopter #2 type and equipment.
Helicopter #3
Enter Helicopter #3 type and equipment.
Helicopter #4
Enter Helicopter #4 type and equipment.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On




Copyright © Website Acquisitions Inc. All rights reserved.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2018 DragonByte Technologies Ltd.

SEO by vBSEO 3.6.1