Fun, Learning, Friendship and Mutual Respect START  HERE


Unregistered
Go Back   HeliFreak > R/C Helicopter Support > Blade Helicopters (eFlite) > Blade mCPS


Blade mCPS Blade mCPS Helicopters Information and Help


Reply
 
LinkBack Thread Tools Display Modes
Old 05-27-2018, 11:35 PM   #1 (permalink)
Registered Users
 

Join Date: May 2018
Default mcps flight mode issues with DX6

I am having issues getting the flight modes to work correctly on the new mCP S paired with a DX6 transmitter - I can only get stability mode to work.

*** if someone could export their DX6 settings that work it would be greatly appreciated (SPM file)***

Using the manuals CH5 -> GEAR -> SW B mapping the heli is unresponsive.

In "STABILITY" mode the LED is BLUE/RED, the lift stick moves full collective up and down but the motor doesnt engage, right stick cyclic doesn't do anything.

In AGILITY once throttle hold is removed, left stick at mid point the motor is off. Moving the stick >50% the motor will decide to turn on. Collective never appears to go negative.

I then tried disabling CH5 (INH), this resulted in the LED indicating BLUE and I was able to fly in what appears to be STABILITY mode.

I then tried mapping SW D to CH5 so I could change the mode independently of the TX pitch/throttle setting. This is what I observed:

CH5=100: appears to be what puts it in an unknown mode with the blue/red LED on.

CH5=0: blue LED on, flys in stability mode

CH5=-100: blue LED on when left stick >50%, RED when <50%. Motor only engages when left stick >50% (blue LED) even though transmitter monitor screen shows 100% THR.

There seems to be a disagreement between the TX monitor screen and what the heli decides it should do. IE agility mode TX indicating 100%THR and NEG collective but the heli is motor off and collective barely goes negative.

Any help is appreciated.

*I have used the SPM file to program my receiver and have also manually programmed it IAW the manual. Neither seem to work.
jkwalker is offline        Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 06-10-2018, 12:49 AM   #2 (permalink)
Registered Users
 
Posts: 234
 

Join Date: Oct 2017
Default

I use dx6 with mcps, followed manual and had no problems. Did you know Every time you make change in settings from 'root menu ' (the one that contains channel assign/config, model name, flight mode setup, etc). You must rebind your heli to the tx afterward. Did you rebind after making such change?



Sent from my EVA-L09 using Tapatalk
koopa137 is offline        Reply With Quote Quick reply to this message
Old 06-22-2018, 02:38 PM   #3 (permalink)
Registered Users
 

Join Date: Feb 2011
Default

make sure you did binding correctly, I have had also similar issues, see solution that worked for me

https://www.helifreak.com/showthread...=6#post7593525
Fiergo is offline        Reply With Quote Quick reply to this message
Old 10-24-2018, 12:15 AM   #4 (permalink)
Registered Users
 

Join Date: Oct 2018
Default

Wow I was having the same issues and was going insane!
This is after going through 3 helis! and a DXe transmitter, then a DX6 transmitter, and multiple people at horizon hobby clueless...
I was moving the left stick to the right after turning on because that's when the DXe would beep. but it's GOT to be in the lower right corner with bind button pressed when powering on or else you get both red and blue lights on...
This has been a nightmare for a month and seems to be solved now!
flyingfadi is offline        Reply With Quote Quick reply to this message
Reply




Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the HeliFreak forums, you must first register.
Please enter your desired user name, your REAL and WORKING email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself. Use a real email address or you will not be granted access to the site. Thank you.
Email Address:
Location
Where do you live? ie: Country, State, City or General Geographic Location please.
Name and Lastname
Enter name and last name here. (This information is not shown to the general public. Optional)
Helicopter #1
Enter Helicopter #1 type and equipment.
Helicopter #2
Enter Helicopter #2 type and equipment.
Helicopter #3
Enter Helicopter #3 type and equipment.
Helicopter #4
Enter Helicopter #4 type and equipment.

Log-in


Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On




Copyright © Website Acquisitions Inc. All rights reserved.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.

SEO by vBSEO 3.6.1