Fun, Learning, Friendship and Mutual Respect START  HERE


Unregistered
Go Back   HeliFreak > R/C Helicopter Support > Mikado Logo Helicopters


Mikado Logo Helicopters Mikado Logo Helicopters Discussion


Like Tree4Likes
Reply
 
LinkBack Thread Tools Display Modes
Old 06-24-2018, 06:31 AM   #1 (permalink)
Registered Users
 

Join Date: Jul 2014
Default Logo 550 tail wag in hover FIXED!!!

I've had the new Logo 550 for the past year and frankly I haven't been happy with it. The tail has consistently wagged during hover and what ever I tried could not get rid of it. A few HF and FB flyers guided me to file the plastic ball ends on the grips (which helped slightly), shimming out slop, and moving the washers and bearings around to ensure they didn't bind but still I had the dreaded tail wag in hover. Nothing worked and I was getting ready to bin the heli.
A few flyers recommended I try the "QuickUK" alloy tail upgrade, which I installed and took for a maiden flight this weekend and surprise, surprise the tail wag is completely GONE. Shout out to anyone battling the same tail wag that I was having that I highly recommend the QuickUK tail upgrade. It will resolve the problem instantly plus it looks a lot better than those cheap looking plastic grips.
I've spoken to nearly 10 people now who have experienced this tail wag issue so its a common problem. I wish Mikado had this right from the beginning because it would have saved a lot of stress and bother.
GO QuickUK
I'm loving my Logo now
smyster is offline        Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 06-24-2018, 03:04 PM   #2 (permalink)
Registered Users
 
Posts: 2,275
 

Join Date: Jan 2015
Location: Santa Cruz
Default

IIRC there has been some mention of faulty thrust bearings. Some mismatch of the cage or race maybe?

But I agree a good tail is gold.

For best long term results I always suggest remove the mains and tail control rod and dynamically balance the tail at the speeds you fly.
__________________
Steve
smittylube is offline        Reply With Quote Quick reply to this message
Old 06-24-2018, 04:08 PM   #3 (permalink)
Registered Users
 
Posts: 7,736
 

Join Date: Apr 2016
Location: Michigan
Default

Quote:
Originally Posted by smittylube View Post
IIRC there has been some mention of faulty thrust bearings. Some mismatch of the cage or race maybe?

But I agree a good tail is gold.

For best long term results I always suggest remove the mains and tail control rod and dynamically balance the tail at the speeds you fly.
Yeah. I thought some used msh thrust bearings and races and solved it. Can't find the posts.
Thickfog is offline        Reply With Quote Quick reply to this message
Old 06-24-2018, 07:28 PM   #4 (permalink)
Registered Users
 
Posts: 7,481
 
My HF Map location
Join Date: Dec 2010
Location: Goodview,MN.
Default

Quote:
Originally Posted by smyster View Post
I've had the new Logo 550 for the past year and frankly I haven't been happy with it. The tail has consistently wagged during hover and what ever I tried could not get rid of it. A few HF and FB flyers guided me to file the plastic ball ends on the grips (which helped slightly), shimming out slop, and moving the washers and bearings around to ensure they didn't bind but still I had the dreaded tail wag in hover. Nothing worked and I was getting ready to bin the heli.
A few flyers recommended I try the "QuickUK" alloy tail upgrade, which I installed and took for a maiden flight this weekend and surprise, surprise the tail wag is completely GONE. Shout out to anyone battling the same tail wag that I was having that I highly recommend the QuickUK tail upgrade. It will resolve the problem instantly plus it looks a lot better than those cheap looking plastic grips.
I've spoken to nearly 10 people now who have experienced this tail wag issue so its a common problem. I wish Mikado had this right from the beginning because it would have saved a lot of stress and bother.
GO QuickUK
I'm loving my Logo now
Is that the same part as Mikado offers Now? The aluminum block between the tail case plates?
__________________
LOGO: 550SX, 700
SAB: MINI COMET, KRAKEN
VCONTROL*NEO*TRIBUNUS*MKS*TORQ*VTX*DPL8 W/BUMP CONTROL*MEANWELL
Corvette & Copter Guy is online now        Reply With Quote Quick reply to this message
Old 06-25-2018, 03:38 AM   #5 (permalink)
Registered Users
Thread Starter Thread Starter
 

Join Date: Jul 2014
Default

Hi, its not the Mikado one. The manufacturer is "QuickUK". Below is the link to the part. I highly recommend it to anyone having the tail wag issue.

Quick UK Retail - shop-products
smyster is offline        Reply With Quote Quick reply to this message
Old 06-25-2018, 05:29 AM   #6 (permalink)
Registered Users
 

Join Date: Dec 2006
Default

Were you able to use the brass insert from your kit?

Quick UK sells the tail slider with and without a brass insert.

Shows slider with insert:-

Quick UK Retail - shop-products

Getting the tail grips, slider and hub working as it should on a Logo is not straight forward. It seems everyone has to do a certain amount of fettling. The fan boys that have built multiple Logos do this with their eyes shut but for the new comer to Mikado this is such a frustrating model to get flying perfectly. Once achieved of course it is one of the best models ever.

If you have done everything suggested with making sure the bearings are seated properly, cleaning the flashing off the parts etc then as Bigpops found out the thrust bearings were not working properly, not something we should expect from a high end company.
Andy from Sandy is offline        Reply With Quote Quick reply to this message
Old 06-25-2018, 06:30 AM   #7 (permalink)
Registered Users
 

Join Date: Dec 2014
Location: always windy on the east coast
Default

is there a retailer here in the states?
__________________
a bunch of helis... now all vcontrol and neo..finally :lol
tonys-heli is online now        Reply With Quote Quick reply to this message
Old 06-25-2018, 06:44 AM   #8 (permalink)
Registered Users
Thread Starter Thread Starter
 

Join Date: Jul 2014
Default

Quote:
Originally Posted by Andy from Sandy View Post
Were you able to use the brass insert from your kit?

Quick UK sells the tail slider with and without a brass insert.

Shows slider with insert:-

Quick UK Retail - shop-products

Getting the tail grips, slider and hub working as it should on a Logo is not straight forward. It seems everyone has to do a certain amount of fettling. The fan boys that have built multiple Logos do this with their eyes shut but for the new comer to Mikado this is such a frustrating model to get flying perfectly. Once achieved of course it is one of the best models ever.

If you have done everything suggested with making sure the bearings are seated properly, cleaning the flashing off the parts etc then as Bigpops found out the thrust bearings were not working properly, not something we should expect from a high end company.
RE: brass insert from the kit. Yes I did use the kits brass insert. It did take some fiddling around with to line it up straight but seemed to go in ok. It would be easier to go with the brass insert pre-installed though as you point out.
smyster is offline        Reply With Quote Quick reply to this message
Old 06-25-2018, 06:45 AM   #9 (permalink)
Registered Users
Thread Starter Thread Starter
 

Join Date: Jul 2014
Default

Quote:
Originally Posted by tonys-heli View Post
is there a retailer here in the states?
Not that I know of. QuickUK is a small shop in the UK. I'm in Australia so I just bought and waited a few weeks for it to arrive.
lcatinchi likes this.
smyster is offline        Reply With Quote Quick reply to this message
Old 06-29-2018, 11:22 AM   #10 (permalink)
Registered Users
 
Posts: 7,275
 

Join Date: Jun 2009
Location: Edmonton, Alberta, Canada
Default

I had the same experience with two Logos I owned. I replace the tail grips with Quick UK after trying many things and it finally went away.

Maybe the new Logo design should have metal tail grips along with the metal head.
__________________
Synergy 696 coming, Synergy E5SS HP, E5S, 2-soXos Strike 7s, soXos 600, VControl T, VBar Neo, Scorpion Tribunus ESC, MKS/Savox
Freeskiken is offline        Reply With Quote Quick reply to this message
Old 06-29-2018, 07:14 PM   #11 (permalink)
Registered Users
 
Posts: 7,481
 
My HF Map location
Join Date: Dec 2010
Location: Goodview,MN.
Default

What other parts are needed?
__________________
LOGO: 550SX, 700
SAB: MINI COMET, KRAKEN
VCONTROL*NEO*TRIBUNUS*MKS*TORQ*VTX*DPL8 W/BUMP CONTROL*MEANWELL
Corvette & Copter Guy is online now        Reply With Quote Quick reply to this message
Old 07-02-2018, 10:29 PM   #12 (permalink)
Registered Users
 
Posts: 524
 

Join Date: May 2006
Default

every one please read the posts on the 480 xxtreme i wrote--i had the exact same issue and most people just buy a higher cost tail servo to power thru the problem--but that is not the issue -it truly has something to do with the blade grips and bearing combination-i tried everything with zero luck including sending my tail to mikado--that was waist of time --they my know the issue but wont share it--the worst part is i purchased a package including the tail servo that i guess it wasent good enough,,but thats not true i replaced the blade grips with the UKquick and yes that solved the issue--mikado needs to get a handle and fix this--it took me a long time to come to the conclusion it was the blade grips and bearings--mikado would do nothing about it--but other then the tail issue the heli is perfect...sorry for the long rant but hope it helps
__________________
I Fly Mikado, Align-repair and Build all brands
marke is offline        Reply With Quote Quick reply to this message
Old 07-03-2018, 09:06 AM   #13 (permalink)
Registered Users
 

Join Date: Dec 2006
Default

Quote:
sorry for the long rant but hope it helps
A bit of white space helps!

A link to your other rant would be very useful.
Andy from Sandy is offline        Reply With Quote Quick reply to this message
Old 07-06-2018, 08:43 AM   #14 (permalink)
Registered Users
 
Posts: 524
 

Join Date: May 2006
Default

Sorry here is the string for the 480 issue. very similar to the 550 tail. I believe its something to do with the interaction of the bearings and the blade grip slop. but i am done chasing


https://www.helifreak.com/showthread.php?t=735356
__________________
I Fly Mikado, Align-repair and Build all brands
marke is offline        Reply With Quote Quick reply to this message
Old 07-31-2019, 09:13 PM   #15 (permalink)
Registered Users
 
Posts: 1,378
 

Join Date: Jul 2013
Default

Just curious, but when I was looking at ERCMarket for the QuickUK tail hub, they mentioned it also fit an Align heli. Well, both the Align 550 and 600 uses the same tail grips so I was wondering if the Align tail grips would possibly work as a replacement for the Mikado plastic grips. Thoughts?
__________________
SAB Kraken, Align 700X, Logo 550SX, Oxy5 & 2, Protos 380 - NEO all the way!
Previous: Logo 600, Protos 700, Synergy 516, Velos 880, Gaui X7 & X5, Goblin 380, 120SR, SR, mcpx BL, 300X, 450XL, Blade 180, Align 150, DJI Spark, Leap 3D
gtruk is offline        Reply With Quote Quick reply to this message
Old 07-31-2019, 09:47 PM   #16 (permalink)
Registered Users
 

Join Date: Dec 2014
Location: always windy on the east coast
Default

I think they do, but mikado grips have that weird dog bone angle. So not sure how that plays out with the geometry.
__________________
a bunch of helis... now all vcontrol and neo..finally :lol
tonys-heli is online now        Reply With Quote Quick reply to this message
Old 07-31-2019, 11:45 PM   #17 (permalink)
Registered Users
 

Join Date: Oct 2010
Default

The gaui x5 fit too, but the Mikado's grip balls are slightly farther from the group than both the x5 and quick UKs. I tried the gaui's first, but you couldn't travel the whole tail shaft without binding, I now have the quick uks and can set the travel all the way to the hub, but about 3mm from the tail box or it binds.
My wag is gone, but the quick uk tail slider is a touch stiff and you have to use it because the tail slide bolts on to the tail grips. I needed back out the slider to grip bolt and use red Loctite - it doesn't use a bearing. Note, too, the quick uk's did not come with the brass tail slider sleeve so I had to steal one from the Mikado slider. Finally make sure you set the slider up with travel all the way to the tail hub. I was seeing ccw piro rate was far slower than the cw piro rate until pushed the travel all the way to the hub. Usually, I leave 1 to 2mm gap.
__________________
Agile 5.5, Logo 550sx, X5, Oxy 3, Trex 450proV2, 250DFC #309
nflanagin is online now        Reply With Quote Quick reply to this message
Old 08-01-2019, 12:31 AM   #18 (permalink)
Registered Users
 

Join Date: Dec 2014
Location: always windy on the east coast
Default

I found it easier to just find better thrust bearings.
__________________
a bunch of helis... now all vcontrol and neo..finally :lol
tonys-heli is online now        Reply With Quote Quick reply to this message
Old 08-01-2019, 04:09 AM   #19 (permalink)
Registered Users
 
Posts: 841
 

Join Date: Jul 2007
Default

Glad it is working for you now

Changing the tail thrust bearings improved things a bit but the wag was still there. The real problem for me was the slider. On the bench everything was smooth, but once the tail was spinning there was binding in the tail. I ended up sanding the tail shaft with very fine sanding paper and that solved the problem.

One way of seeing if the tail is binding:
Remove the blades and disconnect the tail push rod
Now start the motor, the tail should center. Give some tail input by hand and let go, the tail should recenter immediately. If it only centers slowly there is still something binding
mr. mark is offline        Reply With Quote Quick reply to this message
Old 08-01-2019, 07:49 AM   #20 (permalink)
Registered Users
 

Join Date: Dec 2014
Location: always windy on the east coast
Default

one thing I don't understand about that method.. if disconnected and no blades, how does it center?
__________________
a bunch of helis... now all vcontrol and neo..finally :lol
tonys-heli is online now        Reply With Quote Quick reply to this message
Reply




Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the HeliFreak forums, you must first register.
Please enter your desired user name, your REAL and WORKING email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself. Use a real email address or you will not be granted access to the site. Thank you.
Email Address:
Location
Where do you live? ie: Country, State, City or General Geographic Location please.
Name and Lastname
Enter name and last name here. (This information is not shown to the general public. Optional)
Helicopter #1
Enter Helicopter #1 type and equipment.
Helicopter #2
Enter Helicopter #2 type and equipment.
Helicopter #3
Enter Helicopter #3 type and equipment.
Helicopter #4
Enter Helicopter #4 type and equipment.

Log-in


Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On




Copyright © Website Acquisitions Inc. All rights reserved.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.

SEO by vBSEO 3.6.1