Fun, Learning, Friendship and Mutual Respect START  HERE


Unregistered
Go Back   HeliFreak > R/C Helicopter Support > Mikado Logo Helicopters


Mikado Logo Helicopters Mikado Logo Helicopters Discussion


Like Tree19Likes
Reply
 
LinkBack Thread Tools Display Modes
Old 08-19-2018, 01:41 PM   #21 (permalink)
Registered Users
 
Posts: 375
 
My HF Map location
Join Date: Apr 2011
Default

Robert,

I was in the same boat as you but now my tail is perfect. It is all stock but with MSH thrust bearings for the tail. I had done 2 changes
- Changed tail servo from Savox to Futaba.
- Replaced tail thrust bearings.

Although I think the tail servo change was unnecessary.

I'd try these steps and do a hover test between each.
  • Turn off governor. (Governor gains to 0)
  • Lower the tail gain to around 40.

If above 2 steps didn't help then the issue is mechanical. A slow wag is because the system is not precise enough to find the final spot where PID error is 0. This might be due to
  • too much mechanical slop. (worn out ball links/balls)
  • not smooth enough setup (thrust bearings, tight ball links). Try the spring test mentioned by @Bigpops to check thrust bearings. Also disconnect the tail control rod at tail servo end and check smoothness by moving it by hand.
  • poor tail servo resolution. Move tail servo ball inwards. Try a different tail servo.
Hope it helps. Keep trying and you will get there.
cheers,
__________________
-roger
LOGO 550SX, Compass Atom 500 FBL, BLADE NANO cpx
stark is offline        Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 08-26-2018, 03:18 PM   #22 (permalink)
Registered Users
 

Join Date: Feb 2017
Default

I'm trying to fix tail wags on my Logo 550 v3. so tired
Logo 550 tail wags (0 min 14 sec)
letandat20 is online now        Reply With Quote Quick reply to this message
Old 08-26-2018, 09:19 PM   #23 (permalink)
Registered Users
 
Posts: 1,659
 

Join Date: Mar 2011
Default

I think may be there is something wrong with the new batch of Logo helicopter (from 480 to 600/690)
My friends and I owned some old V1 and V2 Logo's without any issue, tail is rock solid from the start but then at our fiend new members have 1 Logo 480 and 1 Logo 550SX V3, both were purchased in 2018, has the same tail wag issue
I fly Logo since 2012/2013 and I never heard or gotten any issue with their tail. But then when my friends got those above Logo's, I tried to goggle the issue this year and found out there are a lot of people had the same issue.
Beside that, all the plastic parts seem not as good as my old Logo 500SE and 600SX V1. The frames now does not fit perfectly, when you assemble 2 left and right frames together as it needs you to push them harder to make them hook in together.
The edge of the plastic frame is not smooth like before and need to sand it with sand paper too.

Last edited by ddhuans; 08-28-2018 at 10:09 AM..
ddhuans is offline        Reply With Quote Quick reply to this message
Old 08-27-2018, 08:52 PM   #24 (permalink)
Registered Users
 
Posts: 161
Thread Starter Thread Starter
 

Join Date: Nov 2013
Default

I agree with you... I build the V2 last year... no big deal, just some tweaks on tail..... many issues on this V3 tail for me.

Well Finally i got it flying as I want.... After re-check and lot of parts changes I notice that the Sleeve on the tail slider was loose. And yes "I glue it". 🙂

For me, the thread on the plastic part wasn't tighten enough. 1 drop of CA, thread all way in, and now looks like the Gyro is finally finding the center.

I'm happy again, and my love for the Logos is back...

PS.: Nothing compares to this machine when U fly on Low RPMs.... What a beauty!!!
__________________
Robert
Queens, NY

Paypal Credit Team Pilot - Mastercard Team Pilot - Half of my Salary field rep.

Last edited by Moronta12; 08-28-2018 at 06:32 AM..
Moronta12 is offline        Reply With Quote Quick reply to this message
Old 08-28-2018, 02:56 AM   #25 (permalink)
Registered Users
 
Posts: 375
 
My HF Map location
Join Date: Apr 2011
Default

Glad, you got it fixed . But I couldn't figure out what part you were referring to when you say "Slave on the tail slider".


Could you please circle the part in the attached picture so it can help others? Thanks.
Attached Thumbnails
Click image for larger version

Name:	logo550_tail.jpg
Views:	131
Size:	68.6 KB
ID:	754423  
__________________
-roger
LOGO 550SX, Compass Atom 500 FBL, BLADE NANO cpx
stark is offline        Reply With Quote Quick reply to this message
Old 08-28-2018, 06:29 AM   #26 (permalink)
Registered Users
 
Posts: 161
Thread Starter Thread Starter
 

Join Date: Nov 2013
Default Here is

On the bench it was looking strong and on place... Once I flew it use to get loose.

__________________
Robert
Queens, NY

Paypal Credit Team Pilot - Mastercard Team Pilot - Half of my Salary field rep.
Moronta12 is offline        Reply With Quote Quick reply to this message
Old 08-28-2018, 06:03 PM   #27 (permalink)
Registered Users
 
Posts: 7,402
 

Join Date: Jun 2009
Location: Edmonton, Alberta, Canada
Default

I had a 550 and a 600SE. I was chasing tail wag issues right from the start. I changed to a Speedix tail case because I like them better. I changed the servos. I then changed the blade grips to Quick UK. When I did that the tail wag improved significantly.... but still a tiny little... but greatly improved. This is the main reason I sold the 550 and 600SE. I really like the Logo,s but the he tail wag is a pain in the..... I really want a 690 but it makes me hesitate to buy another. (I really want another one. They are so light and can fly so nice.) Maybe someday if Mikado fixes the issue. There are numerous posts about the tail problems. Too bad.
__________________
Synergy- 696, E5SS, E5S, Soxos- 600, 2 -Strike 7s, VControl T, VBar, Egodrift, Scorpion, Tribunus ESC, MKS, Savox, Hitec

Last edited by Freeskiken; 08-28-2018 at 08:28 PM..
Freeskiken is offline        Reply With Quote Quick reply to this message
Old 08-29-2018, 12:09 PM   #28 (permalink)
Registered Users
 

Join Date: Feb 2017
Default

Hopefully Mikado read this and come up with a better solution
Freeskiken likes this.
letandat20 is online now        Reply With Quote Quick reply to this message
Old 08-31-2018, 12:36 PM   #29 (permalink)
Registered Users
 

Join Date: Feb 2017
Default

I think I have found some differences between pitch silder of v3 and v2

I have a Logo 550 v3 and stretch up to 550SE (with a 550Se boom and a blade blade RT 560mm) with an extremely tail wag

I borrowed my friend Pitch silder and Tail roto hub (include grip, thrust bearing and blade 95mm). Great, Tail work well, no wag. And then, I use my Pitch Silder and my friend's Tail Roto Hub, then the Tail wag come back. And then, I swap my Tail Rotor Hub and use my friend's Pitch Silder, the Tail wag are back again. This is crazy

Maybe I have to replace both Pitch silder and Tail roto hub


You can see the difference between Pitch Slider V2 and V3. Ball on v2 can rotate and bearings can be different with v3



letandat20 is online now        Reply With Quote Quick reply to this message
Old 08-31-2018, 02:45 PM   #30 (permalink)
Registered Users
 
Posts: 7,402
 

Join Date: Jun 2009
Location: Edmonton, Alberta, Canada
Default

If you have to change the tail pitch slider and the whole tail hub...what do you change it to ? If you get another Logo one it may be back to the same problem. I wonder if you tried another brand ? Would a Synergy E7 tail slider and tail hub fit ?
__________________
Synergy- 696, E5SS, E5S, Soxos- 600, 2 -Strike 7s, VControl T, VBar, Egodrift, Scorpion, Tribunus ESC, MKS, Savox, Hitec
Freeskiken is offline        Reply With Quote Quick reply to this message
Old 08-31-2018, 03:47 PM   #31 (permalink)
Registered Users
 

Join Date: Oct 2010
Default

Problems,problems.....i have said it before and i say It again...MIKADO PLEASE LISTEN: come with a little brother of źnew logo700╗
Moronta12 likes this.
LOGO800 is offline        Reply With Quote Quick reply to this message
Old 08-31-2018, 05:46 PM   #32 (permalink)
Registered Users
 

Join Date: Jan 2008
Default

If you tweak that hub n brass slider down to tight you will kill those little bearings. All ball link should be free sizing maybe necessary. Also be sure the the tail hub pitch links are free and the molded balk on the tail blade holder need to be super free

Looking at you second pic can't tell if you tail blades are leading or trailing controlled ? Think suppose to be trailing edge controlled .
__________________
Trex_600n,Trex_500,MR25,MikadoLoGo5003D_KDE,CastleCreations,Ys,JR XG8,Sab Goblin 380/X_Nova/Bk_Servos, JR TagsMini//Sab Goblin 500Pulse Edition, Sab Goblin570Carbon_SABUSA_X_Nova_BkServos_KDE,RJX-Swash,JR-SPG-Tail/TagsMini_JRX-Bus.
JEEPWORLD2002 is offline        Reply With Quote Quick reply to this message
Old 08-31-2018, 06:03 PM   #33 (permalink)
Registered Users
 
Posts: 7,402
 

Join Date: Jun 2009
Location: Edmonton, Alberta, Canada
Default

The manual shows it leading edge.
Attached Thumbnails
Click image for larger version

Name:	Logo 600SX Tail .jpg
Views:	161
Size:	50.6 KB
ID:	754740  
__________________
Synergy- 696, E5SS, E5S, Soxos- 600, 2 -Strike 7s, VControl T, VBar, Egodrift, Scorpion, Tribunus ESC, MKS, Savox, Hitec
Freeskiken is offline        Reply With Quote Quick reply to this message
Old 08-31-2018, 06:04 PM   #34 (permalink)
Registered Users
 
Posts: 7,402
 

Join Date: Jun 2009
Location: Edmonton, Alberta, Canada
Default

Try the MSH thrust bearings like Stark. See if it works.
__________________
Synergy- 696, E5SS, E5S, Soxos- 600, 2 -Strike 7s, VControl T, VBar, Egodrift, Scorpion, Tribunus ESC, MKS, Savox, Hitec
Freeskiken is offline        Reply With Quote Quick reply to this message
Old 08-31-2018, 06:05 PM   #35 (permalink)
Registered Users
 
Posts: 7,402
 

Join Date: Jun 2009
Location: Edmonton, Alberta, Canada
Default

Also Quick UK makes metal Tail Blade Grips for the Logo 600 that helped mine.
__________________
Synergy- 696, E5SS, E5S, Soxos- 600, 2 -Strike 7s, VControl T, VBar, Egodrift, Scorpion, Tribunus ESC, MKS, Savox, Hitec
Freeskiken is offline        Reply With Quote Quick reply to this message
Old 08-31-2018, 09:44 PM   #36 (permalink)
Registered Users
 

Join Date: Oct 2010
Default

Quote:
Originally Posted by Freeskiken View Post
Try the MSH thrust bearings like Stark. See if it works.
Unfortunately, they don't provide parts for that heli anymore - go over and check out the mini protos forum...
__________________
Agile 5.5, Logo 550sx, X5, Oxy 3, Trex 450proV2, 250DFC #309
nflanagin is online now        Reply With Quote Quick reply to this message
Old 09-01-2018, 08:58 AM   #37 (permalink)
Registered Users
 
Posts: 2,449
 
My HF Map location
Join Date: Apr 2008
Default

Recently replaced the pitch slider on my oldest logo that started life as a 600se (its a 690 now). Anyway I noticed two things about the new pitch slider assembly, the bearings were notchy so I applied a few drops of triflow to each side and after spinning it around for a while it was butter smooth..

The second thing was the bore of the brass slider was not polished enough. How I test for this is with the slider on the tail shaft and no hub or link attached push the slider against the shaft and move it, should not have any sign of stick/slip but it did. Very small raised machining marks would tend to make this happen. So roll up some 1000 grit wet/dry sand paper and work it in the bore a little then test again. Also can use the tail shaft itself to polish the brass by pressing it and working it quickly back and forth. Eventually it will be free of stick/slip and good to go.
__________________
Wayne

Logo 480 / Logo 600sx / Logo 690 / Logo 700 / Vbar Control
Mentalic is offline        Reply With Quote Quick reply to this message
Old 09-03-2018, 08:11 AM   #38 (permalink)
Registered Users
 
Posts: 1,451
 

Join Date: Apr 2009
Default

Quote:
Originally Posted by nflanagin View Post
Unfortunately, they don't provide parts for that heli anymore - go over and check out the mini protos forum...
Maybe so, but they're still in stock in some places. Now you've said that, I'm thinking about buying some seeing as I want a Logo 550 at some point.

The other option is to see if you can find a bearing stockist that has 4x8x3.5 thrust bearings.
__________________
Current fleet: Goblin Thunder Sport, Trex 700L, Logo 600, Specter 700, TDR, HiSKY HCP100S - Vbar Control - 5" and 3" FPV racing quads and a Taranis
Next heli(s): No idea. I have everything I wanted.
Bigpops is online now        Reply With Quote Quick reply to this message
Old 09-03-2018, 09:46 AM   #39 (permalink)
Registered Users
 
Posts: 7,737
 

Join Date: Apr 2016
Location: Michigan
Default

Has anyone with this issue contacted mikado? What was the response?
They also have their own forum. Maybe try there?
Thickfog is online now        Reply With Quote Quick reply to this message
Old 09-07-2018, 11:40 AM   #40 (permalink)
Registered Users
 

Join Date: Feb 2017
Default

You can find the thrust bearing in the replacement part of the Trex 450 HS1268 or Tarot 450 clone TL48015 .
letandat20 is online now        Reply With Quote Quick reply to this message
Reply




Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the HeliFreak forums, you must first register.
Please enter your desired user name, your REAL and WORKING email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself. Use a real email address or you will not be granted access to the site. Thank you.
Email Address:
Location
Where do you live? ie: Country, State, City or General Geographic Location please.
Name and Lastname
Enter name and last name here. (This information is not shown to the general public. Optional)
Helicopter #1
Enter Helicopter #1 type and equipment.
Helicopter #2
Enter Helicopter #2 type and equipment.
Helicopter #3
Enter Helicopter #3 type and equipment.
Helicopter #4
Enter Helicopter #4 type and equipment.

Log-in


Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On




Copyright © Website Acquisitions Inc. All rights reserved.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.

SEO by vBSEO 3.6.1