Fun, Learning, Friendship and Mutual Respect START  HERE


Unregistered
Go Back   HeliFreak > R/C Helicopter Support > Blade Helicopters (eFlite) > Blade mCPS


Blade mCPS Blade mCPS Helicopters Information and Help


Reply
 
LinkBack Thread Tools Display Modes
Old 01-21-2019, 05:14 PM   #1 (permalink)
Registered Users
 

Join Date: Jan 2019
Location: Seattle WA
Default New to flying my blade mcps heli and having trouble can anyone help w/ diagnose's

Hi everyone I've never used or been on a form before but I'm kinda desperate for help.

I have anew blade mcps heli and I've flown it inside my large open garage 5 times for a total of about an hour. It came with two 210 may 1s 3.7v batteries which I have been recharging. The problem I'm having is after connecting the remote to the heli and pushing down on the left control it starts to turn the blades but then when I pull down on the left thumb control it basically won't take off. It's like it doesn't have enough power even though it seems to be spinning the blade fast enough. Nothing looks bent or broken it just won't take off or even hover. Any ideas as to what I should try or look for?
heliofatime! is offline        Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 01-21-2019, 06:51 PM   #2 (permalink)
Registered Users
 
Posts: 6,211
 

Join Date: Sep 2018
Location: Snohomish, WA
Default

I’m a bit confused by the issue you’re having.
What happens if you push UP on the left stick instead of down?

Can you post a video to YouTube and then link it here?
__________________
Brian Oxy 2 & 4 Max S2 & CP X 150X iK2N/Brain2/Spirit Horus X10S OpenTX AccuRC
xoexoe is online now        Reply With Quote Quick reply to this message
Old 01-21-2019, 08:02 PM   #3 (permalink)
Registered Users
 

Join Date: Jan 2016
Default

Quote:
Originally Posted by heliofatime! View Post
Hi everyone I've never used or been on a form before but I'm kinda desperate for help.

I have anew blade mcps heli and I've flown it inside my large open garage 5 times for a total of about an hour. It came with two 210 may 1s 3.7v batteries which I have been recharging. The problem I'm having is after connecting the remote to the heli and pushing down on the left control it starts to turn the blades but then when I pull down on the left thumb control it basically won't take off. It's like it doesn't have enough power even though it seems to be spinning the blade fast enough. Nothing looks bent or broken it just won't take off or even hover. Any ideas as to what I should try or look for?

should be pushing up on the stick if you are and it is still not taking off then check to see if main gear moved down on the shaft. if you crashed it , it might need to be pushed back up on the shaft.
captjack01 is offline        Reply With Quote Quick reply to this message
Old 01-24-2019, 02:57 AM   #4 (permalink)
Registered Users
 
Posts: 234
 

Join Date: Oct 2017
Default

What did u mean by pushing down left control the blades start spinning? What left control?

And you need to push up left thumb stick to take off. And what flight mode are you in? Or what color is the led in the mcps? Seems to me yours has a collective pitch set up issue

Sent from my EVA-L09 using Tapatalk
koopa137 is offline        Reply With Quote Quick reply to this message
Old 02-22-2019, 12:10 AM   #5 (permalink)
Registered Users
 

Join Date: Oct 2018
Default

Here's some issues I ran into when I was newer which might apply to you:
- what transmitter are you using? if it's not the RTF version you to have to pull down AND RIGHT on the left stick when binding. I made that error and the heli was crazy and took me 2 weeks to figure out (both red and blue lights were on).
- If you crashed it, the gear on the shaft (white one) is probably loose. Happened to me every time I crashed. There shouldn't be any play at all in the shaft between the gear and the shaft collar. If there is, take the gear off, line up the notch with the notch on the shaft and press down. Takes a bit of force. if there's play the heli won't take off.
- Now there's a sneaky one, during the crash, you might have popped the swash plate from the anti rotation bracket... this one is sneaky as the heli will barely hover and it's so easy to miss. pull back a bit on the anti rotation bracket and insert the swash plate pin back.
- another thing with crashes that I've changed multiple times is the blade grips. Those things are so weak. they won't break, but the bearing inside falls apart very easy. I've changed so many... If you hold the head and you feel the grip and blade wobble a lot, you broke a bearing and it'll affect the blade angle when applying collective.

Hope that helps!
flyingfadi is offline        Reply With Quote Quick reply to this message
Reply




Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the HeliFreak forums, you must first register.
Please enter your desired user name, your REAL and WORKING email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself. Use a real email address or you will not be granted access to the site. Thank you.
Email Address:
Location
Where do you live? ie: Country, State, City or General Geographic Location please.
Name and Lastname
Enter name and last name here. (This information is not shown to the general public. Optional)
Helicopter #1
Enter Helicopter #1 type and equipment.
Helicopter #2
Enter Helicopter #2 type and equipment.
Helicopter #3
Enter Helicopter #3 type and equipment.
Helicopter #4
Enter Helicopter #4 type and equipment.

Log-in


Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On




Copyright © Website Acquisitions Inc. All rights reserved.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.

SEO by vBSEO 3.6.1