Fun, Learning, Friendship and Mutual Respect START  HERE


Unregistered
Go Back   HeliFreak > R/C Helicopter Support > Blade Helicopters (eFlite) > Blade Nano S2



Like Tree11Likes
Reply
 
LinkBack Thread Tools Display Modes
Old 04-23-2019, 07:13 PM   #1 (permalink)
Registered Users
 
Posts: 191
 

Join Date: Nov 2010
Question Ideas about brushless upgrade

Hello!
Has anybody tried to upgrade Nano S2 to brushless main motor?
I remember stock BLH3325 upgrade did not work with nCP S out of the box, but there was a place on the control board where you could solder BLS ESC signal wire to get proper "old fashion" signal so both stock and third party upgrades will work. See the thread: https://www.helifreak.com/showthread.php?t=720967
I wonder if there is something similar with new S2? Has anybody tried to find soldering spot for ESC signal wire on the new board?
Tigron is offline        Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 04-23-2019, 07:32 PM   #2 (permalink)
Registered Users
 
Posts: 2,955
 

Join Date: Apr 2011
Location: Fullerton, CA
Default

I did a write-up about installing the HH brushless into the CPS:

Installing a brushless motor into a Nano CPS

My assumption is that similar methods can be used for the Nano S2. I have the HH brushless right here, in hand, but I haven't tried installing it yet. I have been pleasantly surprised at how well the stock brushed motor is working in my S2. But once this motor dies (probably in a couple of weeks, lol), I'll probably opt to install the brushless.
__________________
navigator2011
Fusion 180 / Blade 150S / Backup 150S / Blade mCPX BL2 / Align Trex 150X / Spektrum DX9.
Navi's Channel
navigator2011 is offline        Reply With Quote Quick reply to this message
Old 04-26-2019, 11:16 AM   #3 (permalink)
Registered Users
 

Join Date: Dec 2011
Default

There are discrepant experiences concerning the HH brushless upgrade for the nano CPX in the Nano S2. I could not get mine to work whereas another member on RCG could. If you do not have the kit already, it is best that you wait for more feedback on this.
zadaw is offline        Reply With Quote Quick reply to this message
Old 04-26-2019, 11:48 AM   #4 (permalink)
Registered Users
 
Posts: 2,955
 

Join Date: Apr 2011
Location: Fullerton, CA
Default

Hi Zadaw, thanks. That's basically what I've been doing so far. Besides, the stock brushed motor has been working pretty well in the Nano S2. I don't know if they've tuned things differently or something, but this motor never worked this well in the CPS.
__________________
navigator2011
Fusion 180 / Blade 150S / Backup 150S / Blade mCPX BL2 / Align Trex 150X / Spektrum DX9.
Navi's Channel
navigator2011 is offline        Reply With Quote Quick reply to this message
Old 04-29-2019, 10:15 AM   #5 (permalink)
Registered Users
 

Join Date: Dec 2016
Default

Quote:
Originally Posted by navigator2011 View Post
Hi Zadaw, thanks. That's basically what I've been doing so far. Besides, the stock brushed motor has been working pretty well in the Nano S2. I don't know if they've tuned things differently or something, but this motor never worked this well in the CPS.
I saw something that peaked my interest. Rakon has released some custom parts for the S2 including a custom frame. What looks even more interesting is that is appears to share the same aluminum motor mount that the CPX did. Rakon was kind enough to make an optional motor mount for that frame to fit motors other than the stock 8mm. That means a brushless outrunner set up like the HP03SPE could be a possibility for someone looking to turn the S2 into a savage in the air.


https://www.rakonheli.com/collection...20130845786166
Chris1683 is offline        Reply With Quote Quick reply to this message
Old 05-11-2019, 03:36 AM   #6 (permalink)
Registered Users
 

Join Date: Dec 2011
Default

I bought another Nano S2 and tried the Nano CPX brushless conversion again. Again that won't work either. However, it will work with no problems on my Nano CPS.
zadaw is offline        Reply With Quote Quick reply to this message
Old 05-11-2019, 10:00 AM   #7 (permalink)
Registered Users
 
Posts: 2,955
 

Join Date: Apr 2011
Location: Fullerton, CA
Default

Curious, for sure.

Are you connecting the orange wire to the brushed motor socket?
__________________
navigator2011
Fusion 180 / Blade 150S / Backup 150S / Blade mCPX BL2 / Align Trex 150X / Spektrum DX9.
Navi's Channel
navigator2011 is offline        Reply With Quote Quick reply to this message
Old 05-11-2019, 01:18 PM   #8 (permalink)
Registered Users
 

Join Date: Dec 2016
Default

I have a few of the brushless upgrades that I will be testing out and installing within the next few days. I will do a write up on it once it’s installed with photos.
Chris1683 is offline        Reply With Quote Quick reply to this message
Old 05-13-2019, 10:47 AM   #9 (permalink)
Registered Users
 

Join Date: Dec 2011
Default

The orange wire was connected to the motor socket. The motor will run, but it will just fizzle out after a few moments. I have very bad luck with electronics and it could be the ESC which is faulty.
zadaw is offline        Reply With Quote Quick reply to this message
Old 05-13-2019, 10:01 PM   #10 (permalink)
Registered Users
 
Posts: 191
Thread Starter Thread Starter
 

Join Date: Nov 2010
Default

Quote:
Originally Posted by Chris1683 View Post
I have a few of the brushless upgrades that I will be testing out and installing within the next few days. I will do a write up on it once it’s installed with photos.
Looking forward to hear the results soon! I have one extra brushless upgrade for my good old nCP X, but waiting for one proven good result to place an order on S2.
Thank you in advance!
Tigron is offline        Reply With Quote Quick reply to this message
Old 05-14-2019, 02:30 PM   #11 (permalink)
Registered Users
 
Posts: 2,955
 

Join Date: Apr 2011
Location: Fullerton, CA
Default

Seems like my main motor is getting "tired" and may be nearing it's end. I may be installing the brushless in the S2 sooner than I thought.
__________________
navigator2011
Fusion 180 / Blade 150S / Backup 150S / Blade mCPX BL2 / Align Trex 150X / Spektrum DX9.
Navi's Channel
navigator2011 is offline        Reply With Quote Quick reply to this message
Old 05-14-2019, 03:23 PM   #12 (permalink)
Registered Users
 

Join Date: Dec 2016
Default

Quote:
Originally Posted by Tigron View Post
Looking forward to hear the results soon! I have one extra brushless upgrade for my good old nCP X, but waiting for one proven good result to place an order on S2.
Thank you in advance!
My parts will be in tomorrow. I’ll have it done either tomorrow or Thursday the latest.
acidkindred and navigator2011 like this.
Chris1683 is offline        Reply With Quote Quick reply to this message
Old 05-15-2019, 01:43 PM   #13 (permalink)
Registered Users
 

Join Date: Dec 2016
Default

So I installed the HH brushless (I opted for direct soldering of the power wires and I installed an original plug style connector for the motor signal wire.

Works perfectly in idle up 1 and idle up 2. Normal mode is a bit odd (probably due to the Stability Z parameters). The motor acts a little wonky and speeds up and slows in a pattern. After work I will tinker a bit more and see if I can figure out the Normal mode a bit more.
xoexoe likes this.
Chris1683 is offline        Reply With Quote Quick reply to this message
Old 05-15-2019, 01:51 PM   #14 (permalink)
Registered Users
 
Posts: 2,955
 

Join Date: Apr 2011
Location: Fullerton, CA
Default

That's great news--thanks for posting!!!

So, is Idle2 balls to the wall, no matter what's in the tx?
__________________
navigator2011
Fusion 180 / Blade 150S / Backup 150S / Blade mCPX BL2 / Align Trex 150X / Spektrum DX9.
Navi's Channel
navigator2011 is offline        Reply With Quote Quick reply to this message
Old 05-15-2019, 02:02 PM   #15 (permalink)
Registered Users
 
Posts: 8,165
 

Join Date: Sep 2018
Location: Snohomish, WA
Default

Quote:
Originally Posted by Chris1683 View Post
So I installed the HH brushless (I opted for direct soldering of the power wires and I installed an original plug style connector for the motor signal wire.

Works perfectly in idle up 1 and idle up 2. Normal mode is a bit odd (probably due to the Stability Z parameters). The motor acts a little wonky and speeds up and slows in a pattern. After work I will tinker a bit more and see if I can figure out the Normal mode a bit more.
Pictures please!
navigator2011 likes this.
__________________
Brian — XLP 520, YGE 135LVT, IKON2 — Oxy 4 Max, YGE 65LVT, Brain2 — Oxy 2, YGE 35LVT, µSpirit — XK K110 — Horus X10S & OpenTX —
xoexoe is offline        Reply With Quote Quick reply to this message
Old 05-15-2019, 02:53 PM   #16 (permalink)
Registered Users
 

Join Date: Dec 2016
Default

This is still a very rough install. I will clean it all up and heat shrink it once I tweak it a little more for normal mode:

Idle 2 i have set up as a flat 100% throttle curve. Idle Up 1 I had at 80%. When in normal mode and holding it in hand, it increases the throttle smoothly and follows a nice curve. When actually in the air however it starts to behave oddly in Normal mode - again probably due to the stability Z trying to maintain altitude control. I have a few more ideas I will test out later tonight and I’ll post any updates.



Chris1683 is offline        Reply With Quote Quick reply to this message
Old 05-15-2019, 04:05 PM   #17 (permalink)
Registered Users
 
Posts: 2,955
 

Join Date: Apr 2011
Location: Fullerton, CA
Default

Oh, sweet! Thanks for the pics! I look forward to hearing about your tweaks.

I may go ahead and install the HH brushless into my S2 this weekend. Stock brushed motor is getting pretty weak.
__________________
navigator2011
Fusion 180 / Blade 150S / Backup 150S / Blade mCPX BL2 / Align Trex 150X / Spektrum DX9.
Navi's Channel
navigator2011 is offline        Reply With Quote Quick reply to this message
Old 05-15-2019, 11:30 PM   #18 (permalink)
Registered Users
 

Join Date: Dec 2016
Default

I did some more testing and my original thought was confirmed. The motor will run perfectly in Idle Up 1 and 2 but Normal Mode will present an issue. Because of the altitude stabilization, the S2 tries to alter the motor speed based on how fast it is ascending or descending. It makes Normal mode into Abnormal mode with the brushless ESC.

To see what I mean, spool up your S2 in your hand in normal mode and keep it at a constant low speed. Then move the S2 up and down in your hand. You will see it changes motor speed without any input from you. This is what you will see if you use the HH brushless kit.

On a positive note, it means you can have brushless in the S2. On a negative, don’t plan on using brushless with Normal Mode. It will most likely only be good for IU 1+2.
Chris1683 is offline        Reply With Quote Quick reply to this message
Old 05-16-2019, 12:52 AM   #19 (permalink)
Registered Users
 
Posts: 2,955
 

Join Date: Apr 2011
Location: Fullerton, CA
Default

Hey, thanks thoroughly testing and reporting your findings!

Honestly, I don't care at all about Normal mode, haven't even tried it with the stock motor. Idle 1 might also be dead to me since Safe won't allow flipping and inverted flight.

But Idle 2 with the brushless will great! I look forward to not having to cope with the decreasing head speed of the brushed motor.
__________________
navigator2011
Fusion 180 / Blade 150S / Backup 150S / Blade mCPX BL2 / Align Trex 150X / Spektrum DX9.
Navi's Channel
navigator2011 is offline        Reply With Quote Quick reply to this message
Old 05-16-2019, 07:13 AM   #20 (permalink)
Registered Users
 
Posts: 191
Thread Starter Thread Starter
 

Join Date: Nov 2010
Default

Thanks for the feedback!
About brushless in normal mode. It looks like altitude hold may work like a governor. When you set it up did you have a smooth curve 0-25-50-75-100? Try using flat shelf, like I have in my helis with governor 0-50-80-80-80. Adjust values to avoid spool up kicks.
Tigron is offline        Reply With Quote Quick reply to this message
Reply




Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the HeliFreak forums, you must first register.
Please enter your desired user name, your REAL and WORKING email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself. Use a real email address or you will not be granted access to the site. Thank you.
Email Address:
Location
Where do you live? ie: Country, State, City or General Geographic Location please.
Name and Lastname
Enter name and last name here. (This information is not shown to the general public. Optional)
Helicopter #1
Enter Helicopter #1 type and equipment.
Helicopter #2
Enter Helicopter #2 type and equipment.
Helicopter #3
Enter Helicopter #3 type and equipment.
Helicopter #4
Enter Helicopter #4 type and equipment.

Log-in


Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On




Copyright © Website Acquisitions Inc. All rights reserved.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.

SEO by vBSEO 3.6.1